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Chapter 1

Introduction

QCAD is a computer application for technical drawings such as mechanical plans or floorplans.
The CAD in QCAD stands for Computer-Aided Drafting or Computer-Aided Design. QCAD is
one of many applications on the market that provides this kind of functionality. However, if you
have tried other popular CAD systems before, you will likely have realized that these systems are
usually very complex, difficult to learn and for most private users and small businesses almost
unaffordable. This is because CAD has long been a technology that was only used by major in-
dustrial companies, universities and governments and most CAD manufacturers still exclusively
target these groups of users.

QCAD is an alternative solution that is available to everyone who is interested in CAD. QCAD is
not only a lot easier to use than other traditional CAD systems, it also runs on most modern op-
erating systems including Windows, macOS and Linux. This means that with QCAD you are not
locked in on any particular system and you can share your drawings with friends and companies
who happen to use another system. Despite all these advantages, QCAD is also one of the most
affordable complete CAD packages on the market today.

Although QCAD is easy to use compared to other CAD solutions, using a CAD system in general
is not as trivial as using a word processor or as browsing the Internet. Simply learning how to use
the various tools and features of QCAD is not enough to create professional looking technical
drawings. You also have to become familiar with the fundamental concepts of technical drafting
in general and with some CAD specific concepts such as layers, blocks and precision tools. These
concepts are what separates a CAD system from a simple drawing or presentation software.

This book will not only help you to get started with QCAD immediately, it will also teach you
the basics of technical drafting and CAD along the way.

Target Audience

It is only natural to feel insecure about starting to use a CAD system. CAD systems have been
used to design some of the most complex machines and buildings of our time. However, there
is no reason to think that CAD systems are for experts only. QCAD in particular was designed
with beginners, students and home users in mind. This book targets the same audience. It will
help you to get started with CAD and QCAD even if you have a non-technical background and
technical drafting and CAD are both new to you.
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What you do need are some basic computer skills before you get started with this book. It helps
if you already know how to use other applications on your computer and you should be familiar
with the basic concept of folders and files on the operating system of your choice.

QCAD is a generic CAD system which means that it can be used for any type of technical draw-
ing. QCAD is not specialized in mechanical drafting, architecture, landscaping, geographical in-
formation systems, schematics or any other specific area of use. This book provides examples
from various different backgrounds in which CAD systems can be used.

Structure of This Book

This book is divided into several parts that are meant to be studied or worked through in sequence.

Part IV describes the most common construction and editing tools of QCAD in detail with step
by step instructions and examples. You might just want to skim read through this part to get an
idea about the tools QCAD has to offer. You can always come back to these chapters later and
use them as a reference while using QCAD in your projects.

The following is a brief overview of what is contained in each part.

Part II: First Steps with QCAD

In this part you will install QCAD on your computer and start it for the first time. You will learn
how to use and adjust the application window and you will already create and print your first
simple drawing.

Part III: Basic CAD Concepts

This part introduces the fundamental CAD concepts you will be confronted with whenever you
work with a CAD system. You will learn how to navigate in your drawing, understand what
coordinates are and work with layers to organize your drawing. Along the way you will get to
know some first drawing and modification tools and learn how QCAD supports you to create
precise drawings.

Part IV: Drawing and Editing with QCAD

In this part all drawing and editing tools are described in detail. This part also covers the wide
range of selection tools QCAD offers to select entities before changing them.

Part V: Blocks

Groups of entities are called blocks in QCAD. This part introduces blocks and explains when and
how to use them. The part library (or symbol library) is also introduced in this part.
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Part VI: Import, Export and Printing

This part shows ways how you can import and export data with QCAD for example to embed
your drawing in your favorite word processor or presentation program or to share drawings with
other people over the Internet. This part also explains the printing tools of QCAD in detail.

Part VII: Projections

Unless you are drawing mainly schematics with QCAD, your drawings will most likely show
two-dimensional views of three-dimensional objects. This part guides you through the process
of creating two-dimensional drawings that provide enough information to describe three-dimen-
sional objects.

How to use this Book

This book offers hands-on study material for many topics. When working through the examples,
make sure that you have a computer at hand to try out things and to experiment beyond the scope
of the examples.

Prerequisites

The most important prerequisite for this basic course is your own motivation to learn how to use
a CAD system and how to handle QCAD. A specific project which you are planning to realize
is probably the best motivation to keep you going. If you don't have such a project in mind, you
might want to define one right now. This can be anything from designing a bird house to drawing
a floorplan of your house.

Software Requirements

To follow the examples you will of course also need the QCAD software. Fortunately, QCAD is
one of the most economic CAD packages available. For information about QCAD, a price list
and free downloads, please refer to its website at: http://www.qcad.org

Hardware Requirements

QCAD runs on any reasonably modern hardware configuration. Having a screen of 17" or above
is desirable but not a minimum requirement.

The only thing that leaves you with a real disadvantage is a mouse with only one button or one
without a mouse wheel. In QCAD you can use the mouse wheel to quickly navigate around in
the drawing. If your mouse does not have a wheel you will still be able to follow along but you
will not be as efficient. A two or three button mouse with a mouse wheel is therefore strongly
recommended if you are to become a regular QCAD user.
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If you are using a Macintosh computer, you might not be used to a three button mouse since
Apple mice traditionally come with only one button. Nevertheless, three button mice with mouse
wheels also work fine under macOS and generally increase your productivity, not only when
working with QCAD.

Instead of a mouse, you can also use a graphics tablet with a pen. Most CAD users find a tablet
more efficient or ergonomic than a mouse. Since you can access all features of QCAD with a
tablet and pen, a mouse is not required in this case.

From Manual Drafting to CAD

If you have experience in manual drafting you might wonder what this book has to teach to you.
Any prior experience with technical drafting will give you a head start. But note that although
the end products of manual drafting and CAD are usually almost the same, there are some fun-
damental differences between the two approaches. The most important ones are outlined below.

Modifications

Every draftsman knows the fear of making a mistake in an otherwise perfect drawing. The more
complex the drawing becomes, the more frustrating such a mistake can be. But even once the
drawing has been finished there is no guarantee that there will not soon be a request for modifi-
cation. Figure 1-1 shows how a drawing might need to be modified. In manual drafting the part
at the top would most likely have to be re-drafted to create the new drawing at the bottom. In a
CAD system, this modification is easily done in a few seconds using the stretch tool.

Figure 1-1: Changing existing drawings is one of the strengths of a CAD system.
The drawing at the top can be changed into the one at the bottom with a few clicks.

Precision

Manual drawings are never 100% precise. This is not really a problem since the precise mea-
surement is contained as textual information in the dimensions of the drawing. A dimension is a
drawing element that indicates the exact measurement of something in the drawing, for example
how long a part is. A dimension might indicate that a line is 100mm long even if it is only 98mm
long on the paper. When working with a CAD system there are no such arbitrary errors. The
geometry of every element of a drawing is exactly defined. This is something beginners often
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struggle with. You might think that if a line on your computer screen looks horizontal it must be
horizontal. This is far from true. A horizontal line on paper might serve its purpose if it looks
horizontal to the viewer, but CAD systems deliver far better precision. A horizontal line in a CAD
system is truly horizontal. Similarly, if two lines form a corner, they form exactly a corner. That
means that there is no gap between the end points of the lines. This is where CAD also differs
from most other computer applications you might have used so far. In a painting program, pre-
sentation application or word processor you are usually satisfied if the result looks good on the
screen or in the printout. The precision of a CAD drawing goes far beyond that.

There are many reasons for the extreme precision of CAD systems like QCAD, but the most
important one for you at this point is that lack of precision leads to bad results which are hard
to correct. Creating a precise drawing from the start is far less tedious and saves you a lot of
work in the end.

While CAD systems support you to create precise drawings, they do not prevent you from creating
imprecise drawings. You will know that you are about to work imprecisely when you are trying
really hard to position the mouse pointer "exactly" at a certain position or if you move your face
very close to the screen to check if your drawing looks precise. These are signs that you are doing
something wrong and you should find out how the CAD system can support you in what you
are trying to achieve.

Especially if you are a perfectionist, you will very soon appreciate the precision of a CAD system.
In fact, being a perfectionist is a good qualification for any CAD draftsperson.

Drawing Scale

In manual drafting, you would usually work with a fixed drawing scale. To fit the floorplan of
your house on paper you could for example define a drawing scale of 1:100. This means that an
object that is one meter (about 3.3 feet) long would be drawn on paper as an object that is one
centimeter (about 0.4 inch) long, i.e. 100 times smaller. On the other hand, a very small object
such as a mechanical part of a wrist watch could for example be drawn at a scale of 10:1 to make
sure that every detail of it is well visible on paper.

In CAD there are no such drawing scales. In other words, the drawing scale is always 1:1 or
real size. No matter how small or big the object is you are drawing, you will always construct it
exactly in its original size. In a CAD system you can create a plan of our universe in real size.
One reason for that is that in a CAD system you are not restricted to a particular paper size. Your
drawing area is virtually unlimited.

Of course when you print your drawing on paper, the CAD system can scale it up or down for
you so it fits on the paper size your printer uses.

Repetitive Work

With a CAD system, you will never have to draw the same thing twice. For example to draw the
rotationally symmetric part shown at the right in Figure 1-2, the part shown at the left can be
rotated twice by 120 degrees to produce the rest of the drawing.
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Figure 1-2: A CAD system helps you to avoid repetitive work. In this exam-
ple, the drawing at the right can be easily created from the part at the left.

Many CAD systems go even one step further and allow the user to create entire drawings fully
automatically. The example drawing shown in Figure 1-2 could be created automatically based
on a few parameters given by the user. In QCAD this can be done using the very powerful and
complete QCAD scripting interface. The scripting interface offers a programming language to
automate the construction of drawings. It is mainly interesting for programmers and advanced
users and therefore not covered by this book for beginners.

Auxiliary Lines

A similarity between manual drafting and CAD is the use of auxiliary lines. In Figure 1-3, both
the auxiliary construction at the left and the final drawing at the right can be constructed without
having to calculate any positions. Auxiliary lines often visualize how the edges and corners of
an object are defined.

Figure 1-3: Auxiliary construction lines at the left and the final drawing at the right.

In a CAD system, auxiliary lines are usually not deleted after they have served their purpose.
Instead they can be easily hidden when they are not needed, for example for the final printout.

Efficiency

As a beginner you might find that using a CAD system at first is far less efficient than using
pen and paper. It takes some practice to become faster with a CAD system than by hand. The
more complex and repetitive the drawing you are creating, the more the use of a CAD system
will pay off. A rectangle can be drawn very quickly by hand. If that rectangle is filled with a
simple pattern, a CAD system is already much more efficient. Now imagine that there is a circle
inside the rectangle which is not filled and make that two rectangles that are mirrored as shown
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in Figure 1-4. This simple drawing will already take significantly longer to create manually than
with a CAD system. And the quality of the manual drawing will most likely not be a match for
the printout from the CAD system.

Figure 1-4: Even simple drawings like this one are more efficient
to draw with a CAD system. For the computer, filling an area with
a pattern or mirroring a drawing only takes fractions of a second.

Planning

To become an efficient CAD user, you will have to plan your drawings before you start. Try to
identify identical, nearly identical or symmetrical parts early and don't hesitate to create auxiliary
lines that help you to define points and shapes.
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Chapter 2

Introducing the QCAD Application

Objective

In this chapter, you will

• get familiar with the QCAD application window,
• learn how to use menus,
• customize the user interface to better suit the needs of subsequent chapters,
• find out how to launch the integrated help system.

The First Start

When starting QCAD for the first time, it asks you what default unit and user interface language
you want to use (see Figure 2-1). Choose the unit 'Millimeters' for now. You can always change
this setting later in the application preferences or drawing preferences.

Figure 2-1: This dialog is only shown when starting QCAD for the first time.

The Application Window

After launching QCAD, the application window is shown (Figure 2-2).
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Figure 2-2: The QCAD application window.

Most of the application window consists of the drawing area which is used to display your draw-
ing. The drawing area contains many evenly arranged small dots. These are grid dots that have a
similar function like the horizontal and vertical lines of squared paper (or graph paper). You will
learn later in this book how to use this grid in QCAD.

The various toolbars, controls and other user interface components are arranged around the draw-
ing area.

Hands-on: Customizing the Application Window

As you might have noticed, some of the user interface components are not labeled in Figure
2-2. We will not use them for the first steps with QCAD. For this reason, please follow these
simple steps to hide them for now:

1. Click the menu View > Layer List to hide the layer list. Alternatively, you can also click
the button to toggle the layer list in the toolbar at the right:

2. The property editor is also shown initially (as separate window). Hide it with menu
View > Property Editor or by clicking this button:

3. Another component you will not need for the first few chapters is the command line. To
switch it off choose the menu View > Command Line or click the button to toggle the
command line:

4. The application window should now look as shown in Figure 2-3.
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Figure 2-3: The QCAD application window after hiding
the layer list, the property editor and the command line.
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Chapter 3

Using CAD Tools

Objective

In this chapter, you will

• create your first simple drawing,
• learn how to choose tools from the CAD toolbar,
• get an idea of what it means to create precise drawings with QCAD,
• learn how to save your drawings,
• print your first drawing.

The CAD Toolbar

At the left side of the QCAD application window you can find the CAD toolbar. The CAD toolbar
offers all CAD specific tools that you will use to draw and modify drawings. Unlike other toolbars,
the CAD toolbar always shows only those tools which currently make most sense to be used.
Right after the start of QCAD, the CAD toolbar shows the main tool set as shown in Figure 3-1.
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Figure 3-1: The CAD toolbar after starting QCAD.

Some of the buttons have a small black triangle arrow in the lower right corner. This indicates
that the button represents a whole category of tools. For example the line tools button (the button
at the top right in Figure 3-1) represents all tools for drawing lines.

Especially for beginners, the icons shown in the CAD toolbar might not be obvious to understand.
For this reason, QCAD shows you a hint if you move the mouse cursor on top of the button
without clicking a mouse button. These hints are often called tooltips. Figure 3-2 shows the tooltip
for the previously mentioned line button. Tooltips appear not only for the buttons in the CAD
toolbar but also for most other buttons in the QCAD application.

Figure 3-2: Tooltips provide useful information about the buttons in the CAD toolbar.

Starting Tools

As in most applications, there is more than one way to start a tool in QCAD. The application
menus list most available tools and offer a convenient way to browse through tools by name if
you are not sure what exactly you are looking for. Some frequently used tools can also be started
from the toolbars at the top. For CAD specific tools, the CAD toolbar at the left can be used to
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browse and start the various tools. If you are planning to use QCAD on a regular basis, it might be
worth learning the keycodes for some tools you use a lot. Keycodes in QCAD are combinations
of two or three letters you can type shortly after each other to launch a tool.

For example to start drawing lines, you can either choose the menu Draw > Line > Line from 2
Points or click the appropriate buttons in the CAD toolbar or you can press the L key on your
keyboard followed by the I key. Entering this keycode LI is the quickest way to starts the tool
to draw lines. Figure 3-1 and similar figures in subsequent chapters list these keycodes below
the tool name.

For the purpose of this book, we describe how to use the CAD toolbar on the left for CAD tools
and menus for some other tools. Keycodes are mentioned in tool overviews for your reference.

Correcting Mistakes

When working through the step by step instructions of this book, you should always keep the
following two tools in mind. There is no need to start from scratch if something goes wrong.

Undo

Menu: Edit > Undo
Keycodes: OO, Ctrl-Z (Mac: ⌘Z)

 
Whenever you are working with the CAD tools to draw, modify or delete objects you can use
the Undo tool to correct a mistake you have just made. You might for example draw a line at the
wrong position, accidentally delete something or drag a line to another location and then decide
you want to move it back to its original location. Simply choose the menu Edit > Undo or click
the undo button shown above to undo the mistake.

Redo

Menu: Edit > Redo
Keycodes: UU, Ctrl-Shift-Z (Mac: ⌘⇧Z)

 
Should you then decide that the modification was correct after all, there is also a Redo tool, the
counterpart of undo.

The Neutral State of QCAD

Menu: Edit > Reset
Keycode: QQ

 
After the start, QCAD is in its neutral state. That means that no special tool is active and QCAD
waits for you to click a menu or tool button to start a tool and start doing something.

If you get lost in a tool while working with QCAD, you can easily return to this neutral state by
clicking the arrow tool button at the top left.
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Alternatively, you can also click the right button of your mouse to return back to the neutral state
step by step. Depending how far you have progressed with a tool, you might have to click the right
mouse button more than once to fully return to the neutral state. The same can also be achieved
by hitting the Escape key on your keyboard a multiple times.

Hands-on: Drawing a Rectangle

The following instructions guide you through the complete procedure of drawing a simple rec-
tangle. You will probably not yet understand all steps involved but it is crucial that you success-
fully complete these steps since all CAD tools work in a similar way like the rectangle tool.

Figure 3-3: Choosing the CAD tools for draw-
ing rectangles and activating the Snap to grid tool.

1. Launch QCAD if it is not already running. QCAD shows its application window and
creates a new, empty drawing.

2. Before you start drawing anything, save this empty drawing to a file on your disk. To do
so, choose the menu File > Save As...
The dialog for saving a drawing is shown. The dialog automatically suggests a location
for your file. This location is usually not a bad place to start with. You might want
to use a sub-folder drawings in this location instead, but to keep things simple the
following steps assume that you use this default location for saving your drawing.

3. Type the filename example into the input field with the label File name, then click the
Save button to save the empty drawing. The dialog window closes and you are now
ready to start drawing.
Although is is not necessary to first save the empty drawing, it is good practice to do so
as it forces you to think about where you want to store the file before you start drawing.

4. Move your mouse cursor to the shape button as shown in Figure 3-3 at the left (1). Click
the left mouse button to show the shape tools (2).

5. Click the button with a rectangle on it as shown in Figure 3-3 (2). QCAD now knows
that you intend to draw a rectangle and shows the CAD toolbar with the snap tools.

6. Click the button with a grid on it as shown in Figure 3-3 (3).
7. Move the mouse cursor around in the drawing area. There are two things to notice:

• The mouse cursor has changed its shape and is now shown as a pair of cross hairs.
• There is a small yellow circle that follows the mouse cursor around whenever

you move it. This circle is not positioned exactly under the mouse cursor. It
‘snaps’ always to the grid point in the drawing area that is the closest to the mouse
cursor.
This yellow circle indicates what position QCAD is currently working with. The
exact position of the crosshair mouse cursor is irrelevant to QCAD as long as the
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yellow circle is in the correct place. In the previous step you have chosen to use
the grid for positioning (Snap to grid). QCAD is now automatically restricting the
options for choosing a position to the grid points.

8. Click somewhere into the drawing area. A little red circle with a cross appears at the
closest grid point as shown here:

You have now set the first corner of the rectangle you are about to draw. If you move
the mouse cursor around in the drawing area, you will see that QCAD draws a rectangle
from the chosen position to the grid point that is closest to the mouse cursor as shown
below:

Note that this rectangle is not yet part of your drawing and keeps changing whenever
you move the mouse. This is called a preview. QCAD uses these previews to show you
what would be drawn if you would click the mouse button at this point.

9. Move the mouse cursor until the rectangle that is shown is three grid spacings wide and
two grid spacings high. Your rectangle should look like that one in the figure above.

10. Click the left mouse button to set the second corner of the rectangle. This leaves you
with a drawing that looks like this:

The rectangle that is shown now, is a part of your drawing.
11. QCAD is ready to draw the next rectangle and waits for the first corner of the next

rectangle. Since we don't want to draw more rectangles, we will terminate this tool now.
To do so, click the right mouse button twice. If you don't have a right mouse button,
press the Escape or Esc key on your keyboard twice. The mouse cursor is back to
normal and the CAD toolbar shows the same tools as it did after starting QCAD. Your
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rectangle should still be visible. If that is not the case, you did something wrong and
you need to carefully repeat the steps 4 to 10.

12. Save your drawing by choosing the menu File > Save.

In the example you have just completed, you have used a tool called Snap to grid. As a result, the
corners of the rectangle are exactly aligned to the grid points. Snap tools are a central concept of
any CAD system and there are many other snap tools you will get to know later in this book.

Hands-on: A Line through the Middle

To emphasize the importance of snap tools, we will now extend our drawing with a vertical line
that separates the rectangle in two equal halves.

Vertical means that the line extends from a first point to another point directly under or above it.
In our case, the line starts in the middle of the top line of the rectangle and ends in the middle of
the bottom line. The top and bottom lines of the rectangle are horizontal, that means they extend
from left to right. You can easily remember what horizontal means by thinking that the horizon at
the seaside looks horizontal.

Note that there are no grid dots at the center of the top and the bottom line of the rectangle. For
this line we will have to use a different snap tool.

Figure 3-4: Choosing the CAD tool for drawing lines with two
points and changing the snap tool to Snap to middle points.

1. Choose the Line Tools button from the CAD toolbar as shown in Figure 3-4 (1).
2. Select the tool Line from 2 Points (2).
3. Click the button Middle (3). This activates the snap tool to snap to middle points of lines

and arcs. Note that only one snap tool can be active at any time.
4. Move the mouse cursor around in the drawing area like wedid before with the grid snap

tool. As you can see, the yellow circle no longer jumps from grid point to grid point.
Instead it now only shows up in four different positions which are the middle points of
the four lines that form the rectangle. One such possibility is shown here:



Part II First Steps with QCAD

27

Try also to find the other three by moving the mouse cursor around.
5. Click the left mouse button while the mouse cursor is located somewhere close to the

middle of the top line of the rectangle. It doesn't really matter where exactly the mouse
cursor is, as long as the yellow circle is located in the middle of the top line as shown
above.
After clicking the left mouse button, the drawing should look likeshown below. The
start point of the line is now set:

6. Move the mouse cursor approximately to the middle of the bottom line of the rectangle.
You can see a preview of the vertical line we are about to draw.

7. Click the left mouse button to set the end point of the line. The drawing should now
look like this:

8. QCAD now waits for you to draw the next line or to terminate the tool. Click the right
mouse button twice or press the Escape key on your keyboard twice to make sure the
tool is terminated.

9. Save your drawing again by choosing the menu File > Save.

Hands-on: Printing a Drawing

Once your drawing is finished, you will most likely want to print it on paper. In the following
steps we will print your drawing on an A4 or Letter size paper.
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1. Activate the print preview by choosing the menu File > Print Preview. QCAD shows
your drawingas it will be printed. Hit the minus key on your keyboard a couple of times
to zoom out until you can see the paper border:

The white area shows the size and location of the paper.
The toolbar at the top shows some tools and options for the print preview.

2. Print the drawing by choosing the menu File > Print. The printer dialog is shown. If
your printer is set up correctly, it should not be necessary to make any adjustments here.
Click OK to print your drawing.

3. Close the print preview by clicking the close button at the top left in the options toolbar:

4. Save your drawing by choosing the menu File > Save (QCAD will save the paper
settings with your drawing).

5. You can close your drawing now. To do this, choose the menu File > Close.

Closing QCAD

If you want to continue right away with the next chapter you can keep QCAD running. If you want
to finish for now, you might want to close the QCAD application. You can do this by choosing
the menu File > Quit.
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Chapter 4

Viewing

Objective
In this chapter, you will

• learn how to magnify details of your drawing,
• familiarize yourself with the function of the middle mouse button or the

mouse wheel,
• learn why changing the view does not affect the contents of your drawing.

The Viewing Tools

The tools that can be used to change the current view of a drawing are located at the top of the
QCAD application window (see Figure 4-1). The same tools are also available in the View menu
and some of them can be quickly accessed with the middle mouse button or the mouse wheel of
your mouse or the buttons of a graphics tablet pen.

Figure 4-1: The viewing toolbar is shown in the top area of the QCAD application window.

When following the instructions in this chapter you will not change your drawing in any way.
The viewing tools don't have any effect on the actual drawing, they only change the current view
of the drawing. Nevertheless, being able to change the view of your drawing is very important
and the viewing tools are the most frequently used tools while creating a drawing. Using them
will become second nature after you have used QCAD for a few hours.

Hands-on: Zooming in and out

Menu: View > Zoom > Zoom In / Zoom Out
Keycodes: +, -

  

1. Launch QCAD and open your drawing from the last chapter. To open a file, choose the
menu File > Open. The dialog for choosing and opening a drawing appears.
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2. If you have followed the advice in the last chapter to use the default location to store
your example drawing, you will now see that drawing file in the dialog as example.dxf.
The file name extension .dxf was added by QCAD. All your drawings will have the file
extension .dxf or .dwg, depending on the format you choose when saving a drawing.
Select the file example.dxf with your mouse by clicking with the left mouse button on it.

3. Click the button with the label Open to open the drawing.
4. You might be a bit surprised by what you see now. The relatively small rectangle you

have created in the last chapter fills now the entire drawing area:

This is because QCAD performs an automatic zoom when opening a drawing. This
means that it automatically shows the drawing in such a way that everything fits into
the drawing area at the maximum possible magnification factor. Your rectangle has of
course still exactly the same size as before, it is only shown larger.

5. In this step, you will scale the drawing view down a bit to a similar size as in the last
chapter.
If your mouse has a mouse wheel:
- Move the mouse pointer about to the center of the drawing area.
- Rotate the mouse wheel about ten ticks towards you.
If your mouse does not have a mouse wheel:
- Click a couple of times on the button to zoom out:

Alternatively, you can also press the - (minus) key on your keyboard a couple of times
to zoom out.
What you just did is usually referred to as zooming out. You have reduced the
magnification of the drawing view and your drawing now looks smaller, more or less as
shown here:
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6. The opposite of zooming out is zooming in. You can do that by rotating the mouse
wheel away from you, pressing the + key on your keyboard or by clicking the button
Zoom in:

Hands-on: Panning

Menu: View > Zoom > Pan Zoom
Keycode: ZP

 
The zoom factor (or magnification) is one of two aspects that define how a drawing is currently
being displayed. The other one is the position. You may of course use the scroll bars like in most
other applications to move the view around, but QCAD offers a far more efficient way of doing
that called panning.
If you have a three button mouse (or a mouse wheel):

1. Move the mouse cursor approximately to the middle of the drawing area.
2. Press the middle mouse button or the mouse wheel down and hold it down.
3. Move the mouse cursor around while still holding the middle mouse button down. As

you can see, the drawing view now moves with the mouse cursor.
4. Let go of the middle mouse button.
5. Repeat these steps to move the drawing view again until you see the portion of the

drawing you need to work on.

If you have a two- or one button mouse:
1. Click the Pan Zoom button in the viewing toolbar:

2. Move the mouse cursor approximately to the middle of the drawing area.
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3. Press the left mouse button down and hold it down.
4. Move the mouse cursor around. As you can see, the drawing view now moves with the

mouse cursor.
5. Let go of the left mouse button.
6. Repeat these steps to move the drawing view again until you see the portion of the

drawing you need to work on.
7. To stop moving the view, click the right mouse button or press the Escape key.

Once you are used to this procedure, you can navigate around your drawing much faster than
by using the scroll bars. Panning in QCAD is a bit like moving a very large paper around on a
table with your hand.

Hands-on: Auto Zoom

Menu: View > Zoom > Auto Zoom
Keycode: ZA

 

Click the Auto Zoom button in the viewing toolbar or press the keys Z and then A.
Just like after opening the drawing, QCAD automatically fits the whole drawing at the maximum
possible scale into the drawing view.

Hands-on: Window Zoom

Menu: View > Zoom > Window Zoom
Keycode: ZW

 

Sometimes you will want to show exactly a certain area of your drawing to work on. The tool
you are going to use now allows you to choose a rectangular area (or window) of your drawing
and magnify that area.



Viewing Chapter 4

34

1. Make sure that you zoom in or out so that your rectangle drawing has about the size as
shown below:

2. Click the button Window Zoom:

3. Move the mouse cursor into the drawing area. As you can see, the mouse cursortakes
on the shape of a magnification glass.
In the example drawing, we will now magnify the top left quarter of the rectangle you
have drawn. Move the mouse cursor to the location slightly outside the top left corner of
the rectangle:

4. Click the left mouse button.
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5. Move the mouse cursor to the second corner of the area that you want to magnify:

QCAD shows a dark red dashed rectangle around the area that will be magnified.
6. Click the left mouse button.
7. QCAD now zooms in on the chosen area. The application window should now look

more or less as shown below:

Notes

While zooming in and out, you might have observed that QCAD automatically adjusts the grid
spacing in a way that the grid never becomes too dense. At the bottom right corner of the drawing
area, between the scroll bars, QCAD displays the current grid spacing. The first number is the
distance between two neighboring grid dots and the second number is the distance between two
neighboring dotted lines. These lines are displayed as further orientation. If you zoom in, the grid
becomes finer and shows dots at a smaller distance (for example 0.1). After zooming out a lot,
the grid spacing is increased, for example to 100. This behavior makes sense since grid dots that
are too far apart or too close to each other are not useful.

Be sure to check the corner where the grid information is displayed before using the grid to make
sure you are interpreting the grid correctly.
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Exercises

You will have to practice the viewing tools of QCAD for a while to get used to them. If you get
completely lost and you have no idea anymore where your drawing is, simply press the button
Auto Zoom to show the complete drawing again. You might also want to remember the keycode
for auto zoom (ZA) as you will likely be using this tool very often.
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Chapter 5

Layers

Objective

In this chapter, you will

• learn how to organize your drawing with layers,
• create, edit and use layers,
• see how you can easily control the color, line style and linewidth of your

drawing elements with layers.

What are Layers?

Most CAD systems offer a way to organize a drawing by arranging related elements on separate
layers. Think of a layer as a transparent surface onto which you can draw. All elements on the
same layer usually share a specific role in the drawing. For example all lines on a layer called
Walls might represent walls, a layer called Labels may contain all text labels of a drawing.

Layers are crucial to the meaning of the drawing elements. For example if a line is drawn on layer
Walls it usually means that it represents a part of a wall. If the same line would be drawn on layer
Furniture, it might be a part of a bookshelf, a desk or another piece of furniture. In other words:
the layer on which you draw an element often defines its role or function.

While you are working on a drawing in the CAD system, you will always be aware on what
layer an entity is. As soon as you print your entire drawing on a sheet of paper, this information
is generally lost. For this reason, all elements on a layer usually share a unique combination of
visible attributes (color, line style and linewidth). For example all elements belonging to walls
may be drawn in black with thick, solid lines. Furniture may be drawn in gray with thin, solid
lines. Electrical installations may be drawn in red with thin, dashed lines and so on.

In mechanical drafting, visible edges are usually put on the same layer and hidden edges on
another one. Another layer may contain all dimensions or text labels of the drawing.

Because of this close relationship between layers and visible attributes, the attributes are almost
always handled by the layer and not by the individual entities. For example if the color of layer
Walls is set to blue, all elements on that layer (i.e. all walls) are displayed in blue.
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Layers, Groups and Blocks

In the context of CAD, groups and blocks are the same and usually only called blocks. Layers on
the other hand are fundamentally different from blocks.

Blocks would for example be used to treat all elements of a mechanical part or a piece of furniture
as one element.

Layers organize your drawing in a different way. The layer on which you draw an element depends
on the role of that element and not on the part of the drawing the element is in.

Figure 5-1 shows a floorplan of a floor of a house. At the top left is the complete floorplan with
all layers visible. At the top right, only the layer Walls is shown. This layer contains the outline
of all walls. Layer Interiors is shown at the bottom left and contains all interior elements such as
furniture. The interior elements would typically be structured in blocks. For example all drawing
elements of one single person bed might be grouped in a block called Single Bed.

Another layer is called Labels and contains the text labels of the rooms. There are also other
layers in this drawing which contain the windows, the doors, the staircase and the dimensions.
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Figure 5-1: Organization of a drawing with layers.

Example Uses for Layers

Layers can be used in many different ways, depending on the type of drawing. The following list
gives some common example uses for layers in different areas of application.

• Mechanical drafting
• Visible / invisible edges
• Center lines
• Hatches
• Dimensions
• Text labels
• Auxiliary constructions
• ...

• Architecture
• Exterior / interior walls
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• Furniture
• Windows / doors
• Electrical, gas, water installations
• Dimensions
• Text labels
• Auxiliary constructions
• ...

• Geographic Information System (GIS)
• Roads, railway lines
• Houses
• Border lines
• Text labels representing ZIP codes
• ...

• Schemas and Diagrams
• Text labels
• Boxes
• Arrows, connectors
• Entity relationships
• ...

The Layer List

QCAD shows the layers of the current drawing in the layer list. To display the layer list, choose
the menu View > Layer List. The layer list is displayed at the right as shown in Figure 5-2.

Figure 5-2: The layer list displays the layers of the current drawing.

After activation, the layer list shows only one layer with name 0. The layer name is highlighted
to indicate that this is the active layer, the layer onto which you are currently drawing. This initial
layer is present in every drawing and can never be removed from a drawing or renamed.

The layer list also offers tools at the top to show, hide, add, remove and edit layers.

Layers and Linetypes

When creating a drawing, you will be using different linetypes to convey information about the
specific role of an entity. For example there are lines that indicate visible edges, invisible edges or
the center lines of a round part. To make clear to the reader of a drawing what the role of each line
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is, several linetype standards have been defined. It is advisable to apply these standards to your
own drawings whenever possible.

Note that there are no universal conventions and these standards may be country-specific, indus-
try-specific and even company-specific. Table 5-1 shows some established standards for linetypes
in mechanical drawings.

Table 5-1  Established Linetypes
Linetype Example uses Line thickness (mm)

A4/A3/A2 A1/A0

Continuous, thick Visible contours and edges. 0.5 0.7

Continuous, thin Dimensions, leaders, hatches and short
center lines.

0.25 0.35

Dash, thin Hidden contours and edges. 0.25 0.35

Dash dot, thin Center lines and lines of symmetry. 0.25 0.35

Figure 5-3 shows an example drawing of a mechanical part with different linetypes.

Figure 5-3: Different linetypes are used to indicate the meaning of a line.

Hands-on: Using Layers

These steps will guide you through the process of creating a simple drawing with layers. We start
by adding some layers and then create the elements onto these layers.

Creating The Layers

Menu: Layer > Add Layer
Keycode: YA
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Usage
1. In the layer list click the + button to add a new layer:

2. A dialog is shown to enter the name and attributes of the new layer. Enter the name
visible and adjust the attributes as shown here:

3. Click OK.
4. QCAD adds the new layer to the layer list. Later we will use this layer for all visible

edges of the drawing.
5. In the same way, add the following layers with these names and attributes to the

drawing:
• This layer will later be used for hidden edges:

Layer name: hidden
• Color: Black
• Width: 0.25mm
• Linetype: Dash

• All center lines and symmetry lines will be placed on this layer:
Layer name: center
• Color: Red
• Width: 0.13mm
• Linetype: Dash Dot

Drawing onto Layers

The layer list now shows the layers you have just added in addition to the layer 0. Before you are
drawing something, you have to decide on which layer you want to draw. In the following steps
you will draw some elements onto each layer.

The drawing we will produce is shown in Figure 5-4. It is the front view of a simple mechanical
part. The instructions below will guide you through the complete process of creating the drawing
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in Figure 5-4. You will use the rectangle tool again, get to know the tool for drawing parallel lines
and use two simple modification tools to finish the drawing.

Figure 5-4: The final drawing of this exercise.

1. Click on the layer name visible in the layer list. Make sure that you click on the name
and not one of the icons beside it. The layer name is now highlighted:

This indicates that layer visible is now the active layer. The active layer is the layer onto
which you are currently drawing.

2. Choose the drawing tool for drawing a rectangle:

3. Activate the grid snap:

4. Adjust the scale of the drawing area so that you can see a space of about 100 units
horizontally. To do this, keep an eye on the rulers that QCAD displays at the top and at
the left. Check the bottom right corner of the drawing area to make sure that the grid is
currently shown with a spacing of 10 units (the text 10 / 100 is shown).

5. Draw a rectangle that is 50 units wide and 20 units high using the grid.
Set the first corner at any grid point in the drawing and set the second corner 5 grid
points to the right and 2 grid points to the top of the first corner:
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6. We will now create the vertical center line in the middle of the rectangle. We can use the
parallel tool for that, but first we need to switch the active layer to center.
Click on the layer center in the layer list to activate it:

7. Choose the drawing tool for drawing parallel lines:

8. The options toolbar for parallels is shown at the top. Enter 25 for Distance and make
sure that Number is set to 1:

9. Move the mouse pointer close to the left side of the rectangle, just slightly to the right
of it. QCAD gives you an immediate preview of where the parallel will be placed. This
should look like this:

As soon as the parallel is shown at the right place, click the left mouse button to create
it.
Note that the center line you have just created has the attributes of layer center. It
should be displayed in red and with a dash-dot line pattern.

10. Activate the layer with name hidden and create the two hidden lines. The distance from
the center line to each of the hidden lines is 4, so you need to change the distance in the
options toolbar of the parallel tool to 4 and then create the lines as shown here:

11. The drawing is now almost finished. Center lines and symmetry lines are usually
slightly extended to clearly separate them from the edges of the object. QCAD offers
a modification tool to extend a line by a given amount. Start this tool by clicking the
button to show the modification tools, followed by the button for the tool to lengthen
entities:
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12. Enter the amount 2.5 in the options toolbar:

QCAD will now lengthen every entity you click by an amount of 2.5 units. The element
is extended at the end which is closer to the mouse cursor when you click the entity. To
extend the center line by 2.5 units at the top end, click the center line close to its top:

13. Click the center line close to its bottom end to extend it in that direction as well:

Changing the Visibility of Layers

1. You can now easily view your drawing without invisible lines and without the center
line by hiding the layers hidden and center. To change the visibility of layer hidden,
click on the eye symbol next to its name in the layer list:

2. It is not necessary to activate a layer in order to change its visibility, so you can simply
click the eye icon of layer center to hide it as well.
The layer list indicates hidden layers with a gray eye icon:

3. After hiding the layers hidden and center, your drawing now only shows the layers
0 (which is empty) and layer visible:

4. Make sure that all layers are visible again by clicking the button to show all layers:
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Changing Layer Attributes

Menu: Layer > Edit Layer
Keycode: YE

 

One advantage of organizing drawings with layers is that you can easily change the attributes of
all entities on the same layer.

1. Click on layer visible in the layer list to activate it.
2. Click the button Edit Layer at the top of the layer list:

3. QCAD shows the same dialog again as for adding layers. You can change the layer
name and attributes in this dialog. Change for example the color to green and the width
to 2.00mm and click OK.

4. As you can see, all entities on layer visible are now green and wider than before.
5. Change the attributes of layer visible back to white and 0.25mm.

 Exercises

1. What attributes of elements are typically controlled by layers?
2. Explain the difference between layers and blocks.
3. Explain why layers are used to control the attributes of entities rather than assigning

attributes separately to each individual entity.
4. Start a new file and create the drawing shown below. It shows the side view of the

mechanical part for which we have already drawn the front view. Use the same tools as
in the instructions earlier in this chapter. The height of the part is 20 and the width 30
units. The vertical dash-dotted line is located at the center. The distance from the dash-
dotted center line to the two vertical dashed lines is 4 units.
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Chapter 6

Precision

Objective

In this chapter, you will

• learn about the importance of being precise when working with a CAD
system,

• see that precision does not require a great deal of complexity.

Precision in CAD

Precision in the context of CAD means to be in control of the exact position of the objects you
draw. If two lines form a corner, they meet at exactly the same point, if two lines are orthogonal,
the angle between them is exactly 90 degrees. If you mean to draw a line that is 100mm long but
it ends up being 99mm long, your drawing is not precise.

The term accuracy is often used interchangeably with precision. In the context of CAD there is
a difference between the two. Accuracy describes the quality of your drawing when compared
to the real object that you are drawing. Inaccuracy usually comes from insufficient or wrong
information about the real object. For example you might be told that a wall in a floorplan has to
be 10 centimeters thick but in reality it has to be 12 centimeters thick. In this case, your drawing
might still be precise but it is not accurate. Since this is not a technical problem there are also
no special tools in a CAD system that help you to deal with inaccuracies. A CAD system has for
example no way of telling what the real thickness of a wall should be.

The Importance of Being Precise

Precision is fundamental to CAD. Precision is one of the reasons why it makes sense to use a
CAD package rather than an ordinary drawing application for illustrative drawings. Make sure
that your drawings are precise from the beginning. Small errors in precision will quickly grow
into major problems as your drawing progresses. QCAD offers many tools that make it really easy
to create precise drawings with very little effort. In fact, being precise does not cost you anything
and will even save you a lot of time in the long run. Make it a habit to be precise when working
with a CAD system and correct objects immediately if you realize that they are not precise.
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Precision Techniques

QCAD uses several techniques to support you when creating precise drawings:

• Snap tools:
Snap tools allow you to position the mouse cursor exactly on a grid point or reference
point of an existing object (for example the end point of a line, the center of an arc,
the intersection between a line and a circle, and so on). The snap tools of QCAD are
explained in detail in the following chapter.

• Coordinate entry:
Coordinates are a fundamental concept of CAD and technical drawing. QCAD allows
you to enter coordinates directly to specify positions. Coordinates and coordinate entry
is explained in detail in a subsequent chapter.

• Entry of distances, angles and factors:
Many tools offer a way to specify certain parameters of the tool. For example when
drawing a parallel line, you can enter the precise distance between the existing line
and the parallel one. To draw a line at a given angle, you can enter the precise angle
of the line in degrees. If you scale a part of your drawing you enter the precise scale
factor. This technique is described in detail in subsequent chapters along with the
individual tools which use it.

Exercises

1. Explain the difference between precision and accuracy in the context of CAD.
2. Name three techniques offered by QCAD to support you when creating precise

drawings.
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Chapter 7

Snap Tools

Objective

In this chapter, you will

• learn how to precisely define positions in your drawing using snap tools.

What are Snap Tools?

Snap tools offer a convenient way to define the geometry of a new entity based on the geometry
that is already present in the drawing. For example you can easily draw a line to the intersec-
tion point between an arc and a line. Of course you could also calculate the coordinates of that
intersection point and then enter those coordinates. But it is much more efficient to let QCAD
do the work for you. When the snap tool Snap to Intersection is active, QCAD automatically
finds intersection points in the drawing that are close to the mouse cursor and locks on the one
intersection point that is the closest.
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Figure 7-1: The toolbar with the snap tools is displayed auto-
matically whenever you're expected to specify an exact position.

Snap tools can be used whenever you have to specify a point as part of a geometry or as part of
an operation. For example when specifying the startpoint and endpoint of a line, when choosing
a reference point for moving or copying entities, etc.

QCAD shows the complete palette of snap tools in the toolbar at the left whenever it expects you
to specify a precise point. Figure 7-1 shows the snap tools. The first group of tools are snap tools
that allow you to specify points based on existing geometry or the grid. Below are the coordinate
snap tools that will be discussed in detail in a subsequent chapter.

The toolbar also shows advanced snap tools for snap restriction and the tools to move or lock the
position of the relative zero point (not shown in Figure 7-1).

Table 7-1 shows an overview of the first group of snap tools. In most cases, the default snap tool
Auto Snap will be the one you will be using but in some situations it is necessary or convenient
to activate another, more specific snap tool.

Table 7-1  Snap Tools
Button Snap tool Key

code
Effect and Examples

Free SF Allows for free positioning (no snapping). This is only
recommendable when the result is not expected to
be precise (for example when drawing a freehand
line or positioning a text label).
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Button Snap tool Key
code

Effect and Examples

Grid SG Snaps to grid points.

End SE Snaps to endpoints of lines, arcs, ellipse arcs and
polyline segments.

On Entity ST Snaps to the closest point on an object.This is almost
never recommendable since the exact position on
the entity is undefined.

Perpendicular SU Snaps to the perpendicular point on the closest
entity. This can be used to draw a line from an
already specified position to a perpendicular point
on an entity. Perpendicular (or orthogonal) means
that the line is drawn at a 90 degree angle to the
chosen base entity (a line, arc, circle or ellipse).

Tangential SB Snaps to the tangency point on the closest entity to
draw a line from any position, tangential to an arc,
circle or ellipse.

Center SC Snaps to center points of arcs, circles and ellipses
and to middle points of lines.

Reference SR Snaps to reference points. Reference points are
defining points of an entity. This is often used to
snap to orthogonal points on circles as shown in the
example figure.
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Button Snap tool Key
code

Effect and Examples

Middle SM Snaps to middle points of arcs, ellipse arcs and
lines.Note that the middle point of an arc is on the
arc and not at the center of the arc.

Middle Manual SN Snaps to imaginary middle points. These are points
in the middle between any two other points. This
can for example be used to snap to the center of
a rectangle, without having to create any auxiliary
lines. This tool lets you pick two points to snap to the
middle between them.

Distance SD Snaps to points with a given distance to the end
point of an entity.

Distance Manual SH Snaps to points with a given distance along the
imaginary line between two chosen points.

Intersection SI Snaps to visible intersection points.

Intersection
manually

SY Snaps to imaginary intersection points. Such
intersection points are not visible as such. This
tool requires you to pick two entities to lock on an
intersection point between them.
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Button Snap tool Key
code

Effect and Examples

Auto snap SA Snaps to all end points, intersection points, middle
points, reference points, grid points and points on
entities in this order of priority.

Coordinate SX Defines a point by entering the X/Y coordinate in
the options tool bar. This is discussed in detail in the
next chapter.

Polar Coordinate SO Defines a point by entering a polar coordinate
(angle and distance) in the options tool bar. This is
discussed in detail in the next chapter.

X/Y from Points .X Defines a coordinate by clicking a point at the
desired X coordinate, followed by a point at the
desired Y coordinate.

Y/X from Points .Y Defines a coordinate by clicking a point at the
desired Y coordinate, followed by a point at the
desired X coordinate.

Center of Selection SK Clicking this button uses the center of the current
selection as input for the current tool. It is not
necessary to click at the center of the selection
when choosing this snap tool.
This can for example be used to paste a circle at the
center of a previously selected rectangle.

Hands-on: Using Snap Tools

In the following steps, we will draw a simple illustration of the Thales' theorem you might re-
member from school. Different snap tools are used to make sure the result is precise.

1. Launch QCAD with a new, empty drawing and save it under the name snaps01.dxf.
2. We start by drawing a horizontal line.

Click the button for the line toolbar and then the button to start the tool that lets us draw
a line with two given points:

3. QCAD is now waiting for you to click the start point of the line.
Since we did not choose any specific snap tool, QCAD uses the default snap tool for
positioning which is the auto snap tool.
Move the mouse cursor close to the zero point of your drawing. This is the point where
a red crosshair is displayed. QCAD shows a yellow cross hair on top of the red one and
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next to it the text label Grid, also in yellow color. This way QCAD indicates to you
that the mouse cursor is currently locked in on a grid point or in other words, it snaps
to the closest grid point. The auto snap tool snaps not only to grid points but also to
end points, intersections and other relevant points in your drawing. The yellow label is
displayed to emphasize what type of point is currently being used.
Click the left mouse button to set the start point of the line.

4. QCAD is now expecting you to click the endpoint of the line.
Move the mouse cursor somewhat to the right, for example by 50 units. QCAD shows
the label Grid again, as soon as the mouse cursor is close to a grid point. If you don't
want to count the grid points, you can check the position of the mouse cursor by looking
at the status bar of QCAD at the bottom left of the application window. It shows you
the precise location the mouse cursor currently snaps to. For this example, the status bar
should look like this:

The pair of numbers at the top left is called the absolute coordinate. You will learn more
about coordinates in the next chapter. For now, the number 50,0 means that the mouse
cursor is 50 units to the right of the absolute zero point of your drawing.
Click the left mouse button to set the endpoint of the line at that position.

5. Click the selection pointer button at the top left of the QCAD application window:

This ends the line tool and returns to the toolbar with the main selection of tools.
6. Next, we draw a half-circle over the line.

Click the arc button to display the toolbar with the arc tools. Then click the button for
the tool that draws arcs with a center, a point on the arc and the two angles:

7. QCAD waits for you to set the center point of the arc.
Move the mouse cursor approximately to the middle of the horizontal line you have
constructed. As soon as the mouse cursor gets close to the middle point of the line,
QCAD snaps to the exact middle point and indicates this with an appropriate text label:

Click the left mouse button to confirm the center of the arc. The center of the arc is now
set to be exactly in the middle of the horizontal line.

8. Now we can define the radius of the arc by choosing a point on the arc itself.
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Move the mouse cursor to the end point at the right of the horizontal line until QCAD
indicates that it snaps to the end point of the line. Click the left mouse button to confirm
the radius:

QCAD shows a preview of the arc as a full circle because the start angle and end angle
of the arc are still undefined.

9. For the start angle of the arc, we click the same point again to indicate that the arc starts
at an angle of zero degrees:

The preview of the arc changes from a full circle to an arc with a total angle of about 60
degrees. The start angle of the arc is already shown correctly but the end angle is not yet
defined.

10. Make sure that the direction of the arc is set to counter-clockwise in the options toolbar:

11. Move the mouse cursor to the other end of the line at the left and click that endpoint to
define the end angle of the arc:

The arc is now completely defined.
12. Terminate the arc tool by clicking the right mouse button twice or by clicking the

selection pointer button in the toolbar:
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13. Start the line tool as previously described and set the start point at the left endpoint of
the horizontal line:

14. For this example, we want to place the end point at a distance of exactly 20 units along
the arc line.
There are some snap points that cannot be set with the auto snap tool. At the moment,
we would like to snap to a point on the arc line with a distance of 20 units from the end
point. For this, we use the snap tool called Distance from end point. This tool snaps to
a point with a given distance from an end point. Click the Distance from end point snap
tool in the CAD toolbar at the left:

The options toolbar at the top now shows a text field. Enter the distance from the end
point to which you want to snap. For this example, enter 20:

15. Move the mouse cursor along the arc again. The mouse cursor now only snaps to two
positions. One of them is at the right, 20 units away from the right endpoint of the arc.
Note that the distance is measured along the arc, on the arc line. The length of the arc
segment between the end point and the snap point is 20.

The other one is at the left, 20 units away from the left endpoint of the arc (measured
along the arc):

Click closer to the left one of the two snap points to set the endpoint of the line at that
position.

16. We can now continue to the next line without terminating the line tool. For the next
point, we can use the auto snap tool again. Switch back to auto snap by clicking the auto
snap button in the toolbar at the left:
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17. Click the end point at the right of the horizontal line to finishthe drawing:

Snap Restrictions

Figure 7-2: At the bottom of the snap toolbar you can find tools
for snap restrictions and tools to manage the relative zero point.

There are situations in which a point cannot be defined using the snap tools alone because the point
it is not on an intersection, end point, middle point or other distinguished point in the drawing.
In such situations it is often necessary to create an auxiliary construction to construct the snap
points that are required to continue. One very common situation is that you have to draw lines
that are exactly vertical or horizontal.

Consider the dashed line in the example in Figure 7-3. The line starts in the middle of the hori-
zontal line at the top. We can snap to the middle point using the appropriate snap tool or auto
snap. However, the end point of the line is not on a point we can snap to. The line has to extend
vertically to meet the line at the bottom.

There are several possible solutions to this problem: You could for example use a special line tool
that draws only vertical lines or use the parallel tool. But since situations in which two points have
to be vertically or horizontally aligned are so common, QCAD offers special tools to support you
in such cases. These tools are called Snap Restrictions and are shown in the same toolbar as the
snap tools, just below the other snap tools (see Figure 7-2).
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Figure 7-3: The first point of the dashed line (at the top) can be defined us-
ing auto snap or snap to middle. The second point is horizontally aligned
with the end point of the arc and can be defined using snap restrictions.

Hands-on: Using Snap Restrictions

To draw the dashed line in Figure 7-3 one could proceed for example as follows:

1. Start the tool for drawing lines:

2. Set the start point of the line at the middle of the top line using the auto snap tool:

3. Move the mouse cursor down until it is close to the corner as shown here:

Since there are no other snap points nearby, QCAD snaps to the intersection point at the
corner as shown above. This point is on the correct height but we now need to further
restrict the endpoint of the line to be exactly vertically below the start point.

4. Activate the snap restriction Restrict Vertically in the toolbar at the left:
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5. Move the mouse cursor back to the same position as before:

QCAD still snaps to the intersection point at the corner but at the same time it restricts
the angle from the start point to the end point to be exactly vertical.
As usual, click the left mouse button to confirm the endpoint of the line.

Exercises

1. Create the following drawing using only auto snap for positioning. The side length of
the square is 30 units.

2. Use the auto snap tool again to extend the drawing from the previous exercise with the
two lines shown here:

3. Draw the figure below using the snap tools auto snap and distance from end point. The
side length of the square is 30 units. The distances from point A to point B and from
point C to point D are both 7.5 units.
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Chapter 8

Coordinates

Objective

In this chapter, you will

• learn what coordinates are,
• get to know the different types of coordinates QCAD supports,
• learn how to define positions by entering coordinates.

The Cartesian Coordinate System

In the previous chapters you have already seen and used the drawing area of QCAD. Like a sheet
of paper, the drawing area is a flat area onto which you can draw something.

When working with a CAD system, you will often be confronted with the coordinate system of
the drawing area. A coordinate system uniquely defines each point in the drawing area and in
your drawing. If you point with a pen to any position in the drawing area, that position has a
unique coordinate that defines where this point is in the drawing.

By far the most commonly used coordinate system is the Cartesian coordinate system. A coor-
dinate system is not something that is given by nature. Coordinate systems were defined once by
someone (in this case René Descartes in 1637) to define a standard for specifying the position of
a point on a two dimensional surface. The Cartesian coordinate system is not only used in CAD
applications but in many areas of mathematics, physics and engineering.

The Cartesian coordinate system is based on two axes that are at right angles (orthogonal) to each
other. The horizontal axis is commonly called the X-axis while the vertical one is called the Y-
axis as shown in Figure 8-1.
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Figure 8-1: The coordinate axes of the Cartesian coordinate system.

The origin of the coordinate system is the point where the X and the Y axes cross each other. This
point is also referred to as the absolute zero point or just absolute zero.

Both axes have a direction. The X-axis is directed to the right and the Y-axis upwards. This is
not necessarily a logical choice, it was simply defined this way. As you can see in Figure 8-1, the
axes are divided into smaller sections, each one unit long.

Any particular position can be described by its distance from the origin in X-direction and in Y-
direction. For example the position of the point P in Figure 8-2 is 3 units away from the origin
in X-direction and 2 units away from the origin in Y-direction. Or, to use the correct notation,
the point P is located at (3,2). This notation in brackets indicates the location of a point as a pair
of an X-distance and a Y-distance (X,Y).

Figure 8-2: The location of the point P can be noted as (3,2) where 3 is the dis-
tance to the origin in X-direction and 2 is the distance to the origin in Y-direction.

If a point is located left of the origin, its X-coordinate turns negative. If it is located below the
origin, its Y-coordinate turns negative. Figure 8-3 shows some points in the Cartesian coordinate
system and their (X,Y) notation. The (X,Y) notation for the origin is (0,0).
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Figure 8-3: Some example coordinates in the Cartesian coordinate system.

There are different ways to specify the location of a point in the Cartesian coordinate system. The
most common ones are: absolute, relative and polar coordinates.

Absolute Cartesian Coordinates

Absolute Cartesian coordinates indicate the position of a point by its distance to the origin along
the X and Y axes. The coordinates used in previous examples are all absolute Cartesian coordi-
nates.

Absolute Cartesian coordinates are usually noted as (X,Y), for example (6,4). Figure 8-4 shows
an example for an absolute Cartesian coordinate.

Figure 8-4: The absolute Cartesian coordinate of point P is (6,4).

Relative Cartesian Coordinates

Relative Cartesian coordinates relate to the last used position and not to the origin of the drawing.

There is no standard notation for relative coordinates. However, a common notation in the CAD
industry is to prepend an AT sign (@) to a relative coordinate.

A relative Cartesian coordinate may for example be used to position the end point of a line rel-
atively to its start point. Let's assume you have just set the start point of a line at the absolute
coordinate (2,2). You can now set the end point of the line at the relative coordinate (@5,3). The
absolute coordinate of the end point will be at (7,5). In this example, the relative coordinate relates
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to the start point of the line (2,2). In other words, the values of the relative coordinate of the end
point are added to the absolute coordinate of the start point: (2,2) + (@5,3) = (2+5,2+3) = (7,5).

In previous exercises you might have already noticed a small red circle that moves always to
the previously clicked point when you draw lines. This red circle visualizes the position of the
relative zero point of your drawing. When entering relative coordinates, they relate to the current
position of this red circle. Figure 8-5 shows an example for a relative coordinate.

Figure 8-5: The relative Cartesian coordinate of point P is (@5,3).

Absolute Polar Coordinates

Polar coordinates specify the position of a point by an angle and the distance to the origin (often
called radius).

A common notation for absolute polar coordinates is (distance<angle), for example (8<30) for
a point with a distance of 8 units from the origin at an angle of 30 degrees. Angles are always
measured from the positive part of the X-axis. In other words, 0 degrees is east or 3 o'clock on
your watch. Angles are measured counter-clockwise which is the mathematical and technical
standard for indicating angles. Negative angles may be used for clockwise angles. Figure 8-6
shows an example for an absolute polar coordinate.

Figure 8-6: The absolute polar coordinate of point P is (8<30).

Relative Polar Coordinates

Just like Cartesian coordinates, polar coordinates can also refer to the relative zero point instead
of the origin. In this case we talk about relative polar coordinates.

We use the notation (@distance<angle) for relative polar coordinates. Figure 8-7 shows an ex-
ample for a relative polar coordinate.
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Figure 8-7: The relative polar coordinate of point P is (@5<30).

Notes

Note that QCAD stores all coordinates as absolute Cartesian coordinates internally. So there is
no difference in the end result if you use absolute or relative and Cartesian or polar coordinates.
The different ways for specifying a position are only a help for you as a user to avoid having
to calculate positions.

Hands-on: Drawing a Triangle from Three
Absolute Coordinates

The following steps guide you through the process of drawing a triangle from the three coordi-
nates of its corners. The goal is to draw the triangle shown in Figure 8-8.

Figure 8-8: A triangle with known corner coordinates.

1. Launch QCAD with a new, empty drawing and save it under the name
coordinates01.dxf.
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2. Show the line toolbar and choose the tool for drawing lines with two points. Then
activate the snap tool Coordinate:

3. The coordinate snap tool you have activated allows you to type in a coordinate instead
of using the mouse to click a point in the drawing. QCAD displays this special toolbar
at the top to specify the coordinate:

Enter the coordinate (20,10) in theoptions toolbar as shown here:

Just like with other snap tools, the graphic view gives you a preview of the coordinate in
the form of a small yellow circle.

4. Click the green tick button at the right in the options toolbar or press the Enter key to set
the location of the start point of your first line to the coordinate you have entered.

5. Enter the next coordinate (40,10) in the options toolbar and click the green tick button
again (or press the Enter key on your keyboard).

6. Repeat this for the coordinates (30,37.5) and then again for (20,10). Your drawing
should now look like this:

Notes for Advanced Users

If you prefer to work with the command line of QCAD for entering coordinates, you can show
the command line by choosing the menu View > Command Line. You can then enter coordinates
in the command line instead of using the coordinate snap tool. The format how you have to
enter coordinates is the same as described above, without any brackets: x,y for absolute Cartesian
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coordinates, @x,y for relative Cartesian coordinates, radius<angle for absolute polar coordinates
and @radius<angle for relative polar coordinates.

If this format is not accepted, you might have configured an alternative format in the application
preferences (see Edit > Application Preferences > General > Coordinate Format).

Hands-on: Drawing a Shape Using Relative
Coordinates

The drawing shown in Figure 8-9 could be drawn with absolute coordinates, like the triangle in
the previous example. To do so, you would of course have to calculate the absolute coordinates
of each point first. It is easier in this case to draw the shape using mostly relative coordinates.

Figure 8-9: This shape can be easily constructed using mostly relative coordinates.

Before you start drawing a shape like this it is a good idea to write down the coordinates of
every corner of the shape. Remember to use an AT symbol (@) to indicate which coordinates
are relative. Figure 8-10 shows the shape again with all coordinates you will need to enter. The
arrow shows in what direction the shape will be created. Unlike with absolute coordinates this
is significant. 

Figure 8-10: The coordinates that you will use to draw the shape.

1. Launch QCAD with a new, empty drawing and save it under the name
coordinates02.dxf.
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2. The tools you need to select are exactly the same ones as for the example with absolute
coordinates:

3. The options toolbar is shown again at the top of the QCAD application window:

Enter the absolute coordinate (15,10) in the options toolbar:

4. Click the green tick button in the options toolbar or press Enter.
5. The next coordinate is relative to the one you have just defined at (15,10). In Figure

8-10, you can see that the next coordinate to enter is (@0,16). Tick the check box with
the label Relative in the options toolbar and enter the coordinates 0 and 16 as you would
for an absolute coordinate:

6. Repeat this for the rest of the coordinates in Figure8-10.
Note that the last coordinate to close the shape is absolute again: (15,10).
Your drawing should in the end look like this:

Hands-on: Drawing a Shape Using Absolute
Polar Coordinates

In this exercise, you will draw the shape shown in Figure 8-11. To construct the shape using
Cartesian coordinates you would have to calculate the Cartesian coordinates of the corner points
first. This is of course possible and not even particularly hard using trigonometric functions.
But you would have to key in long numbers and the result would still not be as precise as the
coordinates calculated by QCAD.
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Figure 8-11: The shape you will construct in this exercise.

For beginners it is recommendable again to write down the coordinates of each corner as shown
in Figure 8-12 before you begin.

Figure 8-12: The coordinates that you will use to draw the shape.

1. Launch QCAD with a new, empty drawing and save it under the name
coordinates03.dxf.

2. Choose the tool to draw lines, this time using polar coordinates. Note that for polar
coordinates you have to click a different button in the last CAD toolbar:
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3. The options toolbar is shown at the top of the QCAD application window, this time not
for X/Y coordinates but for a radius 'r' (or distance) and an angle '<':

Enter the absolute polar coordinate (20<30) in the options toolbar:

4. Click the green tick button or press the Enter key.
5. Enter the other coordinates of the shape in Figure 8-12 in the correct order.
6. Your drawing should now look like this:

Hands-on: Drawing a Rhombus Using Relative
Polar Coordinates

Just like Cartesian coordinates, polar coordinates can also be relative. The rhombus in Figure
8-13 can be constructed most efficiently using relative polar coordinates.

Figure 8-13: The rhombus you will construct in this exercise.

As in the previous exercises, we start by writing down the coordinates of the corner points as
shown in Figure 8-14. The arrow indicates the order in which the coordinates are entered.
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Figure 8-14: The coordinates that you will use to draw the rhombus.

1. Launch QCAD with a new, empty drawing and save it under the name
coordinates04.dxf.

2. Choose the tool for drawing lines again. Since the first coordinate is an absolute
Cartesian coordinate, choose the button for Cartesian coordinates first.

3. Enter the absolute Cartesian coordinate of the lower left corner of the rhombus into the
options toolbar:

Note that you might have to un-tick the check box with the label Relative since QCAD
remembers the options you have used last time.

4. Click the green tick button or press the Enter key.
5. The next coordinate is (@20<0). This is the lower right corner of the rhombus. This

point is 20 units away from the lower left corner at an angle of 0 degrees.
Since QCAD still expects you to enter a Cartesian coordinate, you need to click the
button for entering polar coordinates first.
QCAD shows now the options toolbar for entering polar coordinates. Enter the radius
(distance) 20 and the angle 0 in the options toolbar and tick the check box for relative
coordinates:

6. Click the green tick button.
7. Repeat this for the next two coordinates (@20<60) and (@20<180). For the last

coordinate that closes the rhombus (10,10) you will have to switch back to absolute
Cartesian coordinates again.

8. Your drawing should now look like this:
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Exercises

1. What are the four different types of coordinates that are supported by QCAD?
2. Write down the absolute Cartesian coordinates of the four points A, B, C and D using

the notation (X,Y).

3. Write down the absolute polar coordinates of the three points A, B and C using the
notation (Radius<Angle).

4. Draw the following shape using the coordinate positioning tools of QCAD. Do not
calculate any coordinates but use relative and polar coordinates instead. The numbers
indicate the length of the segments. Start with point A, which is located at (22,45) and
proceed in the direction of the arrow.





Part IV
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Chapter 9

Drawing Tools

Objective
In this chapter, you will
• get to know the various drawing tools QCAD offers for basic entities,
• learn how to create the basic geometrical objects of your drawing.

Choosing a Drawing Tool

The building blocks of every drawing are the most basic geometric objects: points, lines, arcs and
circles. Depending on the industry you work in, ellipses, splines and polylines might also be used
frequently. This chapter introduces the various tools QCAD offers to create such drawing objects.
Of course there are also more complex drawing objects such as texts, hatches or dimensions.
These objects are not part of the geometry of your drawing but they make your drawing more
readable by adding additional information to it. Complex drawing objects are also composed from
lines and arcs but treated as one object in QCAD to make it easier to handle them. We will learn
more about those complex objects in the next chapter.
The easiest way to access the drawing tools in QCAD is through the CAD toolbar at the left. The
drawing tools are shown at the top of the drawing toolbar. Every button represents one tool or set
of tools to draw objects of a certain type (see Figure 9-1).

Figure 9-1: The drawing tools for basic geometrical objects.

You can also use the application menu Draw to select a drawing tool, but for the purpose of this
book, we stick to the CAD toolbar.
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Preparations before Drawing

Before you draw anything you should set up the layers of your drawing as described in a previous
chapter. The drawing tools of QCAD always draw all objects on the layer that is currently active.
After creating a new empty drawing, spend some time to think about the layers you will be using
for your drawing and create them. Whenever you are about to draw something, have a look at
the layer list at the right to make sure that you are on the correct layer. It can be helpful to assign
different colors to different layers, so you immediately realize that something is wrong if you
draw on the wrong layer.

Line Tools

Menu: Draw > Line
Keycode: WL

 

QCAD offers a variety of tools for drawing lines. They are all available in the CAD toolbar of
QCAD after clicking the line button shown in Figure 9-1. Figure 9-2 shows the CAD toolbar
with the various tools for drawing lines. Note that you can click the button at the top with the
left arrow to return to the main menu.

Figure 9-2: The CAD toolbar showing the drawing tools for drawing lines.

Line from two Points

Menu: Draw > Line > Line from 2 Points
Keycode: LI

 

With this tool you can draw a single line by directly defining its start point and end point. It is
also possible to draw a series of connected lines.
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Drawing a single line

1. Click the start point of the line.
2. Click the end point of the line.
3. Terminate the tool by clicking the right mouse button twice or by pressing the Escape

key on your keyboard twice.

Figure 9-3: Example for drawing a single line with startpoint and endpoint.

Drawing a series of connected lines

1. Click the start point of the first line.
2. Click the end point of the first / next line. Repeat this until you have drawn all

connected lines you want to draw.
3. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key

on your keyboard twice.

Figure 9-4: Example for drawing a series of connected lines.

Drawing a series of disconnected lines

1. Click the start point of the first / next line.
2. Click the end point of the first / next line.
3. Click the right mouse button once or hit the Escape key on your keyboard once.
4. Repeat steps 1-3 until you are finished with drawing lines.
5. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key

on your keyboard twice.
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Figure 9-5: Example for drawing a series of disconnected lines.

Line with fixed Angle

Menu: Draw > Line > Line from Angle
Keycode: LA

 
This tool lets you draw lines at a fixed angle. The length of the line can be specified and you can
choose if you want to position the line by defining its start point, middle point or end point.
When you are using this tool, you will often find that the length of the line is irrelevant at first
and can be better adjusted later using a trim tool.
Usage

1. Enter the angle of the line in the options toolbar. Type a length for the line and choose
how you want to position it.

2. Click the position of the line. You can also repeat this to place more than one line with
the same angle or change the angle in the options toolbar at any time.

3. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key
on your keyboard twice.

Table 9-1 shows three example uses of this tool.

Table 9-1  Line with Fixed Angle
Tool options Click point and constructed line

Angle: 30
Length: 20
Snap Point: Start

Angle: 45
Length: 30
Snap Point: Middle

Angle: 60
Length: 20
Snap Point: End
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Horizontal Line / Vertical Line

Menu: Draw > Line > Horizontal Line / Vertical Line
Keycodes: LH, LV

  

The tools for drawing horizontal and vertical lines work in the same way as the tool for lines with
a given angle. The only difference is that the angle is restricted to 0 degrees for horizontal lines
and 90 degrees for vertical lines.

Bisector

Menu: Draw > Line > Bisector
Keycode: LB

 

A bisector line is a line that divides the angle between two lines into two equal halves (Figure 9-6).

Figure 9-6: A bisector line divides the angle between two lines into two equal halves.

Usage

1. Enter the length of the line in the options toolbar.
2. Make sure that Number is set to 1.
3. Click the first line. This is one of the two lines that enclose the angle that will be

divided into two equal parts by the bisector line.
4. Click the second line.
5. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

The bisector tool can also be used to divide the angle between two lines into more than two equal
parts. This behavior is controlled by the Number option in the toolbar. Table 9-2 shows some
examples with different tool options.
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Table 9-2  Bisector Tool Examples
Tool options Click points and constructed lines

Length: 30
Number: 1

Length: 30
Number: 2

Length: 30
Number: 9

Parallel

Menu: Draw > Line > Parallel (with Distance)
Keycode: LP

 

The tool for drawing parallels is one of the most important drawing tools. The main reason for
this is that most man-made objects have many parallel edges and surfaces. Another reason is that
you will often know the distance between two lines which makes it convenient to use this tool
rather than having to indicate the start point and end point of a line.

Usage

1. Enter the distance of the parallel to the original, existing line in the options toolbar.
2. Make sure that Number is set to 1.
3. Move the mouse cursor close to an existing line in your drawing. QCAD shows a

preview of the parallel line before you click the mouse button. Note that there are two
possible parallels to any line: one on each side of the line. If you move the mouse cursor
somewhat to one side of an existing line, a parallel is shown at that side as shown in
Figure 9-7.

4. Click the left mouse button when the preview shows the parallel you want to draw.
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5. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Figure 9-7: The parallel is created on the same side
of the line on which the mouse cursor is positioned.

The parallel tool is sometimes also used to create multiple parallels to an existing line. Table 9-3
shows some examples with different tool options.

Table 9-3  Parallel Tool Examples
Tool options Click points and constructed lines

Distance: 5
Number: 1

Distance: 5
Number: 3

Parallel through Point

Menu: Draw > Line > Parallel (through Point)
Keycode: LG

 

This is an alternative tool for drawing parallels. Rather than creating a parallel with a distance
this tool creates a parallel through a given point.

Usage

1. Make sure that Number is set to 1.
2. Choose the line for which you want to create a parallel by clicking it.
3. Click the point through which the parallel line goes. This can for example be an existing

intersection point, grid point, end point, etc. The parallel is created as a line that is
parallel to the chosen line and goes through the chosen point as shown in Figure 9-8.

4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.
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Figure 9-8: With this tool, the parallel can be positioned to go through a given point.

Like with the first parallel tool, you can also create multiple parallels at once by typing a number
other than 1 in the options toolbar.

Tangent from Point to Circle

Menu: Draw > Line > Tangent (Point, Circle)
Keycode: LT1

 
This tool lets you create a tangent from a point to an existing circle or arc in your drawing. A
tangent is a line that exactly touches a circle in one point (Figure 9-9).

Figure 9-9: This tool lets you draw a tangent from a point to a circle.

Usage
1. Click the point through which the tangent goes.
2. Move the mouse cursor close to an existing circle or arc until a preview of the tangent

appears on the screen. Note that there are two possible tangents from a point to a
circle or arc. QCAD creates the one that is closer to the mouse cursor when clicking
the mouse button. If no preview of the tangent is shown it could be that no tangent is
possible between the chosen point and the circle (because the point is inside the circle).

3. Click the left mouse button to draw the tangent that is shown as preview.
4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Table 9-4 shows some example uses of this tool.

Table 9-4 Tangent from Point to Circle
Click points and constructed tangent



Drawing Tools Chapter 9

82

Click points and constructed tangent

Tangent from Circle to Circle

Menu: Draw > Line > Tangent (Two Circles)
Keycode: LT2

 

With this tool you can create a line that is tangential to two circles or arcs. This type of tangent
is a line that exactly touches the circle line of the two circles or arcs (Figure 9-10).

Figure 9-10: This tool lets you draw a line that is tangential to two circles or arcs.

1. Click the first circle or arc.
2. Move the mouse cursor close to the second circle or arc until a preview of the tangent

appears on the screen. Note that there are four possible tangents between two circles or
arcs. QCAD creates the one that is closest to the mouse cursor when clicking the mouse
button. If no preview of the tangent is shown it could be that no tangent is possible
because the point is inside either one of the circles.

3. Click the left mouse button to draw the tangent that is shown as preview.
4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Table 9-5 shows some example uses of this tool. Note that it does not matter where exactly you
click when you choose the first circle (at the left). Before you click the second circle, make sure
that the preview shows the tangent you want to create.
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Table 9-5  Tangent to Two Circles
Click points and constructed tangent

Orthogonal Line

Menu: Draw > Line > Orthogonal
Keycode: LO

 

This tool draws lines that are orthogonal to existing entities. Orthogonal means at a right angle or
at an angle of 90 degrees. If a line is orthogonal to another line, that means that the angle between
the two lines is exactly 90 degrees. It is also possible to draw a line orthogonal to an arc or circle.
In this case the line is orthogonal to a tangent of the arc or circle as shown in Figure 9-11.

Figure 9-11: A line that is orthogonal to an arc.
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Usage

1. Enter a length for the line in the options toolbar. The length usually does not matter at
this point. The line length can be adjusted later using modification tools.

2. Click the base entity. The line you are about to draw will be orthogonal to this entity.
The base entity can be another line, an arc or a circle.

3. Click the position of the orthogonal line.
4. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key

on your keyboard twice.

Table shows some example uses of this tool.

Tool options Click points and constructed orthogonal

Length: 20

Length: 20

Line with Relative Angle

Menu: Draw > Line > Relative Angle
Keycode: LR

 

This tool is similar to the orthogonal line tool but more flexible. It allows you to enter an alter-
native angle instead of 90 degrees. The line is then drawn at the given angle, relative to the base
entity.

Usage

1. Enter a length for the line in the options toolbar. Enter the angle between the base entity
and the line in the options toolbar.

2. Click the base entity. The angle you have entered before is the angle between the base
entity and the line you are about to draw.

3. Click the position of the line.
Note: If this tool is used with circular base entities, the entered angle is measured as
shown in the third example in Table 9-6. In most cases you will set the line position on
the circle line when using this tool with circular base entities.

4. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key
on your keyboard twice.

Table 9-6 shows some example uses of this tool.
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Table 9-6  Relative Angle
Tool options Click points and constructed line

Length: 20
Angle: 45

Length: 20
Angle: 60

Length: 20
Angle: 60

Freehand Line

Menu: Draw > Line > Freehand Line
Keycode: LF

 
This tool allows you to draw a freehand line for example for a break line. Break lines may be
used to reduce the size of an object in a drawing without scaling the whole object down. Figure
9-12 shows a part that is 1000 units long and only 5 units thick. If the part would be scaled down
to fit on a paper, the details at the end would hardly be recognizable anymore. Instead of drawing
the object in its full length, it has been broken up in two parts. At the break point, two freehand
lines may be used to make clear that these are break lines and not real edges.
Sometimes you might have to create a smooth curve that is neither a straight line nor an arc or
ellipse arc. In this case, the spline tool of QCAD might be more suitable for your purpose than
the freehand line tool.

Figure 9-12: Freehand lines are sometimes used for short break lines.
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Usage
1. Move the mouse to the start point of the freehand line.

Note that QCAD automatically switches off any object snaps when this tool it started.
With object snaps it would be impossible to draw a freehand line.
Because we cannot use object snaps when drawing freehand lines, it is difficult to
start and end a freehand line at an exactly defined location. The best solution to this is
usually to draw the freehand line somewhat longer than it has to be and later remove the
unwanted segments.

2. Press the left mouse button and keep it pressed down.
3. Move the mouse in the shape of the desired freehand line towards the end point of the

freehand line.
4. Let go of the left mouse button.
5. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

The freehand line tool actually produces a polyline rather than a series of lines. To edit a freehand
line you have to either explode it (break it up into individual lines) or use the polyline tools to
add or remove segments.

Arc Tools

Menu: Draw > Arc
Keycode: WA

 
Arcs are pieces or segments of circles. An arc has a center point, a radius, a start angle and an
end angle.
Figure 9-13 shows the CAD toolbar of QCAD with the tools for drawing arcs.

Figure 9-13: The CAD toolbar with the tools for drawing arcs.

You might be surprised that there is no tool to create an arc that rounds a corner. The tool for
rounding corners is in the modification toolbar since it does not only create an arc but also mod-
ifies the existing corner entities.



Part IV Drawing and Editing with QCAD

87

Arc from Center, Point and Angles

Menu: Draw > Arc > Center, Point, Angles
Keycode: AR

 

Use this arc tool if you know the center of the arc. Figure 9-14 shows the geometry of an arc with
the parameters that need to be defined with this arc tool.

Figure 9-14: An arc from a given center, point and angles.

Usage

1. Click the center point of the arc.
2. Define the arc radius by clicking a point on the circle line of the arc. This point does not

necessarily need to be on the arc itself but can also be on the extended circle line of the
arc as shown in Figure 9-14.
Alternatively, you can also enter the radius in the command line.

3. Choose the direction of the arc in the options toolbar (counterclockwise or clockwise):

4. Click the start point of the arc or any point on the line between the center and the start
point to define the start angle.

5. Click the end point of the arc or any point on the line between the center and the end
point to define the end angle.

6. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Arc from Two Points and Radius

Menu: Draw > Arc > 2 Points and Radius
Keycode: AD

 

This is the first of two tools which can be used to draw an arc from its start point and end point.
This tool also requires a radius to be input. Since there are four arcs possible, you also have to
define the direction and choose between the shorter or longer of the possible arcs. Figure 9-15
shows the two points with the four possible solutions in gray and the chosen solution in black.
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Figure 9-15: Arc from two points and a radius.

Usage

1. Click the start point of the arc.
2. Enter the arc radius and choose the arc direction (counterclockwise or clockwise) and

which solution you want (shorter or larger arc):

For the example in Figure 9-15 the direction was chosen as counterclockwise and the
solution.

3. Click the end point of the arc.
If the end point is two times the radius away from the start point or more, a half circle is
drawn with the given radius.

4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Arc from Two Points and Angle

Menu: Draw > Arc > 2 Points and Angle
Keycode: A2

 

This is the second tool to draw an arc from its start point and end point. With this tool you can
specify the angle that is covered by the arc and the arc direction. Figure 9-16 shows the two points
with the four possible solutions in gray and the chosen solution in black.
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Figure 9-16: Arc from two points and the covered angle.

Usage

1. Click the start point of the arc.
2. Enter the angle that is covered by the arc and choose the arc direction (counterclockwise

or clockwise):

For the example in Figure 9-16 the direction was chosen as counterclockwise and the
solution.

3. Click the end point of the arc.
4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Arc from Three Points

Menu: Draw > Arc > 3 Points
Keycode: A3

 

With this method you can draw an arc from its start point, a second point on the arc and its end
point (Figure 9-17).

Figure 9-17: An arc from three given points.
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Usage
1. Click the start point of the arc.
2. Click a second point on the arc. This point can be anywhere along the curve of the arc

between its start point and end point.
3. Click the end point of the arc.
4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Concentric Arc

Menu: Draw > Arc > Concentric (with Distance)
Keycode: AC

 

This tool creates arcs that are concentric to existing arcs. Concentric means having the same
center. The new arc has the same center as the original arc and also the same start and end angle.
Only the radius is different by the amount that you enter in the option toolbar. You can think of
this tool as the arc version of the parallel line tool. Of course strictly speaking arcs cannot be
parallel to other arcs but the usage of the tool is identical to the parallel line tool. In fact it is the
same tool and both tools can create parallel lines as well as concentric arcs, depending on the
base object that is chosen.

Usage
1. Enter the distance of the concentric arc to the original, existing arc in the options

toolbar.
2. Make sure that Number is set to 1.
3. Move the mouse cursor close to the original arc.

QCAD shows a preview of the concentric arc.
If you move the mouse cursor slightly to the inside of the arc, a concentric arc is created
that is smaller than the original arc. If you move the mouse cursor a bit to the outside of
the arc, a concentric arc is created that is larger than the original arc (Figure 9-18).

4. Click the left mouse button when the preview shows the concentric arc that you want to
draw.

5. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Figure 9-18: The concentric arc is created on the same
side of the arc on which the mouse cursor is positioned.

Just like the parallel line tool, this tool can also create multiple concentric arcs at once if you enter
a number other than 1 in the options toolbar.
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Concentric Arc through Point

Menu: Draw > Arc > Concentric (through Point)
Keycode: AG

 

Like the parallel tool for lines, the concentric tool for arcs also has a version which allows you
to specify a point through which the concentric arc goes.

Usage

1. Make sure that Number is set to 1.
2. Choose the arc for which you want to create a concentric arc by clicking on it.
3. Click the point through which the concentric arc goes. The arc is created as an arc that

is concentric with the chosen arc and goes through the chosen point as shown in Figure
9-19.

4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Figure 9-19: With this tool, the concentric arc can be positioned to go through a given point.

You can also create multiple parallels at once by typing a number other than 1 in the options
toolbar.

Tangentially Connected Arc

Menu: Draw > Arc > Tangentially Connected
Keycode: AN

 

With this tool you can create an arc that connects tangentially to an existing line or arc.

Usage

1. Enter the radius of the arc in the options toolbar.
2. Click the existing base entity to which you want to connect the arc. This can be a line or

an arc.
Note that the arc will be connected to the end that is closer to the cursor when clicking
the entity. So you have to click the entity close to the end to which you want to connect
the arc. In Figure 9-20, the base entity is the line and it is clicked closer to the end to
which the arc is being connected.

3. Define the length of the arc by clicking its end point or a point in that direction.
4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.
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Figure 9-20: This tool creates an arc that is tangentially connected to an existing base entity.

Table 9-7 shows some example uses of this tool.

Table 9-7  Tangentially Connected Arc
Tool options Click point and constructed arc

Radius: 10

Radius: 10

Radius: 10

Radius: 5

Radius: 5

Circle Tools

Menu: Draw > Circle
Keycode: WC

 

The circle tools of QCAD can be used to draw full circles.

Sometimes it can be practical to draw a circle instead of an arc if the start and end angle of the
arc are not yet known. A circle can later be split up into arcs with the appropriate modification
tools (divide, break out segment, trim).

Circles are also often used as auxiliary constructions to create useful intersection points. For
example if you need to find a point P that has a distance of 15 from an existing point A and a
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distance of 10 from an existing point B, you can easily find that point by creating two circles
around A and B as shown in Figure 9-21

Figure 9-21: Circles are often used as auxiliary constructions to create inter-
section points. Point P is 15 units away from point A and 10 units from point B.

Figure 9-22 shows the CAD toolbar of QCAD with the tools for drawing circles.

Figure 9-22: The CAD toolbar with the tools for drawing circles.

Circle from Center and Point

Menu: Draw > Circle > Center, Point
Keycode: CI

 

Use this tool if you know the center of the circle and a point on the circle line (Figure 9-23).
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Figure 9-23: Circle from a given center and a point on the circle line.

Usage

1. Click the center of the circle.
2. Define the circle radius by clicking a point on the circle line.
3. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Circle from Center and Radius

Menu: Draw > Circle > Center, Radius
Keycode: CR

 

Use this tool if you know the center of the circle and the radius of the circle. This tool is also
convenient to quickly produce a couple of circles with the same radius in different locations.

Usage

1. Enter the radius of the circle in the options toolbar.
2. Click the center of the circle(s).
3. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Circle from Two Points and Radius

Menu: Draw > Circle > 2 Points and Radius
Keycode: CD

 

This tool can be used to draw a circle from two points on the circle line and a given radius. There
are in most cases two possible circles that go through two given points, so you have to choose
which one of the possible circles you want to create. Figure 9-24 shows the two points with the
two possible solutions, the chosen solution for this example is shown in black, the alternative
solution in gray.
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Figure 9-24: Circle from two points and a radius.

Usage

1. Click a first point on the circle line.
2. Enter the circle radius and choose if you want to create the circle with its center at the

left or right of the line between the first and the second point:

For the example in Figure the solution with the center at the left of the line between the
two points was chosen.

3. Click the second point on the circle line.
If the second point is two times the radius away from the first point or more, a circle
with the given radius through the first point is drawn. The center is on the line between
the two points.

4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Circle from Two Opposite Points

Menu: Draw > Circle > 2 Points
Keycode: C2
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This tool draws a circle from two points that are opposite of each other on the circle line. The
diameter of the circle is equal to the distance between the two points (Figure 9-25).

Figure 9-25: A circle from two opposite points.

Usage
1. Click the first point on the circle line.
2. Click the second point, opposite of the first point.
3. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Circle from Three Points

Menu: Draw > Circle > 3 Points
Keycode: C3

 

With this method you can draw a circle from three points on the circle line. The three points can
be anywhere on the circle line (Figure 9-26).

Figure 9-26: A circle from three given points.

Usage
1. Click the first point of the circle line.
2. Click the second point on the circle line. This point can be anywhere on the circle line

but cannot be identical to the first point.
3. Click the third point on the circle line. This point can be anywhere on the circle line but

not identical with one of the other two points.
4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Concentric Circle

Menu: Draw > Circle > Concentric (with Distance)
Keycode: CC
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Like the tool for drawing concentric arcs, there is also a tool for drawing concentric circles.

Usage

1. Enter the distance of the concentric circle in the options toolbar.
2. Make sure that Number is set to 1.
3. Move the mouse cursor close to the original circle.

QCAD shows a preview of the concentric circle on that side of the circle on which your
mouse cursor is positioned.

4. Click the left mouse button when the preview shows the concentric circle that you want
to draw.

5. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Figure 9-27: The concentric circle is created on the same side
of the existing circle on which the mouse cursor is positioned.

Just like the concentric arc tool and the parallel line tool, this tool can also create multiple con-
centric circles at once if you enter a number other than 1 in the options toolbar.

Concentric Circle through Point

Menu: Draw > Circle > Concentric (through Point)
Keycode: CG

 

Like the concentric tool for arcs, the concentric tool for circles also has a version which allows
you to specify a point through which the concentric circle goes.

Figure 9-28: With this tool, the concentric cir-
cle can be positioned to go through a given point.

Usage

Please refer to the tool Concentric Arc through Point for the usage of this tool.
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Ellipse Tools

Menu: Draw > Ellipse
Keycode: WE

 

QCAD offers two basic ellipse tools: one to draw full ellipses and one for ellipse arcs with a start
angle and an end angle.

The shape of an ellipse is defined by its major axis and its minor axis. The major axis is usually
the axis at the largest diameter of the ellipse and the minor axis is the axis at the smallest diameter
as shown in Figure 9-29.

Figure 9-29: The shape of an ellipse is defined by its major axis and minor axis.

Note that there is also one other tool that produces ellipses: The tool for creating isometric pro-
jections. If you need an ellipse to represent a circle or arc in an isometric drawing, you might
want to look at that tool instead.

Figure 9-30 shows the CAD toolbar with the ellipse tools.

Figure 9-30: The CAD toolbar with the tools for drawing ellipses and ellipse arcs.

Ellipse from Center and Two Points

Menu: Draw > Ellipse > Full Ellipse
Keycode: EP
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This tool draws an ellipse with a given center, the end point of the major axis and the end point
of the minor axis (Figure 9-31).

Figure 9-31: Ellipse construction for a full ellipse.

Usage

1. Click the center point of the ellipse.
2. Define the major axis by clicking the point at the end of the axis. This defines not only

the length of the major axis but also the rotation angle of the ellipse.
3. Define the minor axis by clicking its end point or somewhere along the side lines A or B

as indicated in Figure .
4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Ellipse Arc from Center, Two Points and Angles

Menu: Draw > Ellipse > Ellipse Arc
Keycode: EA

 

This is a more flexible version of the ellipse tool. With this tool you can create ellipse arcs with
a start angle and end angle (Figure 9-32).

Figure 9-32: Ellipse arc construction.

Usage

1. Click the center point of the ellipse arc.
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2. Define the ellipse rotation angle and the length of the major axis by clicking the end
point of the major axis.

3. Define the minor axis by clicking its end point.
4. Click somewhere along the line from the center point to the start point of the ellipse arc

to define the start angle of the ellipse.
5. Click somewhere along the line from the center point to the end point of the ellipse arc

to define the end angle of the ellipse.
6. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Spline Tools

Menu: Draw > Spline
Keycode: WN

 

The spline tools of QCAD can be used to draw smooth curves that are not straight lines, arcs or
ellipse arcs. A spline is a curve that is mathematically exactly defined and can be reproduced at
any later point.

The spline tools of QCAD create so-called NURBS (Non-Uniform Rational B-Splines). NURBS
are a superset of Bézier splines. These splines are defined by a mathematical formula and have
two important characteristics:

• The curve is smooth and always remains smooth when the spline is modified. There are
never any sharp corners or 'kinks' in a spline curve.

• Editing a local segment of a long spline results only in local changes to the spline.

Control Points (Knots)

Splines are defined by a number of control points which are also called knots. You can also think
of the spline curve as a blend of the control points. Figure 9-33 shows a spline with four control
points. The control points of a spline are normally not visible in a drawing but shown in this
example for illustration purposes.

Figure 9-33: This spline is defined by four control points.
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Closed Splines

Splines might also be used to form one closed loop. Of course one could simply create an open
spline for which the first control point and the last control point are identical. However, this can
result in a sharp corner which is usually not desirable. The spline tool offers an option to create
closed, smooth (periodic) splines. Figure 9-34 shows a closed spline which has been defined with
the same four control points as the open spline in Figure 9-33.

Figure 9-34: A closed periodic spline with the
same four control points as the spline in Figure 9-33.

Spline Degree

The ‘smoothness’ of a spline is defined by its degree. QCAD can produce splines of degree 2
and 3.

Splines of degree 2 are also sometimes called quadratic splines and splines of degree 3 are known
as cubic splines. Cubic splines are smoother because every point on the spline is a blend of four
control points. For quadratic splines, every point on the spline is a blend of three control points.

Strictly speaking, splines can also have a degree of 1 (linear splines). In this case the control
points are connected by straight lines and we usually talk about polylines rather than splines.

Figure 9-35 shows two spline curves: a quadratic one and a cubic one. The first part of the qua-
dratic spline is a blend of the points A, B and C and the second part is a blend of points B, C
and D. For the cubic spline, the whole spline is a blend of all four points. For this reason, you
need to specify at least four control points for cubic splines while three control points are enough
for quadratic splines.

Fit Points

Creating splines from control points is often impractical since the control points are not located
on the spline curve. Changing the position of a control point might have unexpected effects and in
order to create the desired spline one often has to experiment. For this reason, QCAD also offers
an alternative spline tool that works with fit points. Fit points lay on the spline curve self which is
very convenient when a curve has to go through certain given positions. Internally, these splines
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are still defined by control points, but QCAD computes the control points automatically from the
given fit points. Splines created from fit points are always cubic splines.

Figure 9-35: Quadratic and cubic splines.

Figure 9-36 shows the CAD toolbar with the spline tools.

Figure 9-36: The CAD toolbar with the tools for drawing splines.

Spline from Control Points

Menu: Draw > Spline > Spline (Control Points)
Keycode: SP

 

Usage

1. Choose the spline degree in the options toolbar and tick the check box Closed if you
want to create a closed spline.

2. Click the position of the first control point. For open splines this is also the start point of
the spline.

3. Click any further control points. For quadratic splines you need to click at least three
control points, for cubic splines at least four.

4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Table 9-8 shows some example uses of this spline tool. The control points are only shown for
illustration purposes.
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Table 9-8  Spline from Control Points
Tool options Click points and constructed splines

Degree: 2
Open

Degree: 3
Open

Degree: 3
Closed

Spline from Fit Points

Menu: Draw > Spline > Spline (Fit Points)
Keycode: SL

 

Usage

1. Tick the check box Closed in the options toolbar if you want to create a closed spline.
2. Click the position of the first fit point. For open splines this is also the start point of the

spline.
3. Click any further fit points.
4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Table 9-9 shows some example uses of this spline tool. The fit points are also shown for illustra-
tion purposes. Note that splines from fit points are always cubic (3rd degree).

Table 9-9  Spline from Fit Points
Tool options Click points and constructed splines

Open

Closed
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Polyline Tools

Menu: Draw > Polyline
Keycode: WO

 

With the line tools of QCAD you can draw individual lines. In some cases, a number of lines
might be connected at the end points to form a string of line segments. This is for example the
case if the lines represent the outline of one single object, for example the border line of a country
as shown in Figure 9-37. Such objects are difficult to handle if they consist of individual lines.
For such cases, QCAD allows you to create one single object from a number of connected lines.
Such an object is called a polyline.

Figure 9-37: Connected outlines such as border lines (here the border line of
Switzerland) can be best represented in a drawing as one single polyline object.

A polyline consists of a number of connected lines and sometimes also arcs. These parts of a
polyline are called segments and the connection points between the segments are called nodes (see
Figure 9-38).

Figure 9-38: Polylines consist of segments. The
points at the ends of the segments are called nodes.

Polylines have the advantage that they guarantee that the segments are and remain connected. A
polyline can be moved as a whole and individual nodes may be moved but all segments remain
connected through these modifications.

Figure 9-39 shows the toolbar with the polyline tools of QCAD. These are not only tools to draw
new polylines but also to modify existing polyline nodes and segments.
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Figure 9-39: The CAD toolbar for polylines con-
tains all tools that are directly related to polylines.

Drawing a Polyline

Menu: Draw > Polyline > Draw Polyline
Keycode: PL

 

The tool to draw polylines is only convenient if all polyline nodes are already defined or easy
to define in your drawing. For example the symbols and profiles shown in Figure 9-40 can be
relatively easily drawn directly on the grid using the polyline tool.

For more complex polylines, it is almost always more comfortable to create the individual seg-
ments first with the normal line and arc tools of QCAD. These segments can then be joined to-
gether into a polyline later (see next tool Creating a Polyline from Segments).

Figure 9-40: Simple symbols and profiles can be easily drawn directly as polylines.
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Usage

1. Click the first point of the polyline.
2. Click any further points (nodes) of the polyline.
3. To create a closed polyline, you can either click the first point again in the end or simply

click the Close button in the options toolbar.
4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

It is also possible to draw arc segments directly. The polyline drawing tool limits arc segments
to be tangentially connected to the previous segment. The reason for this is that this type of arcs
is often used in polylines.

Creating a Polyline from Segments

Menu: Draw > Polyline > Create from Segments
Keycode: OG

 

This tool can be used to convert a number of connected lines and arcs into one single polyline.

Usage

1. Click any of the existing line segments or arc segments in your drawing.
Note that all segments of a polyline have the same color, line width, line style and
are on the same layer. If the existing segments in your drawing don't have the same
attributes, their attributes are adjusted to match the attributes of the segment you click.

2. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

To check if the conversion did what you expected, you can click the new polyline to select it. If
the conversion was successful, the whole polyline is now selected as one entity.

Adding a Node to a Polyline

Menu: Draw > Polyline > Insert Node
Keycode: OA

 

With this tool you can add a new node to an existing polyline. The new node is placed between
two existing nodes. In other words, this tool splits up a segment into two segments.

Usage

1. Click the segment of the polyline to which you want to add the new node.
In this example, that is the top segment:
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2. Click the position of the new node.
The top segment is split up into two segments and the new node is placed at the
specified location:

3. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Appending a Node to a Polyline

Menu: Draw > Polyline > Append Node(s)
Keycode: OP

 

This tool is used to add a node at either end of a polyline. Between the new node and the end of
the polyline, a new segment is inserted.

Usage

1. Click a segment of the polyline somewhere close to the end to which you want to
append the node.
In this example, that is the vertical segment at the top of the polyline:

2. Click the position of the new node.
A new segment is added at the specified end of the polyline:

3. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Deleting a Node

Menu: Draw > Polyline > Delete Node(s)
Keycode: OD

 

With this tool you can remove an individual node from a polyline.
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Usage

1. Click the polyline from which you want to remove a node.

2. Click the position of the node you want to remove. QCAD automatically snaps to end
points for this step:

3. QCAD removes the node. The two segments that connect to the node are replaced by
one straight segment:

If the last node at either end is selected for removal, the last segment of the polyline is
also removed.

4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Deleting Segments between Two Nodes

Menu: Draw > Polyline > Delete Segments between Two
Nodes

Keycode: OB  

This tool is efficient to remove multiple segments at once.

Usage

1. Click the polyline from which you want to remove segments.

2. Click the first limiting node. This node will remain in the polyline.
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3. Click the second limiting node. This node will also remain in the polyline.

4. All segments between the first node and the second node you have clicked are removed:

5. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Trimming Segments

Menu: Draw > Polyline > Trim Segments
Keycode: OT

 
The normal trim tools of QCAD don't work with polyline segments due to the restriction that
polyline segments are always connected. This tool allows you to trim two polyline segments to
each other.

Usage
1. Click the first segment you want to trim.

2. Click the second segment.

3. The first and the second segment are trimmed to their intersection point if there is any.
Other segments in between are removed to keep the polyline segments connected.

4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Polylines Offsets (Equidistant)

Menu: Draw > Polyline > Offset, Modify > Offset
Keycode: OQ

 
This tool is similar to the parallel tool for lines. It draws a parallel to a polyline, a so-called
equidistant polyline or polyline offset. An equidistant polyline is a polyline with a constant dis-
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tance to another polyline. All points on the equidistant polyline have an equal distance to the
original polyline.

Usage
1. Enter the distance of the offset polyline from the original polyline in the options toolbar.
2. Make sure that the tool is in polyline mode by checking the polyline mode button:

In polyline mode, the tool can be used to offset entire polylines or connected entities. In
segment mode, the tool offsets single line or arc segments:

3. Enter the number of offset polylines to create. Multiple offset polylines may be created
at equal distances.

4. Check the button for rounded corners (round join) to round sharp corners:

Or check the button for trimmed corners (miter join):

See also Table 9-10.
5. Click the original polyline. Just like with the parallel tool for lines, the equidistant

polyline is created on the same side of the original polyline on which you position the
mouse cursor.

6. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Table 9-10 shows some example uses of this tool.

Table 9-10  Equidistant Polyline
Tool options Click point and equidistant polyline

Distance: 2.5
Number: 1
No rounded corners

Distance: 2.5
Number: 1
No rounded corners

Distance: 2.5
Number: 1
Rounded corners
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Tool options Click point and equidistant polyline

Distance: 2.5
Number: 1
Rounded corners

Distance: 2.5
Number: 3
No rounded corners

Distance: 2.5
Number: 3
Rounded corners

Shape Tools

Menu: Draw > Shape
Keycode: WH

 

The shape tools of QCAD make it easier to draw common shapes directly without using the line
or polyline tools.

Figure 9-41 shows the toolbar with the shape tools of QCAD.

Figure 9-41: The CAD toolbar for shapes offers tools to
draw common shapes such as rectangles or polygons.

Rectangle

Menu: Draw > Shape > Rectangle
Keycode: RE

 

The rectangle tool lets you draw four lines (or a polyline) that form a rectangle. To define the
rectangle you only need to click two diagonally opposite corners.
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Figure 9-42: Example for drawing a rectangle from two diagonally opposite corners.

Usage

1. Click the position of the first corner of the rectangle. This can be any of the four
corners.

2. Click the position of the corner diagonally opposite of the first corner.
3. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Rectangle with Size

Menu: Draw > Shape > Rectangle with Size
Keycode: RS

 

The rectangle with size tool lets you draw a rectangle with a given width and height.

Usage

1. Enter the width and height of the rectangle you want to create.
2. Click the position of the rectangle. Depending on your choice of reference point, you

can position the rectangle by one of its corners, one of its middle points or its center.
3. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Polygon with Center and Corner

Menu: Draw > Line > Polygon (Center, Point)
Keycode: PG1

 

This tool makes it easy to create regular polygons. A regular polygon is a polygon with equal
sides and equal angles.

Usage

1. Enter the number of corners of the regular polygon. This is equal to the number of sides
of the polygon. For example 3 will create a regular triangle, 4 a square, etc.
Tick Create polyline if desired to create a polyline instead of loose line segments.

2. Click the center of the polygon.
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3. Click a position for a corner of the polygon.
4. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key

on your keyboard twice.

Table 9-11 shows some example uses of this tool.

Table 9-11  Polygon with Center and Corner
Tool options Polygon with Center and Corner

Number: 3

Number: 4

Number: 5

Number: 12

Polygon with two Corners

Menu: Draw > Line > Polygon (Two Corners)
Keycode: PG2

 

This tool offers an alternative way to define a regular polygon.

Usage

1. Enter the number of corners of the regular polygon and tick Create polyline if desired.
2. Click a position for the first corner of the polygon.
3. Click a position for the second corner of the polygon.
4. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key

on your keyboard twice.

Table 9-12 shows some example uses of this tool.

Table 9-12  Polygon with Two Corners
Tool options Click points and constructed polygon

Number: 3
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Tool options Click points and constructed polygon

Number: 4

Number: 5

Polygon (Center, Side)

Menu: Draw > Shape > Polygon (Center, Side)
Keycode: PG3

 

This tool draws a regular polygon from its center and a middle point of any side.

Usage

1. Enter the number of sides in the options tool bar and tick Create polyline if desired.
2. Click the center point of the polygon.
3. Click the middle point of any given side of the polygon.
4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Polygon (Side, Side)

Menu: Draw > Shape > Polygon (Side, Side)
Keycode: PG4

 

This tool draws a regular polygon from the middle points of two opposite sides or from two
opposite corners.

Usage

1. Enter the number of sides in the options tool bar and tick Create polyline if desired.
2. To create a polygon from two opposite corners, tick the Corner to Corner option.
3. Click the middle point of a side (or a corner) of the polygon.
4. Click the middle point of the opposite side (or the opposite corner) of the polygon. For

polygons with an uneven number of sides, one of the point chosen will be a corner point
and the other point the middle of a side.
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5. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.



Selection and Modification Chapter 10

116

Chapter 10

Selection and Modification

Objective
In this chapter, you will
• learn how to efficiently select entities in your drawing,
• get to know object handles (grips) and learn how to use them,
• read about the advanced tools that can be used to change your drawing,
• learn how to change entities with the property editor of QCAD.

Introduction

In the last chapter we have looked at the tools for drawing new entities. In this chapter we will
look at the tools for editing or modifying existing entities. When working with a CAD application,
you will often spend more time modifying entities than you spend drawing them. QCAD offers
many tools to modify entities in an easy and precise way.
Some of these tools may be familiar to you from other computer applications. It is for example
possible to copy a part of your drawing to the clipboard and paste it somewhere else again, just like
you are probably used to from a word processor. On the other hand there are many modification
tools in QCAD that are unique to CAD. For example there are tools to extend a line by an exact
amount or to make a part longer by stretching it.

Modification Tools Which Operate on a Selection

For modification tools that modify whole entities or a set of entities, you need to make a selection
first. To make a selection means to pick the entities you want to modify before you modify them.
For example if you want to move some entities of your drawing, you have to tell QCAD which
entities you want to move first as illustrated in the following example.

• In this example drawing, the circle should be moved 10 units to the right. The center
lines have to be moved with it:
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• The first step is to make a selection. Selections are shown in QCAD in a distinguished
red-brown color. Selected entities are also displayed with their reference points (small
blue squares):

• Now the move tool can be used to move the selection to the desired location.
Note that this tool is described in more detail later in this chapter.

This procedure is the same for all tools that modify a set of whole entities and therefore require
a selection. Other examples for such tools are: rotate, scale, mirror, delete or change attributes.

Modification Tools Which Operate without a
Selection

There are also modification tools that do not require a selection. They operate only on one or
two entities at a time or modify only a part of an entity. For example the trim tool can be used
to lengthen a line until it exactly meets with another line or arc. The following example shows
how the trim tool works.

• In this drawing the dashed line has to be extended towards the left until it meets exactly
with the arc. The whole modification involves two entities: the dashed line and the arc.
The only entity that is affected by the modification is the dashed line.

• First, the trim tool lets you pick the limiting entity, in this case the arc:

• Then you pick the entity that has to be trimmed. In this example that is the dashed line:
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• QCAD trims now the dashed line to the arc. It was not necessary for this tool to make a
selection of entities first.
You can find a more detailed description of this tool later on in this chapter.

This procedure applies for all tools that operate on a fixed number of entities. The entities have to
be picked in a certain order and sometimes even the exact pick point is relevant. For this reason,
the selection is not relevant for such tools. Other examples for tools that operate like this are:
stretch, bevel corner, round corner or divide.

Basic Selection Tools

When QCAD is in its neutral state, you can select and deselect entities in a very similar way as
in other applications.
QCAD is in its neutral state when no other tools are active. If you are not sure if this is the case,
you can click the button with the selection pointer on it in the toolbar at the top left:

This button terminates any tools that might be currently active and sets QCAD back into its
neutral state.

Selecting a Single Entity

1. Move the mouse cursor close to an entity.
For example to select the circle in this drawing, move the mouse cursor close to the
circle. You don't have to move it exactly on top of the circle but it should be within a
close range of it as shown here:

2. Click the left mouse button. The entity is now selected. QCAD highlights the entity in
a unique red-brown color to indicate that the entity is selected. Small blue squares are
shown at the reference points of the entity:
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Any previous selections are cleared and the clicked entity (in this example the circle) is
now guaranteed to be the only entity that is selected in the drawing.

Adding an Entity to the Selection

It is also possible to add an entity to the current selection. This way multiple entities can be
selected.

1. Move the mouse cursor close to an entity that is not yet selected, in this example the
vertical center line. Again, you don't have to position the cursor exactly on top of the
line, but it has to be closer to the line than to any other entity:

2. Hold down the Shift key on your keyboard and click the left mouse button. Then let
go of the Shift key. The entity is now selected. Any previously selected entities (in this
example the circle) are also still selected:

Removing an Entity from the Selection

By holding down the Shift key, you can also remove an entity from the current selection. Simply
click an entity that is already selected and it will be deselected.

Clearing the Current Selection

As in most graphics programs, you can clear the current selection by clicking somewhere into
the empty area of your drawing.

Selecting Entities inside a Rectangular Area

Sometimes you need to select many entities and picking them one by one would be too tedious.
For such tasks, QCAD offers a window selection feature that works very similar like in other
applications. The only difference is that it has two operation modes that you have to be aware of:
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• Window box selection. In this mode, all entities that are completely inside the
rectangular area are selected, as you would probably expect. For this mode, you have to
pick one of the left corners of the rectangular area first and drag the area selection from
the left to the right.
QCAD highlights the selection area in blue color and with a solid border.

• Crossing box selection. In this mode, all objects that are completely or partly inside the
rectangular area are selected. For this mode, you have to pick one of the right corners of
the rectangular area first and drag the area selection from the right to the left.
In this mode, QCAD highlights the selection area in green color with a dashed border to
indicate that also entities that are only partly inside the area will be selected.

Usage of window box selection:

To select entities that are completely inside a rectangular area, proceed as follows.
1. Move the mouse cursor to the upper or lower left corner of the rectangular area you

want to select:

2. Press the left mouse button and drag the mouse cursor to the diagonally opposite corner
of the rectangular area without letting go of the mouse button:

3. Let go of the left mouse button. QCAD selects all entities that are completely within the
chosen area:

Usage of crossing box selection:

To select also entities that are only partly inside a rectangular area, start the selection at the right
side instead.

1. Move the mouse cursor to the upper or lower right corner of the rectangular area you
want to select:



Part IV Drawing and Editing with QCAD

121

2. Press the left mouse button and drag the mouse cursor to the diagonally opposite corner
of the rectangular area:

3. Let go of the left mouse button. QCAD selects the entities completely inside the chosen
area as well as those that are only partly inside the area:

The Shift key has the same effect for this selection tool as when picking single entities. If you press
the Shift key while doing a rectangular selection, the selection is added to the current selection.
Otherwise, the previous selection is replaced with the new one.

Advanced Selection Tools

In addition to the simple selection tools described so far, QCAD offers some more selection tools
for advanced selection needs. Those more advanced selection tools can only be accessed through
menu Select or through the selection tools button in the CAD toolbar at the left:

Menu: Select
Keycode: WS  

Figure 10-1 shows the CAD toolbar with the complete palette of selection tools.

Figure 10-1: The CAD toolbar showing the advanced selection tools.

Note that some of these tools are also available in the neutral mode of QCAD as basic selection
tools as previously described.
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Selection Modes

Some of the selection tools offer different selection modes. The selection mode that is chosen
defines how the newly chosen selection affects the current selection. The default selection mode
replaces the current selection with the new selection.

Table 10-1  Selection modes for the rectangle
selection tool and other selections tools.

Selection Mode Description

Replace Replaces the current selection with the new selection.
If used for example with the rectangle selection tool, all entities inside the
rectangle are selected and everything else is deselected.

Add Adds all matching entities to the current selection.
For the rectangle selection tool, all entities inside the rectangle are
selected in addition to the entities that were already selected before using
the tool.

Subtract Subtracts all matching entities from the current selection.
This turns for example the rectangle selection tool into a rectangle
deselection tool. All entities inside the rectangular area are deselected.
Entities outside the rectangle that were previously selected remain
selected.

Intersect Intersects the current selection with the new selection.
After using the rectangle selection tool with this selection mode, only
entities that were already selected and that are inside the rectangle are
selected.

Deselecting Everything

Menu: Select > Deselect All
Keycode: TN

 

Click this button to clear any selections. Alternatively, you may want to simply click into an
empty area of your drawing to deselect everything.

Selecting Everything

Menu: Select > Select All
Keycode: TA

 

Click this button to select all visible, editable entities of your drawing. Entities on layers that are
hidden or locked are not selected by this tool. This prevents you from accidentally selecting and
later modifying or deleting something you are not aware of because it is hidden.

Note that those entities which are on a visible, unlocked layer but are not within the currently
visible area of the screen are also selected with this tool.
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Inverting Selection

Menu: Select > Invert Selection
Keycode: TI

 

With this tool you can quickly invert the current selection. The tool selects all not selected entities
and deselects all selected entities. This is especially useful if you need to modify almost your
entire drawing, except a few entities. In this case you might want to select the entities which
should remain the same and then invert the selection with this tool.

Selecting Rectangular Areas

Menu: Select > (De-)Select Rectangular Area
Keycode: TR

 

This is an alternative tool for selecting and deselecting entities inside a rectangular area. This tool
is similar like the basic window selection tool described in the previous section. The advantage
of this tool is that you may choose a selection mode in the options tool bar. Table 10-1 shows
what the different selection modes do.

In addition to the selection mode, you can also choose if entities which are not completely inside
the area but intersect (‘cross’) the selection area also match the selection.

Usage

1. Choose the desired selection mode (see Table 10-1) and tick the option ‘Cross
Selection’ in the options tool bar if desired.

2. Click the first corner of the selection area.
3. Click the second corner of the selection area.

Selecting Polygonal Areas

Menu: Select > (De-)Select Polygon
Keycode: TP

 

This tool selects or deselects entities inside a polygonal area.

Usage

1. Choose the desired selection mode (see Table 10-1) and tick the option ‘Cross
Selection’ in the options tool bar if desired.

2. Click the first corner of the polygonal selection area.
3. Click the second corner and any further corners of the polygonal selection area. To set

the last corner, click the right mouse button or press the Escape key.
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Selecting Contours

Menu: Select > (De-)Select Contour
Keycode: TC

 

This tool is especially handy when dealing with complex shapes of connected entities, for example
a number of connected lines that form the outline of an object.

Figure 10-2 shows a floorplan with wall outlines, interiors, a staircase, etc. If you for example
want to create a solid fill for all the walls, you will have to select the wall outlines first. This
could be quite tedious with all those other objects in between them. The tool to select contours
can be useful in such a situation.

Figure 10-2: A floorplan with wall outlines and interiors. The tool to
select contours can be used to easily select only the wall outlines.

Usage

1. Choose the desired selection mode (see Table 10-1).
2. Move the mouse cursor to an entity that is part of the contour you want to select. In this

example, that is the wall outline at the top / right:
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3. Click the left mouse button. All entities that are directly or indirectly connected to the
entity you have picked are selected:

Selecting Intersected Entities

Menu: Select > (De-)Select Intersected Entities
Keycodes: UX, TX

 

This tool selects entities that are arranged in a straight line but cannot be selected using the window
selection tool.

In the example drawing in Figure 10-3, all circles from the lower left diagonally to the upper right
are to be selected. The window selection tool is not useful in this case since a rectangular area
around those circles would also select all the other circles.

This tool lets you draw a line instead to select all entities that are intersected by this line.

Figure 10-3: Entities that are in a row, but neither verti-
cally nor horizontally can be easily selected with this tool.

Usage

1. Choose the desired selection mode (see Table 10-1).
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2. Click the first point of the selection line with the left mouse button:

3. Move the mouse cursor to the end point of the selection line. QCAD shows a red dashed
line. All entities that are intersected by this line at the moment when you click will be
selected:

4. Click the left mouse button. QCAD selects the circles that were intersected by the
selection line:

The tool to deselect intersected entities can be used in the same way to deselect entities that are
arranged in a straight line.

Selecting a Layer

Menu: Select > (De-)Select Layer
Keycode: TL

 

This tool lets you select or deselect all entities on a layer by clicking one entity on that layer.

Usage

1. Choose the desired selection mode (see Table 10-1).
2. Click with the left mouse button close to an entity that is on the layer which you want to

select.
3. QCAD selects all entities that are on the same layer.

If the entity you have picked was already selected, the whole layer is deselected instead.
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Basic Modification Tools

QCAD offers many modification tools to perform different kinds of modifications and transfor-
mations on your drawing. Besides those CAD specific precision tools, there are also some basic
tools that are provided for convenience and to provide the standard functionality you can expect
from nearly every application. These basic modification and editing tools include:

• Delete, cut, copy, paste functionality.
• Moving reference points with the mouse (drag and drop).
• Moving entities with the mouse (drag and drop).

Cut, copy and paste are among the favorite tools of many computer users and most likely you have
already come across these features in many other applications. In QCAD these tools operate in a
similar way as you would probably expect. In addition, QCAD offers some features in connection
with these tools that make them even more powerful.

Many applications and most operating systems with a graphical user interface are using drag and
drop to move or copy things, for example to move or copy files. In such operations it is usually
not required to position the object precisely. In QCAD, drag and drop functionality has been
implemented in such a way that you can still work with the usual precision of a CAD system.

Deleting Entities

Menu: Edit > Delete
Keycodes: ER, Delete, Backspace

 
With this tool you can delete all selected entities. You can also simply make a selection and hit
the delete key on your keyboard instead.

Usage
1. Make a selection of entities to delete.
2. Click the delete tool button shown above or hit the delete or backspace key on your

keyboard.
3. QCAD removes the selected entities from the drawing.

Cut, Copy and Paste

Menu: Edit > Cut
Keycodes: CT, Ctrl-X (Mac: ⌘X)

 
Menu: Edit > Copy
Keycodes: CP, Ctrl-C (Mac: ⌘C)

 
Menu: Edit > Paste
Keycodes: PS, Ctrl-V (Mac: ⌘V)

 
The cut, copy and paste tools use an internal, temporary storage called the clipboard. The clip-
board is used by QCAD to temporarily store entities which can later be inserted into the same or
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a different drawing. By pasting the clipboard into a different drawing, it is possible to move or
copy entities, layers and blocks from one drawing document to another.

The cut tool and the copy tool are very similar. They both put the selected entities on the clipboard.
The only difference is that the cut tool deletes the original entities while the copy tool leaves
them in place.

The example drawing in Figure 10-4 shows the top view of a chair and a table. Using the cut and
paste tools, we will move the chair and place it at the table. We will also make another copy of
the chair and place it at the opposite side of the table.

Figure 10-4: The cut and paste tools are best suited to
place two copies of the chair at the table in this drawing.

Usage

1. Select the entities you want to cut or copy.
In our example, we select all entities that make up the chair:

2. Click the copy tool:

or the cut tool:

For this example, we use the cut tool, since we do not want to keep the original
selection. The original chair is removed from the drawing:
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The selection is now stored on the clipboard and the drawing has no selected entities
anymore.

3. You can paste the clipboard contents into any drawing anytime later on. Note that the
clipboard contents is lost if you quit the QCAD application.
To paste the clipboard contents, click the paste tool:

4. Other applications usually paste the clipboard contents in the same position from where
it was cut or copied or anywhere in a drawing. QCAD chooses a more flexible approach
and allows you to precisely position the pasted entities with the mouse or by entering a
coordinate.
In this example, we want to place the chair at the table as shown below. Click the left
mouse button to place the chair in this position:

5. You can directly continue to paste the clipboard contents multiple times and if desired
with different rotation angles, scales, etc.
In our case, we want to place another copy of the chair at the opposite side of the table.

6. This time, type a rotation angle of 180 into the options toolbar at the top:
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7. The chair is rotated by 180 degrees and you can place it now by clicking the left mouse
button at the lower position:

As you have noticed, QCAD automatically uses the center point of the selection as reference
point when pasting entities. In the example above, the center point of the chair has been used as
reference point to position the chair in the drawing. This is not always convenient when creating
precise drawings. Therefore, QCAD offers two alternative tools to cut or copy entities to the
clipboard with a custom reference point.

Cut and Copy with Reference Point

Menu: Edit > Cut with Reference
Keycodes: RT, Ctrl-Shift-X (Mac: ⌘⇧X)

 
Menu: Edit > Copy with Reference
Keycodes: RC, Ctrl-Shift-C (Mac: ⌘⇧C)

 

Figure 10-5 shows the side view of the previous example drawing with the chair and the table.
Again, we want to move the chair closer to the table using cut and paste. This time it is important
that the pasted chair is aligned at the bottom with the table. Using the center of the chair as
reference point might not be convenient in this situation.

Figure 10-5: To place the chair at an exact position, the tool Cut with Reference can be used.
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Usage

1. Select the entities you want to cut or copy.
In the example, that is the side view of the chair:

2. Choose the tool "Copy with reference":

or the tool Cut with Reference:

Since we want to remove the original chair in this example, we choose the tool Cut with
Reference.

3. QCAD now asks you to specify the reference point. Click a point in the drawing to use
as reference point. This can be any point but is typically a significant point within the
selection or a grid point.
For our example, we choose the corner point at the lowest right edge of the chair:

4. As soon as you have chosen the reference point, the original entities are removed from
the drawing and stored on the clipboard:

5. You can now use the paste tool to paste the clipboard contents. Note that there is only
one paste tool which always requires you to position the pasted entities:
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6. Make sure that the options in the options tool bar are reset to a rotation angle of 0, a
scale of 1 and that the mirror buttons are not activated. To quickly reset all values, click
the reset button at the right of the options toolbar:

7. Click the left mouse button to place the entities. The entities can now be positioned by
the previously chosen reference point.
For this example, this means that you can position the chair to be exactly aligned with
the bottom of the table by clicking one of the grid points on the same height as the
ground level:

8. We can continue to place another copy of the chair at the other side of the table.
Click the vertical flip button in the options toolbar to mirror the chair horizontally:

9. You can now place the mirrored chair in the same way as before:

As you might have noticed, the options toolbar of the paste tool also offers some options we
did not discuss. While pasting something, you can not only rotate or flip it but also scale it.
Simply type a scale factor into the Factor field of the options toolbar. At the right of the options
toolbar there is a check box with the label To current Layer. If you tick this check box all pasted
entities will be placed on the current layer rather than their original layer. This is usually only
recommendable if all entities on the clipboard are on one single layer and have to be pasted on
another layer.

Moving Reference Points

Whenever an entity is selected in QCAD, its reference points are shown as small blue squares.
Reference points are the defining points of an entity. For example for a line, the reference points
are the start point and the end point. Reference points are sometimes also called object handles or
object grips. When QCAD is in its neutral state, you can modify an entity by moving one of its
reference points with the mouse. In the example in Figure 10-6 we want to move the left end point
of the long horizontal line to change the shape of the mechanical part from a cylinder into a cone.
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Figure 10-6: The long cylinder shape in the upper drawing can
be quickly changed into a cone as shown in the lower draw-

ing by moving the left reference point of the long horizontal line.

Moving a Single Reference Point

1. Select the entity for which you want to move a reference point.
In this example, we want to change the long, horizontal line to shape a cone:

2. Move the mouse pointer very close to the blue reference point that you want to move:

3. Press the left mouse button and hold it down.
4. Move the mouse cursor until the mouse pointer turns into a crosshair. Then you can let

go of the mouse button. It does not matter at this point where exactly the mouse cursor
is (the entity will not yet be modified).

5. Set the new position of the reference point by clicking the left mouse button. You can
use any of the object snaps or the grid snap to position the reference point precisely:

It is also possible to move more than one reference point if they are in the same position. This
makes it for example possible to move a corner.
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Moving Multiple Reference Points

1. Select the entities which you want to modify.
In this example, we want to change the cone without affecting the horizontal cylinder
line. The vertical edge between cone and cylinder has to be modified, so we select the
cone line and the vertical edge:

2. Move the mouse pointer very close to the blue reference point that you want to move.
In this example, there are actually two reference points at the same location, where the
cone line and the vertical edge meet:

3. Press the left mouse button and hold it down.
4. Move the mouse cursor until the mouse pointer turns into a crosshair.
5. Set the new position of the reference point by clicking the left mouse button. Use the

object snaps or the grid snap as appropriate:

Table 10-2 shows some more examples of how entities can be modified by moving reference
points.

Table 10-2 Moving Reference Points

Moving the end
point of a line.

Moving the end
point of an arc.

Moving the center
point of an arc.

Changing the radius
of an arc or circle.

Changing one radius and the
rotation angle of an ellipse.

Moving the end angle
of an ellipse arc.



Part IV Drawing and Editing with QCAD

135

Moving the end
point of a line.

Moving the end
point of an arc.

Moving the center
point of an arc.

Moving a control
point of a spline.

Moving a node of a polyline.

You can also move reference points of more complex entities such as dimensions. This is de-
scribed in part 5 of this book.

Moving Entities

The most flexible tool for moving entities is described in the next chapter. Sometimes it can be
handy to quickly move an entity by simply dragging it to another place. Like most features of
QCAD, this one is also designed to work more precisely than the features of a regular drawing
program. Like the cut, copy and paste tools, dragging entities also operates on clearly defined
reference points.

In the example drawing in Figure 10-7, the screw on the left has to be moved up to align exactly
with the thread on the right.

Figure 10-7: Drag and drop can be used to quickly and precise-
ly move entities. In this example, the two parts have to be aligned.



Selection and Modification Chapter 10

136

Usage

1. Select the entities you want to move.
In this example, that is the screw:

2. Move the mouse cursor close to one of the selected entities. Make sure that the mouse
cursor is not very close to one of the blue reference points.
For this example, we move the mouse cursor close to the center line of the screw,
somewhat closer to the right side of the center line. This decision influences the
reference point that is used to place the selection later on:

3. Press the left mouse button down and hold it down.
4. Move the mouse cursor. It does not matter in which direction or exactly how far at this

point. Moving the mouse cursor a significant distance simply tells QCAD that you are
intending to move the selection using a drag and drop operation.

5. As soon as the mouse pointer turns into a crosshair, you can let go of the left mouse
button. The position where exactly you do this is still irrelevant since this does not yet
define the new position of the entities.
• QCAD automatically determines the reference point for the move operation as

follows:
The reference point is one of the reference points of the entity that is the closest to
the mouse cursor when starting to drag. In the example, that is the center line.

• If that entity has more than one reference point, the reference point that is the closest
to the mouse cursor is chosen.

6. You can now reposition the selection using the usual object and grid snaps of QCAD.
Click the left mouse button when the position is correct.
In this example, we position the screw on the same height as the thread at the right:
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Advanced Modification Tools

For more advanced modifications, QCAD offers a large number of modification tools. These tools
can be accessed through the Modify menu or through the CAD toolbar by clicking the modify
button:

Menu: Modify
Keycode: WM

 

Figure 10-8 gives an overview of the modification toolbar of QCAD. Note that the menu ‘Modify’
has some more, less frequently used modification tools.

Figure 10-8: The CAD toolbar with the modification tools of QCAD.

Moving / Copying Entities

Menu: Modify > Move / Copy
Keycode: MV

 

This tool can be used to move or copy entities to a new location. It can also make multiple copies
that are lined up with a uniform distance between them.
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Usage

1. Select the entities you want to move or copy.
In this example, we want to line up multiple tree symbols along the road with a uniform
distance between them, so we select the tree symbol for modification:

2. Start the modification tool:

3. Click a reference point for moving the entities. This point will be used to place the
entities at the target location. Choosing the best reference point can save you a lot of
time.
Choosing the reference point at the end of the road curb allows us to move the tree
along the road without any auxiliary constructions or calculations:

4. Click the target point. The selection will be moved or copied by the distance between
reference point and target point.
Since we chose the reference point to be at the end of the road curb, we can now define
the target point to be for example 6 meters away from the end point. For that, we choose
the snap tool to snap to a point with a given distance from an end point:

We enter 6 for the distance and place the tree by clicking close to that end of the road
curb from which the distance is measured:
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5. QCAD pops up a dialog with some options for this modification:

• The choice Delete original has the effect that the selection is moved to a new
location.

• The choice Keep original makes one copy of the selection.
• The choice Multiple copies makes any desired number of copies from the selection.

The copies are all lined up with a uniform distance.
• With the Use current layer and attributes option, all copies are created with the

current pen (line width, line color and line style) instead of the same pen as the
original entities. Further, all copied entities are placed on the current layer instead of
their original layer. This option is almost never used.

• For our example, we choose the option Multiple copies and enter 4 for the number
of copies to create four copies of the tree along the road. Note that creating four
copies means that there will be five trees in the end, since we also keep the original
tree.

6. Click OK to confirm the options.
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7. QCAD creates the copies, or moves the selection depending on the options you chose in
the dialog.
In our example, the original tree is copied four times parallel to the road with a distance
of 6 meters from one tree to the next one:

Rotating Entities

Menu: Modify > Rotate
Keycode: RO

 

This tool rotates a selection around a center point by a given angle. Like the move tool, this tool
can delete the original, copy the original or make multiple rotated copies of the original.

Usage

1. Make a selection for the rotation.
The example for this tool is a rotationally symmetric mechanical part. The selected part
shown here has to be present five times, evenly rotated around the center of the part:

2. Click the rotation tool button:
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3. Click the center of the rotation.
In the example, that is the center of the part:

4. QCAD pops up a dialog window with the options for the rotation, most importantly the
rotation angle:

The choices for the number of copies, attribute usage and layer usage have the same
meaning as for the move / copy tool.
Note that for a counter-clockwise rotation you have to enter a positive rotation angle
and for a clockwise rotation a negative angle.
Since we want to have five evenly distributed copies of the selection around the center,
we choose the option Multiple copies and enter 4 for the number of copies. For the
angle we enter 360/5. Of course we could also enter 72, but letting QCAD compute the
value is usually more convenient and prevents mistakes.

5. Click OK to confirm the options.
6. QCAD creates the rotated copies of the selection:
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Scaling Entities

Menu: Modify > Scale
Keycode: SZ

 

Scaling means to change the size of the selected entities, usually while maintaining proportions.
The selection can be scaled up (making it larger) or down (making it smaller).

Usage

1. Select the entities you want to scale.
The example for this tool contains dimension entities that indicate the part size:

We select the whole part for scaling in this example:

2. Click the scale tool button:

3. Click the center for the scaling operation. The selection will be scaled towards or from
this center.
In the example, we choose the lower left corner as the center:

4. The dialog with the scaling options is shown:
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The choices for the number of copies, attribute usage and layer usage have the same
meaning as for the move / copy tool or the rotation tool. Creating copies when scaling is
very unusual though and Delete original is by far the most common choice.
At the right side of the scale factor, there is a button with a chain on it. It is usually
checked to indicate that only one factor can be entered. In that case, the scale factor in
Y direction is the same as the factor in X direction (proportional scaling). In most cases
you will want to use proportional scaling. Non proportional scaling is only supported
for line entities and polyline entities which only contain line segments.
We enter the number 2 for the factor to double the size of the part. If we would want to
scale the part down to half its size, we would enter the number 0.5 or 1/2 instead.

5. Click OK to confirm the options.
6. QCAD scales the part up and deletes the original:

Note that the dimension labels have been adjusted automatically to show the correct
measurements.

Mirroring Entities

Menu: Modify > Mirror
Keycode: MI
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The mirroring tool is helpful to create symmetrical drawings. The symmetry is defined by an
axis of symmetry. All objects on one side of the axis are mirrored (or flipped) to the other side
of the axis.

Usage

1. Select the entities you want to mirror.
For this example, we assume that you have already created the side view and half of the
front view of a chair. The other half of the front view can be created by mirroring the
existing half along a vertical axis of symmetry.

In the first step, we select the existing half:

2. Click the mirror tool button:

3. Click the first point of the axis of symmetry.
In the example, we choose a point at the top along the vertical symmetry axis:

4. Click the second point of the symmetry axis. The symmetry axis is shown as a red dash-
dotted line.
We choose a point vertically below the first point of the symmetry axis:

5. QCAD shows the dialog with the mirroring options:
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The choices for the number of copies, attribute usage and layer usage have the same
meaning as for the move / copy tool, the rotation tool and the scaling tool. The only
difference is that you can only create no copy (Delete original) or one copy (Keep
original) but not multiple copies with this tool. The most common option is Keep
original.

6. Click OK to confirm the options.
7. QCAD mirrors the selection:

Moving and Rotating Entities

Menu: Modify > Move and Rotate
Keycode: MR

 

With this tool you can move and at the same time rotate a selection. This tool is usually used
to create multiple copies of an object beside each other with each copy rotated a bit more than
the previous one.

Usage

1. Select the entities you want to move and rotate.
For this example, we want to copy the hour hand of the clock at the left to the other
three clocks. The second clock should display the time 4 o'clock, the third one 5 o'clock
and the fourth one 6 o'clock:

In the first step, we select the hour hand:
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2. Start the modification tool:

3. Click a reference point for moving the entities. This is also the center for the rotation.
We choose the reference point at the center of the clock:

4. Enter the rotation angle in the options toolbar. This step is optional since you can also
adjust the rotation angle later in the dialog, but entering it at this point allows you to
display the correct preview and detect any potential errors already.
For our clock example, we enter the angle -360/12 or -30:

Note that positive angles rotate counterclockwise and negative angles clockwise.
5. Move the mouse cursor to the center of the second clock and check if the correct

preview is shown for the rotation. If that is not the case, correct the angle in the options
toolbar.
In the clock example, the preview looks like this:

6. Click the left mouse button to set the target point for the first copy.
7. QCAD shows the dialog with the options for this tool:
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The choices for the number of copies, attribute usage and layer usage are the same as
for previous tools.
We choose the option Multiple copies and enter 3 for the number of copies. This will
create three copies of the hour handle. The angle has already been entered before and
does not need to be adjusted anymore.

8. Click OK.
9. QCAD creates the copies with the specified distance and rotation angle:

Rotating and Counter-Rotating Entities

Menu: Modify > Rotate Two
Keycode: R2

 

This tool is related to the move and rotate tool as it also combines two transformations into one
operation. Although this tool is quite flexible, in practice it is almost exclusively used to distribute
a selection evenly on a circle around a center without actually rotating the selection. This is also
sometimes referred to as polar duplicate. Figure 10-9 shows an example for such a part.

Figure 10-9: This tool is usually used to distribute a selection in a circular pattern.
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Usage

1. Select the entities you want to rotate.
In our example that is the elongated hole at the right:

2. Start the rotation tool:

3. Click the center point for the primary rotation. The selection will be rotated around this
center.
We choose the center point for the rotation at the center of the drawing:

4. Click the center for the secondary rotation. This is usually at the center of the small part
that is rotated around the center point for the primary rotation.
In this example, we choose the center of the elongated hole:

5. QCAD shows the dialog with the options for this tool:
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For our example we want to create 7 copies. The main rotation angle a is 45 degrees
and the secondary rotation angle b is -45 degrees. The secondary angle b usually has
the same value as the main rotation angle a, but with the opposite sign. This keeps the
rotated selection exactly straight.

6. Click OK.
7. QCAD creates the rotated copies with the specified rotation angles.

The finished example looks like this:

Trimming Entities

Menu: Modify > Trim
Keycode: RM

 

The trim tool provides a way to trim an entity to meet another entity. The entity is shortened or
extended in such a way that the end point exactly touches the other entity.

For example in the drawing shown in Figure 10-10 we can trim the upper one of the horizontal
lines to the skewed line to form an L-shape.
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Figure 10-10: With the trim tool, the upper one of the horizontal lines at the left can be
shortened in a way that the end point is exactly on the skewed line as shown at the right.

Note that this tool does not operate on a previously made selection. Any existing selection is
ignored.

Usage

1. Start the trim tool:

2. Pick first the limiting entity. This entity will not be changed in any way but it defines
the position to which the other entity should be trimmed.
For the example drawing, we choose the skewed line to which we want to trim the
horizontal line:

3. Click the entity you want to trim. Note that it is significant where you click the entity.
Click the entity on that part which you want to keep, not the part you want to trim away
when shortening an entity.
In this example, we choose the horizontal line somewhere at the right of the intersection
point between the limiting line and the line that has to be trimmed:

4. QCAD trims the horizontal line to meet exactly with the skewed line:

Table 10-3 shows more examples for trim operations. Pay special attention to the relevance of
the click points.
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Table 10-3 Trimming
Choosing the
limiting entity

Choosing the trim
entity(ies)

Result after
trimming

Extending a line to another
line.

Shortening a line to another
line. Note how the click point
used when choosing the
entity to trim defines which
part of the line is kept and
which one is trimmed. The
part you click on is always
the part you want to keep.
Here that is the left part.

Here the right part is clicked
and kept.

Trimming a line to an arc.

The click point when
choosing the limiting entity
can also be relevant since
there are two possibilities
how an arc can limit the
trimming of a line.

Trimming a circle to a line.
Because a circle has no end
points, the circle is changed
into an arc and both arc end
points are trimmed to the
limiting entity.
Here, the top part of the
circle is meant to stay
and the bottom part to be
trimmed (removed).
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Choosing the
limiting entity

Choosing the trim
entity(ies)

Result after
trimming

In this example, an arc is
created from the bottom part
of the circle. The top part is
removed.

This example shows how
multiple entities can be
trimmed to the same limiting
entity. Simply click the
limiting entity and then click
all entities to trim to it.

Trimming Both Entities

Menu: Modify > Trim Both
Keycode: TM

 

This trim tool trims two entities in one step to each other. The two entities form an exact corner
after this operation. Figure 10-11 shows an example in which two lines are trimmed to each other
to form a corner.

Figure 10-11: This trim tool efficiently trims two entities to each other.

This tool does not operate on a selection.

Usage

1. Start the trim tool to trim both entities:

2. Pick the first trim entity. This is also the limiting entity for the second trim entity. Keep
in mind to click the entity at that part which you still want to see after trimming.
For the example drawing, we choose one of the lines we want to trim. We click the line
above the intersection point to make sure that this part of the line will not be trimmed
away:
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3. Click the second entity you want to trim, again at that side of the intersection which will
be a part of our corner.
We click the second line at the right of the intersection point in our example:

4. QCAD trims the two lines to form an exact corner:

Lengthening Entities by a Given Amount

Menu: Modify > Lengthen / Shorten
Keycode: LE

 

With this tool you can lengthen or shorten entities by a given amount. For example you can make
a line exactly 5 units longer at one end. This tool is often used to extend center lines and other
auxiliary lines.

Figure 10-12 shows a typical example usage for this tool. The center lines of the circle at the left
have to be extended over the edge of the circle line as shown at the right.

Figure 10-12: The center lines of the circle at the left can be ex-
tended by an exact amount over the circle line with this tool.

Usage

1. Start the lengthen tool:

2. Enter the lengthening distance in the options toolbar. Enter a positive value to lengthen
an entity and a negative value to shorten an entity.
For example, enter 4 to extend entities by 4 units:
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3. Pick the entity to lengthen or shorten by the amount you have entered. Click the entity
closer to that end which you want to change.
To extend the vertical center line 4 units towards the top, we click the line somewhere in
the upper half:

4. QCAD lengthens the line accordingly:

In the same way, the other ends of the center lines can be lengthened into their final
shape:

Stretching

Menu: Modify > Stretch
Keycode: SS

 

The stretch tool is a very powerful tool that allows you to stretch complex constructions. Most
of the time the stretching direction is orthogonal (to the right, left, top or bottom of the drawing).
Stretching in QCAD means to move all end points inside a rectangular area. If both end points
of an entity are inside the rectangle, the whole entity is moved. If only one end point is inside
the rectangle, only that end point is moved.

The middle part of the roof structure at the top in Figure 10-13 can be stretched with this tool
as shown at the bottom.
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Figure 10-13: The stretch tool is usually used to
vertically or horizontally lengthen a construction.

Usage

1. Start the stretch tool:

2. Click the first corner of the rectangular stretch area. All end points inside that area will
be moved.
For the roof example, we choose the first corner of the stretch area approximately as
shown here:

3. Click the second corner of the stretch area. QCAD shows the stretch area with a dashed
rectangle.
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4. Click a reference point for the movement, for example a grid point.
For the example, we choose the top right corner of the roof:

5. Click the target point for the movement.
In our case, we stretch the roof in horizontal direction:

6. QCAD stretches the roof:

Chamfering Corners

Menu: Modify > Chamfer / Bevel
Keycode: CH

 

With this tool you can chamfer (bevel) corners formed from two lines or arcs.

Usage

1. Start the chamfer tool:

2. Enter the geometry of the chamfer in the options toolbar. Length 1 is the distance of the
chamfer line from the corner along the first entity you pick when defining the corner.
Length 2 is the distance from the corner along the second entity of the corner:
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Tick the Trim check box to trim the corner lines automatically to the chamfer. If you
choose not to trim, the lines that shape the corner will remain unchanged.
For this example, we want to create a 2x2 chamfer and trim the corner lines to the
chamfer:

3. Pick the first entity that forms the corner you want to chamfer.
We first chamfer the top right corner of the inner rectangle in this example. We click the
top line of the rectangle as the first part of the corner:

4. Pick the second entity of the corner.

5. QCAD chamfers the corner and trims the lines to the chamfer:

6. In the same way, the other corners can be chamfered:
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Rounding Corners (Fillet)

Menu: Modify > Round
Keycode: RN

 

This tool is used to round corners. It works very similarly to the chamfering tool.

Usage
1. Start the round tool.

2. Enter the radius of the rounding in the options toolbar.
Make sure that the Trim check box is ticked if you want to automatically trim the corner
lines to the rounding.
For this example, we want to create a rounding with a radius of 4.5 units with trimming
enabled:

3. Pick the first entity that forms the corner you want to round.
In our example, we click the top line of the rectangle as the first line of the top right
corner which we want to round:

4. Move the mouse cursor to the second line of the corner. QCAD shows a preview of the
rounding you are about to create. At this point it is important to place the mouse cursor
at the correct side of the line since there are two roundings possible.
If you place the mouse cursor somewhat to the right of the vertical line, an alternative
rounding is shown:

Move the mouse cursor somewhat to the left of the vertical line to show the rounding
we want to create:

5. Click the left mouse button when the preview shows the correct rounding.
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6. QCAD creates an arc that is tangential to the two chosen lines and trims the lines to the
arc as shown here:

7. The other corners can be rounded in the same way:

Dividing Entities

Menu: Modify > Divide
Keycode: DI

 

This tool divides (or cuts) an entity at a given point. You can for example divide a line into two
parts. The division point must be on the entity and is in most cases an intersection point with
another entity.

Entities often have to be divided to change the line style in the middle of an entity or to form
closed contours for hatching or solid fills.

In the example in Figure , the original shape of a mechanical part before bending is shown with
a dash-dot-dot line in the view at the bottom.

Figure 10-14: Lines often need to be divided to apply dif-
ferent layers or line styles to the two separate parts.

Usage
1. Start the dividing tool:
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2. Pick the entity to divide.
In the example drawing, the two lines at the right are initially constructed as one line
each:

We click one of the lines to divide:

3. Click the dividing point. Use an appropriate snap tool for this, for example snap to
intersection.
For our example, the dividing point is the intersection point between the line we want to
divide and the vertical line:

4. QCAD divides the line at that point. You can verify that by selecting one part of the
line. If the whole line is selected, the intersection point was not exactly on the line.

5. In the same way, the bottom line can be divided into two parts. It is then possible to
move the divided parts of the lines to another layer or to apply a different style to them:

Breaking out Segments (Divide 2)

Menu: Modify > Break out Segment
Keycode: D2

 

This is an alternative dividing tool that can save a lot of time in various situations. It can be used
to quickly cut out a segment from a line or arc. The segment must be limited by two intersecting
entities.

Consider a part of a floorplan as shown in Figure 10-15. The wall outlines at the left are the result
of using the parallel tool to create the sides of the walls. There are many small line segments that
cross the outline and need to be removed for the final plan as shown at the right.
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Figure 10-15: This tool breaks out line segments that are limited by two intersections.

Usage

1. Start the tool to break out segments:

2. Click the segment(s) to break out.
In the floorplan example, that is for example the segment at the top right that crosses the
right wall of the room:

3. QCAD breaks out the segment:

4. Continue to click any other segments to break out:
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5. The final drawing without the unwanted segments:

Splitting up Entities into Equal Parts

Menu: Modify > Split Entities
Keycode: MS

 

This tool breaks entities up into a given number of equal parts. It can for example convert a line
into three equally long smaller lines.

Usage

1. Select the entities you want to split up. Supported entities are lines, arcs and circles.
2. Start the split up tool:

3. Enter the number of equal parts to create in the options toolbar:

4. If you are splitting up any circles, enter the start angle of the split up process. The
circles will be first split at that angle.

5. Click the green tick button at the right in the options toolbar to split up the selected
entities. Unsupported entities are ignored.

Breaking up (Exploding) Entities

Menu: Modify > Explode
Keycode: XP

 

This tool lets you break up complex entities into simple entities. Usually you will not want to
do that since after the operation, the entity is no longer treated as one entity. However, there are
situations in which you will have to break up entities, for example for further processing.

Table 10-4 lists the effect that this tool has on different types of entities.

Table 10-4 Breaking up Entities
Original entity Broken up into

Block reference (insert, group) Entities that make up the block reference
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Original entity Broken up into

Text Lines, arcs and splines

Dimension or leader Lines, triangular solids for the arrows, one
text entity for the label

Polyline Lines and arcs

Spline Polyline with tangentially connected arc
segments

Ellipse Polyline with arc segments

Hatch Lines

Usage

1. Make a selection of all entities to break up.
2. Start the tool:

3. QCAD breaks up the entities according to Table 10-4.
4. Repeat the procedure if necessary to further break up the remaining entities.

Reverse

Menu: Modify > Reverse
Keycode: RV

 

This tool reverses the direction of all selected lines and arcs. The direction of lines and arcs is
usually irrelevant in CAD but can be important for further processing, for example in Computer
Aided Manufacturing (CAM).

Editing Text

Menu: Modify > Edit Text
Keycode: MT

 

Use this tool to edit the text or attributes of an existing text entity. Note that single line texts can
also be edited using the property editor.

Usage

1. Start the tool to edit texts:

2. Click the text entity you want to edit.
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3. QCAD shows a dialog to modify the text string and the various attributes of the text
entity. This is described in more detail in Part IV: Texts, Dimensions and Hatches.

4. Click the OK button to confirm your changes and QCAD will apply them to the chosen
text entity.

Notes

As an alternative to using this tool, you can also double-click a text entity in the drawing to edit it.

Moving Entities into the Background or Foreground

Menu: Modify > Bring to Front, Modify > Send to Back
Keycodes: MF, MB

  

If your drawing contains overlapping hatches or solid fills, you might have to use this tool to
arrange them in the desired order.

Usage

1. Select the entities you want to bring to the front or send to the back of all other entities.
For this example, we want to move the filled circle into the background to highlight an
area in the drawing:

2. Click the appropriate button to bring the entities to the front:

Or send them to the back:

In our example, we click the button to move the filled circle to the back.
3. QCAD moves the selection into the foreground or as in the example, into the

background:

Note

The property editor offers more fine-grained control over the order in which entities are drawn
through the field Draw Order. Entities are always drawn by draw order, ascending from the lowest
to the highest value.
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Detecting Duplicates

Menu: Modify > Detect Duplicates
Keycode: MD

 

This tool can be used to clean up a drawing by removing duplicate entities. Two entities are
considered duplicates if their geometry is near to identical.

Usage

1. Start this tool and adjust the tolerances in the options toolbar if desired.
2. Check the option Ignore Layer if you want to detect duplicates which are on different

layers but have an identical geometry.
3. If you want to directly remove those entities, click the delete button in the options

toolbar:

If you only want to select the duplicate entities and do something else with them (for
example move them to another layer), don't click the delete button.

4. Click the close button in the options toolbar to close the tool:

Detecting Zero-Length Entities

Menu: Modify > Detect Zero-Length Entities
Keycode: MZ

 

This is another cleanup tool, used to remove very small entities. Such entities are often the result
of a mishap when using a drawing or modification tool. If you are not sure if there are such
artifacts in your drawing or if you have troubles selecting such an entity, you can use this tool.

Entities that can be selected or deleted with this tool are:

• very short lines, arcs or splines;
• arcs, circles or ellipses with a very small radius;
• any entity which covers a very small area.

Usage

1. Start this tool and adjust the tolerances in the options toolbar if desired.
2. All very small entities (within the given tolerance) are selected.
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3. If you want to directly remove those entities, click the delete button in the options
toolbar:

You can also choose to keep the entities selected without deleting them.
4. Click the close button in the options toolbar to close the tool:

Aligning Entities

Menu: Modify > Align
Keycode: MA

 

This tool can be used to align the selected entities to an edge or the center of an entity or the
drawing boundaries.

The snap tools are not always convenient to move a selection to be aligned with an entity. In the
example shown in Figure 10-16, the part at the top left has to be aligned to the left bottom edge
of the rectangular polyline as shown in Figure 10-17. Since the left bottom edge of a circle is not
a reference point that can be chosen with a snap tool, using the alignment tool is more efficient
in this case.

Figure 10-16: The circular part at the top left has to
be aligned with the bottom left edge of the rectangle.

Figure 10-17: Using the alignment tool is more convenient in this case.

Usage

1. Select the entities you want to align to an entity.
2. Start the alignment tool:
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3. In the options toolbar, choose if you want to align the selection to the document
boundaries or to a picked entity.
You can also choose the vertical and horizontal alignment and if you want to treat the
selected entities as one group or as individual entities to be aligned:

Table 10-5 shows the effect of the alignment tool if Selection as group is on or off. The
selected entities are treated as one object that is aligned to the rectangular polyline if
the option is on. Without treating the selection as group, each individual of the selected
entities is aligned to the rectangular polyline.

4. If you chose to align the selection to the document boundaries, click the green tick to
confirm the alignment operation.
If you chose to pick an entity to align to, click that entity now (the rectangular polyline
in our example).

Table 10-5  Alignment
Horizontal
Alignment

Vertical
Alignment

Selection as group:
on

Selection as group:
off

Left None

None Top

Center Center

Right Bottom
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Chapter 11

The Property Editor

So far, we have seen how drawings can be modified with the various modification tools of QCAD.
The property editor is another very powerful tool to change entities. It allows you to directly
change a particular property of one or multiple selected entities. Which properties are available
in the property editor depends on the entity type(s) that are selected.

The most common uses of the property editor are:

• Moving all selected entities to another layer.
• Changing the color, linetype and lineweight of entities.
• Changing the text height, alignment, style or angle of one or multiple selected text

entities.
• Changing the scale, angle or pattern of hatch entities.
• Changing the dimension labels of one or multiple selected dimensions.
• Inspecting the properties of an entity, for example to find out what layer an entity is on,

how long a line or arc is or what the area of a circle is.

It is also possible to change the geometry of selected entities directly in the property editor.

The property editor is a permanently visible or hidden user interface component of QCAD, similar
like the layer list. Before you can use it you have to make sure it is currently shown. You can
show the property editor by choosing the menu View > Property Editor or by clicking the button
to toggle the property editor at the right:

Menu: View > Property Editor
Keycode: GP

 

When you show it at first and no entities are selected, the property editor is empty as shown in
Figure 11-1.
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Figure 11-1: The property editor is empty if no entities are selected.

If you select for example a line entity, the property editor immediately shows the properties of
that line entity (Figure 11-2).

Figure 11-2: If an entity is selected, the property editor shows
the properties of that entity (in this example a line entity).

You can also use the property editor with multiple selected entities. If multiple entities of the same
type are selected, the property editor shows all properties for that type. Properties with mixed
values are shown as *VARIES*.

Figure 11-3 shows how the property editor might look like when two lines are selected. Both lines
are on layer 0 and have all attributes set to By Layer. But since they have different start and end
points, length and angle the property editor shows *VARIES* for these properties.
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Figure 11-3: With multiple entities of the same type selected, the property editor
shows *VARIES* for properties that don't have the same value for all selected entities.

When multiple entities of different types are selected, only those properties that are common
among all selected entity types are displayed in the property editor. For most combinations these
are only the general properties at the top which are present for all entity types (Figure 11-4).

Figure 11-4: When multiple entities of different types are selected, on-
ly those properties are shown that are available for all selected entities.

Usage

1. Select the entity or the entities for which you want to browse or change properties.
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2. Click into the value field of the property you want to change.
For example, to change the radius of a selected arc, click into the field where the radius
property is shown at the right:

3. The moment you click into the field it becomes active and lets you change the property.
4. Change the property the way you want to.

For input boxes like the one shown for the arc radius, you have to press the Enter key
or the Tab key or click somewhere outside the input box when you are done to confirm
your changes. If you press the Tab key, you can directly edit the next property.
Whenever a numeric value is expected, you can either type a value or a mathematical
expression (e.g. 15/2 instead of 7.5).

Filtering Entity Types

The combo box at the top of the property editor shows the total number of selected entities. It
can also be used to show and edit only properties of a certain entity type. This can be convenient
when entities of multiple types are selected but you are only interested in one entity type.

You might for example want to change the font of all texts in a drawing. Instead of going through
the procedure of selecting each individual text entity you can simply select all entities in your
drawing and then activate the filter for text entities. Once the filter is set, the properties of the
text entities are shown and the font can be changed.

Usage:

1. Select some entities of mixed types.
For our example, we select all entities (Menu Select > Select All).
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2. Click the Selection combo box at the top of the property editor:

Note the number in brackets beside the text All. This number indicates the total number
of entities that are selected. In this example, ten entities are selected in total.

3. Click the entry of the entity type you are interested in.
For our example, we choose the Text entry. This time the number in brackets indicates
how many of the selected entities are text entities (six in this example):

The property editor now shows all available properties for text entities. Any change
made to these properties will only affect text entities.
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The texts that are selected in this example are all on layer 0 and all were created with
the same font, font style and alignment. The text positions, text heights and the text
contents are not identical (*VARIES*).

4. In this mode, the property editor behaves exactly as if only the text entities were
selected.
To change the font of all selected texts, simply choose a new font with the Font
Name combo box.
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Chapter 12

Measuring Tools

Objective

In this chapter, you will

• learn how to measure distances, angles and areas from a drawing.

Introduction

Sometimes it can be useful to measure certain geometries in a drawing to either check if a con-
struction is accurate or simply to gather information about an object.

Keep in mind that the geometry of an object might be subject to tolerances that are indicated in a
dimension or common in an industry. For example a length might be indicated as 100±0.1 which
means that the manufactured part can be between 99.9 units and 100.1 units long to be acceptable.
For this reason, the measurements in a CAD drawing do not necessarily match exactly those of
the real world objects they represent.

The measuring tools can be displayed by clicking the appropriate button in the CAD toolbar:

Menu: Info
Keycode: WI

 

Figure 12-1 shows the CAD toolbar with the measuring tools of QCAD.
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Figure 12-1: Overview over the measuring tools of QCAD.

Distance between Two Points

Menu: Info > Distance Point to Point
Keycode: IP

 

This tool lets you measure the distance between two coordinates (or points) in the drawing.

Usage

1. Click the position of the first point.
2. Move the mouse cursor to the second point. QCAD shows the distance between the

point chosen before and the current point. This makes it possible to use this tool in a
dynamic way like a tape measure.

3. Click the second point. The distance is shown in the drawing area but also printed in the
command line history together with the distance in X, the distance in Y and the angle in
which the distance was measured.

4. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key
on your keyboard twice.

Distance from Entity to Point

Menu: Info > Distance Entity to Point
Keycode: IE
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With this tool you can measure the shortest distance from an entity to a point.

Usage

1. Click the entity from which you want to measure the distance to a point.
2. Move the mouse cursor to the point. QCAD immediately displays the shortest distance

between the entity and the point.
3. Click the point. The distance is now also printed in the command line history.
4. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key

on your keyboard twice.

Angle between Two Lines

Menu: Info > Angle
Keycode: IA

 

This tool measures the angle between two lines in degrees.

Usage

1. Click the first line.
2. Move the mouse cursor to the second line to display the angle.
3. Click the second line to print the angle in the command line history.
4. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key

on your keyboard twice.

Total Length of Selected Entities

Menu: Info > Total Length of Selection
Keycode: IS

 

This tool prints the total length (the sum of all lengths) of the selected entities. The result is printed
to the QCAD command line window. The command line must be displayed to show the result of
this tool. To display the command line, choose the menu View > Toolbars > Command Line. You
can also measure the length of spline curves with this tool.

This tool operates on a selection that is made before starting the tool. As soon as you start this
tool, the total length of all selected entities is printed to the command line.

Area of a Polygon

Menu: Info > Polygonal Area
Keycode: IR
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With this tool you can trace a polygon to measure the area inside it.

Usage

1. Click the corner points that surround the polygon one by one. QCAD displays the area
outline in green and shows the current area close to the mouse cursor.

2. Click the right mouse button or hit the Escape key when you are done. QCAD prints
the area again to the command line history. A second value is also printed which is the
circumference of the polygon drawn.

3. Terminate the tool by clicking the right mouse button or by hitting the Escape key again.
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Chapter 13

Texts

Objective

In this chapter, you will

• learn how to add text labels to your drawing,
• learn how the text height can be controlled,
• get to know the various attributes of text entities,
• see some advanced text techniques to create subscripts and superscripts.

Texts in CAD

CAD drawings usually contain some text labels to explain things that are difficult to draw or to
provide more detailed information about a drawing. QCAD comes with a simple text tool that lets
you create text labels in a few steps. The text tool of QCAD is precise and efficient as you would
expect from a CAD tool. You should not use the CAD text tool if you need to create beautiful
decorative texts or to replace a word processor. A CAD system provides you with a text tool to
add information to a drawing. The important thing about CAD texts is that they are well readable
and practical to work with.

All text labels should usually be placed on a separate layer. If your drawing contains texts with
different text heights it is a good idea to create one layer per text height. This allows you to adjust
the line thickness accordingly and make small texts thinner and large texts thicker. The line width
of a text label should be about ten times smaller than the text height. For example a text that is
2.5mm high should be drawn with a linewidth of 0.25mm.

Fonts

QCAD offers its own set of fonts. These fonts are optimized for CAD drawings and fit in with
CAD drawings. Although, there are many different fonts included with QCAD, you should stick
with the font standard for most if not all of your texts. This font is very well readable even at
a small scale.



Part IV Drawing and Editing with QCAD

179

Text Height

Before you create any text labels, you have to decide what text height to use. In a CAD system, all
objects are drawn at their actual size. When a drawing is printed, it is scaled up or down to fit on
a sheet of paper. Naturally, text labels are scaled up or down together with the rest of the drawing.
If you draw a floor plan of a house, your text labels probably have to be about 25cm high. When
printing the drawing, QCAD scales it down for example by a factor of 100 (1:100). The 25cm
text labels are then printed 2.5mm high, that is 100 times smaller.
On the other hand, if you draw a small mechanical part at a scale of 10:1, your text labels should
be about 0.25mm high to print as 2.5mm on paper.
Remember to always keep the scale factor of your drawing in mind when creating text labels.

Creating Text Entities

Menu: Draw > Text
Keycode: TE

 
To create a new text entity, click the text tool button in the CAD toolbar.
Usage

1. The text dialog of QCAD is the starting point to create new text entities:

2. Choose a font for the text entity.
There are two types of fonts available in QCAD:
CAD fonts with letters that consist of lines and arcs. They are shown at the top of the
font list. If you are creating a text using a CAD font, the font standard is usually a good
choice:

System wide fonts are shown below the CAD fonts. These fonts create texts in which
the letters are displayed as filled areas rather than lines and arcs. If you are planning
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to share your drawing, keep in mind that other users might not have the same fonts
installed on their systems as you. The font ‘Arial’ is usually a safe choice for a system
font as it is available on most systems:

3. Enter the height of your text by following the notes about drawing scale above. Texts
that are too small on paper (smaller than about 2.5mm) are hardly readable while large
texts might get in the way of the actual drawing elements.
The text height is measured from the bottom line of the text to the top of a capital letter.
The height that is chosen is the initial height for your text entity. You may also change
the text height anywhere in the text using the text editor at the right.

4. Check the Bold or Italic choices to make your text bold or italic. These settings are
default settings for your text. You may also change the style inline using the text editor
at the right.
Bold and italic styles cannot be applied to CAD fonts.

5. Make sure that the Line spacing factor is set to 1. The line spacing factor does not need
to be changed in most cases.
If you do wish to change the line spacing, enter a different line spacing factor in the text
field. A factor of 1.0 produces a normal line spacing, 2.0 increases the line spacing to
double the normal line spacing.

6. Enter the rotation angle of the text in degrees. An angle of zero degrees produces
normal, horizontal text that is readable from the left to the right. Note that in CAD
drawings texts should be either readable from the bottom or from the right. The most
sensible choices for text angles are between about -60 degrees and 90 degrees where 0
degrees and 90 degrees are the preferred angles:

7. Choose the vertical and horizontal alignment of the text by clicking the appropriate
alignment button. The alignment determines not only how multiple text lines are
arranged below each other but also where the reference point (or anchor) of the text
is. Table 13-1 shows the alignment options and their effect on an example text. The
reference point of the text is also indicated.

8. Enter the text for the text entity you want to create into the large text field at the right.
You may use the formatting tools at the top to change the font, text height, style and
color inline or to create subscripts or superscripts.
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If you are creating a single line text without any formatting, click the Simple Text choice
at the top. This simplifies the handling of the text entity. Simple texts can be changed
into regular texts anytime later using the text dialog or the property editor.
Use the Omegasymbol button at the top right to insert special characters into the text.
Note that the CAD fonts that come with QCAD contain only a subset of the Unicode
standard. If you insert a character into your text that is not available in the font, the
character will still be stored in your text entity but QCAD will not be able to display it.

9. Click OK to confirm the dialog.
10. Click the location where you want to place the text entity.
11. Terminate the tool by clicking the right mouse button twice or by hitting the Escape key

on your keyboard twice.

Table 13-1  Text Alignment
Top Left Top Center Top Right

Middle Left Middle Center Middle Right

Bottom Left Bottom Center Bottom Right

Subscript and Superscript

Using the text dialog as described above, it is possible to create small subscripts or superscripts
within the regular text flow. To fully leverage this feature in text entities and also in dimension
labels, you may want to learn how subscripts and superscripts are internally represented. This
internal representation is visible in the property editor when editing text or dimension entities and
in the text dialog in the Source tab.

Subscripts often used to create indices (for example x1, x2, ...) and superscripts for exponents (for
example 100m2). In mechanical drawings, superscripts and subscripts are also often used together
(stacked text) to indicate the upper and lower tolerances of a measurement.



Texts Chapter 13

182

The special text sequence to create subscript or superscript is: \Sa^b; where a is the superscript
and b the subscript. For example the text 100m2 is internally represented as 100m\S2^;. Table
13-2 shows some other examples for subscript and superscript. You can use these special text
sequences to change texts or dimension labels in the property editor.

Table 13-2 Subscript and Superscript
Text string Generated text

100m\S2^;

X\S^1;

10\S+0.10^-0.25;

Σ\S6^k=2;(k\S2^;)
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Chapter 14

Dimensions

Objective

In this chapter, you will

• learn what dimension entities (or dimensions) are in the context of CAD,
• get to know the reasons why dimensions are needed,
• set up the dimension properties to adjust the look of dimensions,
• learn how to add dimensions and leaders to your drawing,
• see how some modification tools affect dimensions.

What Are Dimensions?

Dimensions are drawing elements that provide accurate information about the size of something
in the drawing. They can also be used to add other information to the drawing. Typically they
contain information that is required for manufacturing.

Dimensions are meant for the reader of the drawing. If you want to know how long a part is
or what the angle is of a line you have constructed, you can use the measuring tools in menu
Info instead.

Figure 14-1 shows the drawing of a mechanical part with an elongated hole. The drawing contains
two dimensions which indicate the size of the elongated hole:

• The label 15 at the bottom indicates the distance between the two center points of the
elongated hole. The whole dimension entity is made up from three lines, two arrows
and the text label. The horizontal line has the length of the measured distance and is
limited by two vertical lines. The arrows emphasize from where to where the distance is
measured.

• The dimension label at the right indicates that the hole has to be manufactured at
least 8.05mm wide and at most 8.10mm. Note that this important information is only
contained in the dimension label. Even if the reader of the drawing has access to the
original CAD file, the exact upper and lower limits of the measurement cannot be
measured from the drawing data. The hole would usually be constructed as exactly 8mm
wide in this case. This example shows that a text label is sometimes far more concise
than the drawing data itself.
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Figure 14-1: The two dimension entities indicate the size of the elongated hole.

The Parts of a Dimension

A dimension entity consists of a text label, arrowheads and lines or arcs. Figures 14-2 and 14-3
show the different parts of dimension entities and how they are called in QCAD.

Figure 14-2: Each dimension consist of several parts
as shown in this example with a vertical dimension.

Figure 14-3: The same parts also make up angular dimensions.

The dimension text usually indicates the length or angle between the arrows of the dimension.
In QCAD, the text label can also contain any user supplied text string beside the measurement
or instead of it. A distance of 10 can for example be labeled as 10 (default), 10H7, R10, 10°, A,
See detail 2B, etc.

The dimension line is the line or arc directly under, above or beside the text label. It usually has
the same length or covers the same angle as indicated by the text label. The dimension line also
shows at what angle a distance is measured (often horizontally or vertically).

The arrowheads are shown at the ends of the dimension line to emphasize the exact extent of
the distance or angle.
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The extension lines extend the end points of the dimension line in direction of the dimensioned
object. They allow the dimension line and the text label to be located further away from the object
for example to be able to place multiple dimensions beside or under each other.

Dimension Preferences

Before creating any dimensions it is necessary to set up the size, style and format that will be used
for the dimensions. Most importantly, the height of the text labels and the size of the arrowheads
has to be set up correctly. Just like with text labels, these measures are in drawing units and depend
on your drawing scale. In most cases, the dimension label text height should be set up to print
at a height of about 2.5mm on paper.

You can also change these settings later on, but this will cause you some extra work since you
might also have to rearrange the dimensions for example to avoid the text from overlapping with
your drawing.

The dimension preferences can be set up in the drawing preferences dialog of QCAD. Choose the
menu Edit > Drawing Preferences to show the drawing preferences dialog. Click on the section
Dimension Settings to show the dimension preferences (Figure 14-4).

Figure 14-4: The dimension preferences of QCAD.

The dimension options are split up into three parts:

• Sizes: In this part you can set up the size of the text labels, the arrowheads and some
gaps between the parts of a dimension.
Leave the Keep Proportions option on and only adjust the text height. QCAD
automatically adjusts all other sizes to match the chosen text height.

• Arrow Style: This part allows you to choose between the default arrowheads and
ticks that are typically used in architectural drawings:
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• Label Format: In this part you can define the format and precision of the numerical
value that is used for the text labels. Table 14-1 gives a couple of examples for the
options that are available. Note that the formats Engineering and Architectural are only
available if the drawing unit is set to Inch.

Table 14-1 Dimension Format Options
Format options Measured value Example label

Format: Decimal

Precision: 0.0000 1 1

Precision: 0.0000 14.3541598 14.3542

Format: Engineering

Precision: 0'-0.0000" 1.5 1.5"

Precision: 0'-0.0000" 12.5 1'-0.5"

Format: Architectural

Precision: 0'-0 1/16" 1.5 0'-1 1/2"

Precision: 0'-0 1/16" 12.5 1'-0 1/2"

Precision: 0'-0 1/16" 14.3541598 1'-2 3/8"

Precision: 0'-0 1/64" 14.3541598 1'-2 23/64"

Format: Fractional

Precision: 0 1/16 14.3541598 14 3/8

Creating Dimensions

The tools for drawing dimensions are available through the CAD toolbar by clicking the dimen-
sion menu button:

Menu: Dimension
Keycode: WD

 

Figure 14-5 shows the CAD toolbar with the tools for creating dimensions.
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Figure 14-5: The CAD toolbar showing the dimension tools.

Aligned Dimension

Menu: Dimension > Aligned
Keycode: DA

 

This tool creates dimensions that indicate the distance between two points. Aligned in this context
means that the dimension line is aligned with the two points. The dimension line has the same
angle as the line that connects the two points. Figure 14-6 shows an example for an aligned
dimension. The dimension indicates the distance between the two points shown as crosshairs.

Figure 14-6: Aligned dimension.

Usage

1. Click the position of the first of the two points between which the distance should be
dimensioned.
In this example, we choose one end point of the tilted line:
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2. Click the position of the second point.
Note that while you are moving the mouse, QCAD already previews the aligned
dimension and its measurement.
For the example, we click the other end point of the tilted line:

3. Click the position of the dimension line. This step allows you to place the dimension
line closer or further away from the object.

Alternatively, you could also place the dimension line below the tilted line by clicking
in that area:

4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Rotated (Linear) Dimension

Menu: Dimension > Rotated (Linear)
Keycode: DL

 

This tool creates dimensions with a fixed angle for the dimension line. The most common angles
for linear dimensions are 0 degrees (horizontal) and 90 degrees (vertical). Because they are so
common, QCAD offers two separate tools for those dimension types.

Sometimes it is necessary to create a dimension at a different fixed angle. This is often the case
if a whole part of a drawing is rotated by a fixed angle and the dimensions are also given at that
angle. Figure 14-7 shows an example for such a drawing. The center axis of the right part of the
drawing has an angle of 60 degrees. The dimension lines of the two dimensions also need to have
an angle of 60 degrees in order to automatically show the correct measurement.
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Figure 14-7: The two linear dimension have a fixed an-
gle of 60 degrees, parallel to the distance they measure.

Usage
1. Enter the angle of the dimension line in the right part of the options toolbar.

For this example, we enter 60 to produce a linear dimension with the dimension line at
an angle of 60 degrees:

The buttons at the right of the input field allow you to quickly reset the angle to 0
(horizontal) or 90 (vertical).

2. Click the position of the first of the two points between which the distance should be
dimensioned.

3. Click the position of the second point.

4. Click the position of the dimension line. Note that you can still adjust the angle of the
dimension line in the options toolbar at this point if you can see from the preview that
you have entered a wrong angle.

5. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.
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Horizontal and Vertical Dimension

Menu: Dimension > Horizontal / Vertical
Keycode: DH / DV

  

These two tools operate in the same way as the tool for linear dimensions. The only difference
is that you cannot enter an angle for the dimension line. The angle is fixed to either 0 degrees
(horizontal) or 90 degrees (vertical). These tools are available because horizontal and vertical
dimensions are very common.

Figure 14-8 shows a drawing of a round part. The diameters in the drawing could be dimensioned
with any type of linear dimensions. Horizontal dimensions are usually chosen as the default when
the angle is not relevant. Vertical dimensions would be the second choice.

Figure 14-8: Horizontal dimensions are very common
and usually also used when the angle is not relevant.

Ordinate Dimension

Menu: Dimension > Ordinate
Keycode: DO

 

Ordinate dimensions are typically used in drawings which are intended for Computer-Aided Man-
ufacturing (CAM). Computer controlled machines are often fed directly with coordinates. Instead
of drawing many horizontal and vertical dimensions which all start at the origin of the drawing,
it is usually more convenient to create a drawing that directly contains the relevant coordinates
as shown in Figure 14-9.
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Figure 14-9: A front panel for an electronic device. The relevant co-
ordinates of the openings are indicated with ordinate dimensions.

Usage

1. Click a position that is at the X-ordinate or Y-ordinate which you want to dimension.
In this example, we will create the Y-ordinate dimension for the center of an opening.
We click a point on the horizontal center axis:

2. Click the position of the text label.
For the example, we click on the same height as the center line at the left of the
drawing:

Note that you don't have to place the text label on the same height as the dimensioned
ordinate. Especially if multiple ordinate dimensions are close to each other, it can be
useful to place the label in a slightly different location. QCAD then creates an extra line
that connects the label with the ordinate as shown here:

3. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.
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Leaders

Menu: Dimension > Leader
Keycode: DE

 

Leaders are arrows that point to a detail in your drawing. At the start of the leader is typically a
comment with a piece of information about that detail. Leaders might also be used without any
text as simple arrows. Figure 14-10 shows a landscape design. The various plants are shown as
symbols with a leader that indicates what plant is meant.

Figure 14-10: Leaders are used in this landscape de-
sign to point out what plants are to be planted and where.

Usage

1. Click the position where the leader points to.
In this example, we will draw a leader that points to one of the tree symbols. We first
click the point where the arrow points to, close to the tree:

2. Click the first position away from the arrow.
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3. Click the next position(s) away from the arrow. With every click a new segment is
added to the shaft of the leader. You can add as many segments as desired but usually
leaders have not more than three segments for clarity.

4. Click the right mouse button when you don't want to add any more segments. QCAD
now adds the leader to the drawing.

5. Use the text tool to add a text label to the leader (if desired).

Radius Dimension

Menu: Dimension > Radial
Keycode: DR

 

With this tool you can quickly add a radius measurement to an existing arc or circle. Figure 14-11
shows an example for a radius dimension.

Figure 14-11: Radius dimension.
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Usage

1. Click the arc or circle for which you want to add a radius dimension.
For this example, we click the arc. It does not matter at this point where exactly you
click as long as the closest entity to the mouse cursor is the arc you want to dimension:

2. Click a position to define the angle of the radius dimension line.

Please read the section Choosing a Different Text Label further on to learn how to
change the text label from 6 to R6.

3. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Diameter Dimension

Menu: Dimension > Diametric
Keycode: DD

 

Analog to the radius dimension tool, this tool dimensions the diameter of circles or arcs. Diameters
can also be dimensioned with horizontal, vertical or linear dimensions. The difference of the
diameter dimension tool is that the dimension line is placed inside the circle, going through its
center. Figure 14-12 shows three examples for diameter dimensions. If there is no space inside the
circle for the arrows, QCAD places them automatically outside of the circle as shown in the third
circle from the left in Figure 14-12. To learn how to move the text label of a diameter dimension
outside of the circle, please refer to section Moving the Text Label further on in this chapter.

Figure 14-12: Diameter dimensions are placed inside the circle. The arrows
are placed outside the circle if there is not enough space inside the circle.
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Usage

1. Click the arc or circle for which you want to create a diameter dimension.
For the first circle in this example, we click the circle at the left:

2. Click a position to indicate the angle of the dimension line.
In this example, we set the angle at about 45 degrees by clicking a point as shown:

3. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Angle Dimension

Menu: Dimension > Angular
Keycode: DN

 

The angle dimension tool dimensions an angle in degrees or an alternative angle unit. The angle
is defined by either two lines in the drawing or an arc.

Figure 14-13: Angle dimensions indicate the angle between two lines or the angle of an arc.
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Usage

1. Click the first line that limits the angle or click an arc for which you want to dimension
the angle.
In this example, we click the horizontal center line of the drawing:

2. If you have clicked a line in the previous step, you can now pick another line.
We pick the other center line for this case:

If you have picked an arc in the first step, this step does not apply since an arc defines
the start angle and the end angle for the angle dimension.

3. Click the position of the dimension line.

4. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

Choosing a Different Text Label

Most dimension tools create a text label with the correct measurement automatically. To change
that label or add information to it, an options toolbar is displayed during the construction of the
dimension:

If you don't type anything in this toolbar, the dimension label is generated automatically as this
was the case in the examples above.
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Fixed Text Labels

To replace the text label of a dimension by any fixed text, type the text into the text field at the
left in the options toolbar. For example, if you want to replace the measurement with the fixed
text Distance A, enter that text in the toolbar as shown here:

The text label of the dimension is changed to contain the text that was entered. In Figure 14-14,
the text label of a horizontal dimension was set to the fixed text Distance A.

Figure 14-14: Example for a fixed text label.

Adding Custom Text to the Label

As you have seen above, the dimension label is replaced with a fixed text as soon as you type
something into the text field of the options toolbar. The original measurement is no longer dis-
played in this case. To customize the dimension label without losing the measurement number,
you can type the two characters <> (that is, the less than and the greater than symbols) into the
options toolbar. This sequence is then replaced by the actual measurement by QCAD. For exam-
ple to prepend the text ‘ca.’ to a dimension label, type ‘ca. <>’ into the text field:

Adding a Prefix

In many cases the text label needs to be accompanied by a symbol or a text. For example diameter
dimension labels often start with diameter symbol. QCAD offers a special choice for such com-
mon symbol prefixes. The choice at the left of the toolbar can be switched from '(No Prefix)' to
any desired symbol. For example to show a diameter symbol in front of the label:

The vertical dimension in Figure 14-15 contains a diameter symbol to indicate that the right side
of the part is cylindrical. The left side of the part has a square profile which is emphasized by the
thin diagonals across the visible surface.
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Figure 14-15: Diameter dimensions are often prepended by a diameter symbol,
especially if it is not obvious that the measured part is round as in this example.

Adding Symbols to the Text Label

Some useful symbols for dimension labels are hard or impossible to find on a keyboard. To enter
these into the text fields, QCAD offers a context menu. From that menu you can select some
symbols that are commonly used in dimension labels. To access the context menu, right-click
into one of the text fields on the options toolbar and choose Insert Symbol and then the symbol
that you want to insert.

Tolerances

Another very common function of dimensions is to indicate construction tolerances. These tol-
erances tell the manufacturer the exact range within which a length has to be for the product to
be acceptable. Figure 14-16 shows a typical combination of tolerances for a hole and a bolt. The
tolerances assure that the bolt will fit into the hole, not too tight and not too loose.

Figure 14-16: Dimension labels often indicate manufacturing tolerances.

In QCAD, tolerances can be entered in the dimension options toolbar at the time of construction.
For the bolt dimension at the right in Figure 14-16, you would have to enter the tolerances into
the text fields at the right as shown here:

The first tolerance text field is for the upper tolerance (superscript) and the second field is for
the lower tolerance (subscript).

It is also possible to use the subscript and superscript text sequences described in chapter Texts di-
rectly in the text field for more complex dimension labels.

Examples

Table 14-2 shows some examples for dimension labels.
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Table 14-2 Dimension Text Labels
Text string for dimension label and
explanation

Example

Text string: <>m
Units are usually not shown in dimension
labels unless a measure is indicated in a
different unit than the rest of the drawing.

Text string: ◻<>
The square in front of the dimension label
in this example means that the part has a
square profile of 7x7 (as opposed to a round
profile with a diameter of 7).

Text string: R<>
Radius dimensions are usually prefixed with a
capital R.

Text string: SR<>
Spherical radius dimensions are prefixed with
SR.

Text string: (<>)
Auxiliary dimensions are usually enclosed in
brackets like the total length of this axle.

Text string: 5×15°=(<>)
Repetitive, equal divisions are sometimes
dimensioned as shown in this example.

Text string: <>±0.01
Symmetrical tolerances can be indicated with
a ± symbol.
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Text string for dimension label and
explanation

Example

Text string:
<> G7(\S+0.028\+0.007;)
To have a text after a subscript or superscript
(here a closing bracket), the text sequence
for subscripts and superscripts can be used
instead of the tolerance input fields.

Text string:
<>±0°0'30"
Custom label example with an angle
dimension.

Moving the Text Label

QCAD automatically positions the label of dimensions. Sometimes QCAD places the label in a
position where it overlaps with other parts of the drawing (for example as shown in Figure 14-17).
In such cases, you can manually move the label to another position.

Figure 14-17: In situations like this, the dimension text label can be repositioned manually.

Procedure:
1. Make sure that no tool is active and QCAD is in its neutral state.
2. Select the dimension entity for which you want to move the label by clicking on it.

QCAD highlights that entity and shows its reference points as blue spots:

3. Move the mouse cursor to the blue spot that is at the center of the text label:

4. Press the left mouse button and hold it down.
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5. Move the mouse cursor until it turns into a crosshair.
6. Let go of the left mouse button.
7. Move the mouse cursor to the position where you want to place the label. You can use

the snap tools as usual or disable them by activating the snap tool for free positioning.

8. Click the left mouse button to place the label.

Moving Reference Points

In the same way as you can move the text label, you can also move other reference points of di-
mension entities. This can be useful to quickly modify an existing dimension instead of replacing
it with a new one.

Table 14-3 shows some examples how you can modify dimensions by moving reference points.

Table 14-3 Moving Dimension Reference Points
Explanation Movement of reference

point
Modified dimension

By moving one of the reference
points at the end of the
extension lines you can change
the length of the dimension.
QCAD adjusts the measured
label accordingly.

The reference point on the
dimension line can be used
to move the position of the
dimension line closer or further
away from the dimensioned
object.

Ordinate dimensions feature
a reference point to move the
position of the label and the
leader to the label. This has no
effect on the measured value of
the dimension.

Another reference point of
ordinate dimensions can be
used to reposition the location
that is measured. The label is
adjusted accordingly.
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Explanation Movement of reference
point

Modified dimension

Ordinate dimensions also
have a reference point at
the coordinate from where
the ordinate is measured. By
default that is the absolute
zero point (0,0). You can move
this reference point to create
relative ordinate dimensions.

If you select multiple ordinate
dimensions, you can change
the coordinate from where the
ordinates are measured in one
step.

The angle of a radius dimension
can be changed by moving the
reference point on the circle
line.

Stretching Dimensions

It is noteworthy that dimensions can be stretched with the stretch tool like other entities. QCAD
automatically adjusts the measurement of the dimensions that are affected by the stretch tool.

Figure 14-18 shows a side view of a table with its height and length dimensioned. The stretch
area that was selected by the user contains the right side of the table as indicated with the dashed
rectangle. The length of the table is then stretched from 1.2m to 1.8m. The horizontal dimension
is adjusted automatically by QCAD. The vertical dimension is simply moved since it is entirely
inside the stretch area. The result is shown in Figure 14-19.

Figure 14-18: A stretch area can contain one part of a dimen-
sion entity. The dimension is then stretched like any other entity.
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Figure 14-19: QCAD automatically adjusts the dimension labels of stretched dimensions.
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Chapter 15

Hatches and Solid Fills

Objective

In this chapter, you will

• learn what hatches and solid fills are,
• see some example uses for hatches and solid fills,
• learn how to fill areas of your drawing with hatches or solid fills.

What Are Hatches?

A hatch in the context of CAD is an area in a drawing that is filled with a pattern of lines. Hatches
are not part of the drawing geometry. Their purpose is to provide additional information about
your drawing or to make your drawing more readable. Hatches can be used for various reasons.

In mechanical drafting, the most common use is to show cut surfaces in cross sections. Figure
15-1 shows an example for a cross section. The drawing shows the assembly of four parts. The
bolt is not shown as cross section and therefore not hatched. The other parts are filled with hatch
patterns with different angles and scales to make sure they can be easily distinguished.

Figure 15-1: Hatches in a cross section of a mechanical drawing.

In mechanical, architectural and geological drawings, hatches are also often used to represent and
distinguish different materials. Figure 15-2 shows a cross section of a wall. Hatch patterns are
used to separate the insulation, wood sheeting and the plaster.
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Figure 15-2: Hatches are often used to indi-
cate or emphasize the material of a part or section.

What Are Solid Fills?

Solid fills cover an area in your drawing just like hatches. Unlike hatches, solid fills completely
fill the area with the same color rather than a pattern of lines. In QCAD, the same tool is used
to create hatches and solid fills since a solid fill can be seen as a special kind of hatch pattern.
Solid fills are traditionally rarely used in CAD, partly because they are not suitable for plotting.
However, they can be very convenient to highlight parts of a drawing or to improve the display
of logos and symbols in the drawing. Figure 15-3 shows the symbol of a thermostat, at the left
without a solid fill and at the right with a solid fill.
Solid fills are also used to hatch areas that are too small to display a hatch pattern (for example
the shingles at the right in Figure 15-2).

Figure 15-3: Logos and symbols often have filled areas.

Creating Hatches and Solid Fills

Creating the Hatch Boundary

Before you can create a hatch or solid fill, you need to draw the closed geometry that you want to
fill with the pattern or color. This geometry must consist of one or more closed contours. Closed
means that the entities that make up the contour must be connected to each other at their end
points. Since this is often not the case with the existing geometry, it is advisable to create the
hatch contour(s) on a separate layer, on top of the existing geometry.
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Consider the drawing in Figure 15-4. For the cross section in the middle, the exact boundary has
to be created before the hatch can be drawn. The isolated hatch boundary QCAD can work with
is shown at the right.

Figure 15-4: Before an area can be filled with a hatch or solid fill,
the boundary of the area has to be isolated as shown at the right.

For better understanding of the drawing in Figure 15-4, Figure 15-5 shows an isometric drawing
of the same mechanical part.

Figure 15-5: Isometric drawing of the part in Figure 15-4.

The following instructions guide you through the process of isolating the hatch boundary. This is
not the only way how this can be done. The goal is to have the complete, closed hatch boundary
on a separate layer, so it can be easily selected and later hidden or deleted when it is not needed
anymore.

1. Create a new layer for the hatch boundary.
For this example, we call the layer hatch boundary. The layer attributes don't matter,
you can just leave the default attributes on.

2. Select all entities that are or might be part of the hatch boundary. At this point it does
not matter if you select too many entities. If your drawing is not very large, you can also
simply select the whole drawing.
For our example, we select the complete cross section:
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3. Copy the selection to the clipboard (Menu Edit > Copy with reference). Choose the
absolute zero (origin) of the drawing as reference point.

4. Make sure that the layer hatch boundary is the current layer.
5. Choose the menu Edit > Paste. Before you position the selection, enable the option To

current Layer in the options toolbar.
Click the absolute zero point to position the selection.

6. Your drawing now contains the selection twice: once on the original layers of the
drawing and once on the special layer hatch boundary.

7. Switch all layers off by choosing menu Layer > Hide All.
8. Switch only layer hatch boundary back on by clicking the eye symbol at the left of its

name in the layer list.

9. Delete all entities that are not a part of the hatch boundary:

10. Delete all segments that are not part of the hatch boundary with the tool Modify > Break
out Segment:

11. The layer hatch boundary now contains only the isolated hatch boundary and our
drawing is prepared for the hatch tool to fill the area with a pattern or solid fill.

Creating the Hatch

Menu: Draw > Hatch
Keycode: HA
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Usage

1. Select all closed contours you want to fill with the same hatch pattern or solid fill.
For our example, we select all entities on layer hatch boundary:

2. Make sure that the layer on which you want to create the hatch pattern is active and
visible.

3. The tool for drawing hatches or solid fills is available directly in the main toolbar of
QCAD:

4. After starting the hatch tool, QCAD shows the hatch dialog that lets you choose the
hatch pattern and its scale and rotation angle:

If no dialog is shown, your hatch boundary might not be a properly closed contour and
you will have to fix this first. Make sure that the entities that make up the boundary
connect to each other and that there are no duplicate entities on top of each other.
QCAD prints some hints about what and where the problem is into the command line
history.

5. Choose the pattern you want to use. The preview at the right shows how the pattern
looks like. To create a solid fill, check the Solid Fill choice at the top. You can also
enter a scale factor for the pattern. Make sure that you don't choose a very small value,
otherwise it can take very long to render the hatch. In the Angle field, you can enter a
rotation angle for the pattern in degrees.
For the example, we use a standard 45 degree hatch pattern. The pattern is called
ANSI31 and we use a scale factor of 1 and a rotation angle of 0 degrees.

6. Click the OK button to confirm and close the dialog.
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7. QCAD now fills the selected area with the pattern:

8. You can now hide the special layer hatch boundary and show the other layers again:





Part V
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Chapter 16

Creating and Using Blocks

Objective

In this chapter, you will

• learn what blocks are and how to use them,
• get familiar with the terms block and block reference,
• get to know the difference between blocks and groups,
• learn how to create new blocks.

What is a Block?

If you have worked with drawing or presentation applications before, you might be familiar with
the concept of grouping multiple objects into one group. Such groups of objects can be selected
with one click and moved around or rotated as one.

Groups of objects are called Blocks in CAD. You can do exactly the same things with blocks as
you can do with groups, but there are also some crucial differences:

• Every block in QCAD has a name. As soon as you create a block, you have to give it a
unique name that identifies the block in your drawing.

• Once a block is defined, it can be inserted multiple times in different locations, at
different angles and at different scales. Every such inserted reference to a block is called
a Block Reference or short Reference. Sometimes, block references are also called Block
Inserts, or short Inserts.

• Blocks can be modified. Modifying a block affects all references to that block, even if
they were made before the block was modified.

• Every block has a reference point. If a block is being edited, the reference point is the
zero point of the block. When a block is inserted, the reference point is used to position
the block reference.

Table 16-1 shows three examples for blocks as they might be used in a floorplan. The first block
is named Workstation and contains a symbol for a desk with a computer and a chair. In a floorplan
this might be used to plan an office layout. The other blocks are called Door and Window and
represent those building elements in a floorplan.
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Table 16-1 Block Definitions
Workstation Door Window

The floorplan in Figure 16-1 shows how these blocks might be used in a drawing. The drawing
contains six references to block Workstation, four references to block Window and one to block
Door. Besides these elements, it also contains regular lines or polylines which represent the out-
lines of the walls and the tables.

The drawing in Figure 16-1 could have also been produced without the use of blocks. The work-
stations and windows could have for example been duplicated using the copy / paste commands
with the same efficiency. However, there are two major advantages of using blocks and block
references:

• A workstation is treated as one entity. As such it can be easily selected by clicking on it.
When moving a workstation, the entities always stay together.

• The Workstation block can be modified anytime and the individual workstations in the
drawing will be updated automatically to reflect these changes.

The second point is different from other applications and sometimes hard to understand for CAD
beginners. The following example should help to illustrate this concept.

Figure 16-1: Example drawing that uses the blocks in Table 16-1.

Let's say the monitors are being replaced by flat screens and the drawing needs to be updated to
reflect this change. Updating the drawing without the use of blocks could be a very lengthy and
frustrating task, especially if there is a large number of workstations. If the drawing uses blocks,
only the block definition needs to be modified. Table 16-2 shows the modified block definition
of block Workstation. Note that the monitor has been changed into a flat screen.
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Table 16-2 Updated Block Definition
Workstation

As soon as the block is modified, all block references in the drawing are automatically updated
by QCAD to reflect the changes. Figure 16-2 shows the updated drawing.

Figure 16-2: Example drawing after changing the mon-
itors in block Workstation from monitors to flat screens.

The Block List

Before starting to work with blocks, please make sure that the QCAD application window displays
the block list. The block list is a user interface component that can be permanently shown or
hidden like the layer list. The block list shows the names of all blocks in your drawing. It also
allows you to manage blocks and to insert blocks into your drawing.

To show the block list, choose the menu View > Block List or click the appropriate button at the
right.

Menu: View > Block List
Keycode: GB

 

The block list is displayed at the right in the QCAD application window as shown in Figure 16-3.

Figure 16-3: Make sure that the block list is visible when you are working with blocks.
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As you can see in Figure 16-3, the block list already shows one block with the name *Model_S-
pace. This special block is always present and represents your entire drawing. You can also think
of the *Model_Space block as a big group that contains every entity of your drawing. Whenever
you are editing your main drawing, you are actually editing the block *Model_Space.

Creating New Blocks

Menu: Block > Create Block from Selection
Keycode: BC

 

QCAD offers two approaches to create new blocks:

• You can create a new, empty block and then add entities to it.
• Or you can first draw the entities in your drawing as usual and then convert them into a

block.

The second way is for most cases the more natural one.

Figure 16-4 shows the pneumatic schematic of an AND circuit (only if both valves A and B are
activated, the cylinder is pushed out by the air supply). In schematics like this, it is sensible to cre-
ate one block for every symbol. The drawing entities that make up a symbol belong logically to-
gether. A symbol rarely needs to be edited, but if it is adjusted, all symbols of the same type should
be updated accordingly. Such symbols are also often used repeatedly in the same schematic.

Figure 16-4: Blocks are very useful for symbols in schematics like this.

To produce such a schematic, one would typically proceed as follows:

1. First, the symbol can be constructed with the normal drawing and modification tools of
QCAD.
For this example, we assume that the drawing has been started with the entities shown
here:
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2. Select the entities that make up the new block.
In the example, we select all entities of the symbol that represents a pneumatic three-
port valve:

3. Click the tool button in the CAD toolbar to create a block from selected entities:

4. Click a reference point for the block. This point should be a significant point of the
block. It will be used later when positioning references of that block.
In our example, we use the left bottom corner as reference point:

5. QCAD shows a dialog to enter a name for the block. Enter a unique name that helps you
to later identify the block.
For this example block, we enter Valve:

For real drawings you might want to choose a more descriptive name than this by
including a measurement or type number in the block name. Good block names are
for example Table 100x200 for a table that measures 100x200 or DIN85 M4x16 for
mechanical element of that type.

6. Click OK. QCAD creates the block and adds the name to the block list:

Note that QCAD did not only create the block, it also created a block reference of the
block at the exact position of the original entities. In other words: your selection has
been replaced by a block reference of the block you have just created.
You can easily verify this by clicking on one of the lines that make up the symbol.
Instead of only that line, the whole symbol is selected.
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7. The block Valve that has been created looks as shown here:

8. Our drawing still looks exactly the same, but it is now more structured and the valve
symbol acts as one entity.

In the same way, blocks might be created for the air supply symbol, the exhaust symbol and the
cylinder. Table 16-3 shows the blocks that could be created for the schematic in Figure 16-4.

Table 16-3 Pneumatic Symbols
Valve Cylinder Air supply Exhaust

Inserting Blocks

Menu: Block > Insert Block
Keycode: BI

 
This example shows how the block Valve can be inserted into our drawing again.

Usage
1. For this example, we start with the drawing from the previous section again:

The valve symbol has already been structured into a block and now it has to be inserted
again, so that the drawing contains two identical valve symbols.

2. In the block list, click on the block name of the block you want to insert.
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We click on Valve to activate the block that contains the valve symbol. Make sure to
click the block where the name is shown or further at the right and not in one of the
symbol columns at the left:

Note that this does not change the block we are currently editing. We are still viewing
and editing the main block *Model_Space as indicated by the pen symbol between the
eye symbol and the block name.

3. Still in the block list, click the button to insert the selected block into your drawing:

4. Move the mouse to the position where you want to create the block reference and click
the left mouse button at that position.
For our example, we position the symbol on the same height as the other symbol but
more to the right:

The drawing now contains two references of the block Valve at two different locations.
5. Terminate the tool by clicking the right mouse button or by hitting the Escape key on

your keyboard.

Notes

As mentioned before, you should give your blocks meaningful names, so you will remember what
a block contains when you see a block name. The more blocks your drawing contains, the more
difficult this becomes. In practice you might find it easier to copy an existing block reference of
a block using the copy / paste tools of QCAD. This is fine and QCAD does exactly what you
would expect: it creates another block reference to the same block.
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Modifying Blocks

Menu: Block > Edit Block
Keycode: BE

 
The contents of a block can be edited at any time. When a block is modified, all block references
that have previously been created from it are automatically updated to reflect the changes.

Usage
1. Our starting point for this example is the finished schematic from the sections above:

The two valve symbols are references to the Valve block.
2. In the block list, click on the block name of the block you want to modify.

In this example, we want to change the Valve block, so we click on Valve in the block
list:

3. Click the button to edit the selected block. This button is located above the block list:

QCAD opens the block for editing. You can now edit the block like you would normally
edit the drawing.
The block list indicates with the pen symbol beside the block name which block is
currently being displayed and edited.
In our example, the Valve block is being edited right now:
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To start editing a block, you may also click on the position of that pen symbol beside a
block name or double-click the block name.

4. For this example, we add a spring to the bottom of the valve symbol:

In pneumatic schematics, this spring indicates that the valve should automatically
switch back to its original position after it has been operated.

5. When you are finished with editing the block, you can switch back to the main drawing
by clicking the close symbol in the block list:

Alternatively, you may double-click block *Model_Space which is the main block of
our drawing.
The block list moves the pen symbol back to the main block to indicate that we are
viewing and editing the main drawing again:

The Valve block is still selected as the block which is meant when choosing one of the
block tools to delete, rename, edit or insert a block.

6. QCAD shows the main drawing again. All references to the block Valve have been
updated automatically to reflect the changes we have made.
In the example, a spring has been added to both references of the block Valve:
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Modifying Blocks from Block References

Menu: Block > Edit Block from Reference
Keycode: BD

 

The tool to modify a block suffers from the same problem as the tool for inserting blocks: If your
drawing contains many blocks it can be difficult to find the one you want to modify. QCAD offers
an alternative tool that allows you to edit a block by picking one of the block references that was
created from that block.
To edit the block Valve in our example, you can also proceed as follows:

1. Choose the menu Block > Edit Block from Reference.
2. Click one of the block references of the block you want to modify. To edit the block

Valve, click one of the valve symbols in the drawing. Which one does not matter since
they were both created from the same block.

Deleting Blocks

Menu: Block > Remove Block
Keycode: BR

 

If you want to remove a block from a drawing, you can use the minus (-) button in the block list.
If you remove a block from a drawing, all references to that block are also removed.

Usage

1. Click the block name of the block you want to delete in the block list.
2. Click the minus button in the block list:

Notes

In most cases, it is not necessary to remove blocks from your drawing. You can simply delete the
block references instead and keep the block in case you might need it again later on.

Block references can be removed from a drawing like any other entity: select the block reference
and hit the delete key on your keyboard. Deleting a block reference does not delete the block
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definition. Even if you delete all references of a certain block, the block definition will still remain
a part of your drawing document. It is just not visible anymore since there are no references to it.

Exploding Block References

Menu: Block > Explode
Keycode: XP

 

The opposite of creating a block from existing elements is called exploding in QCAD and most
other CAD systems. Exploding a block reference only affects that particular reference and not
the block definition or other references.

Usage

1. Select the reference(s) you want to explode.
2. Choose menu Block > Explode.

Just like when creating blocks from existing entities, there is no visible change to your
drawing. What happens is that the reference is replaced by individual, loose entities.

Notes

The explode tool can also be used for other entities than references (for example dimensions, texts,
hatches or ellipses). This is the reason why this tool is listed in two menus, the menu Modify and
menu Block.
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Chapter 17

The Library Browser

Objective
In this chapter, you will
• get to know the library browser, a user interface component to browse and

insert predefined drawing blocks,
• learn how to extend the part libraries to make blocks available to other

drawings.

What is a Part Library?

In the previous chapter you have seen how entities can be grouped together into blocks and how
these blocks can be inserted multiple times into the same drawing. QCAD also offers a way
to make blocks available across drawings. For example if you often create floorplans of office
layouts, you might frequently use the same blocks representing desks, chairs, tables, doors, etc.
You can store such blocks in a part library to make them easily accessible when working on new
drawings.
The default part library that comes with QCAD already contains a few example symbols and parts.
More symbols, drawings or entire libraries can be added by the user. Several extensive libraries
with blocks for various industries are available from the QCAD website at http://www.qcad.org.
There are also various other sources on the Internet from where drawings can be downloaded or
purchased. If the drawings are two dimensional and available as DXF or DWG files, they can
usually be used with the library browser of QCAD. SVG files are also supported, although only
a subset of the elements in an SVG file can be imported by QCAD.

The Library Browser

The library browser is a utility that can be used to browse part libraries and insert drawings from
them as blocks into your current drawing.
You can display the library browser through the menu View > Library Browser or by clicking the
library browser icon in the tool bar at the right:

Menu: View > Library Browser
Keycode: GL
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Figure 17-1 shows the library browser as it is displayed after when shown for the first time.

Figure 17-1: The library browser allows you to browse and
insert blocks from a library of existing parts (drawings).

The library browser is displayed as a separate window at the right of the QCAD application
window. You might want to move it to a different location, resize it or dock it to the QCAD
application window if desired.

Initially, the library browser only shows a few folders and items which are provided with every
QCAD installation as the QCAD Default Library.

The library browser has three different navigation modes which can be accessed through the tabs
at the top:

• The File System tab shows the structure of the library in the same way as it is stored and
organized in the file system.

• The Search tab lets you search for items.
• The Favorites tab shows your favorite items and folders. This is likely empty at the

moment as you might not have marked any items as favorites yet.

The File System and Search tabs of the library browser are split up into two parts:

• The top part shows the navigation that lets you select which folders or subjects you are
interested in.

• The bottom part shows a preview of the symbols or parts which match the current
selection. It is also used to select the item to insert.

Browsing Library Items Using the Folder Structure

The File System tab is helpful to find items that were not previously tagged with meaningful key-
words or to locate an item if its folder is already known. If you double-click on folder default and
then click on the subfolder Symbols the contents of the folder libraries/default/Symbols is dis-
played in the bottom part of the library browser (Figure 17-2).
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Figure 17-2: In the File System tab, the contents of the selected
folder at the top is shown in the bottom part of the library browser.

Inserting an Item

To start inserting an item from the list at the bottom, you can either:

• double-click the item icon in the preview or
• drag and drop it into the drawing area of your open drawing or
• select it and then click the insert button at the bottom of the library browser window:

1. Choose or type the desired rotation angle and scale factor in the options tool bar and use
the flip buttons to mirror the item horizontally or vertically if desired.

2. Tick the option Overwrite layers to overwrite layers which already exist in the drawing
with those from the library item. This is usually not desired. If layers are overwritten,
the attributes of existing layers will be replaced with attributes from the layers of the
library item.

3. Tick the option Overwrite blocks to overwrite existing blocks in the drawing with the
blocks of the library item. This can be useful to update a block definition.
The library might for example contains a new block definition for a block called
desk. All block references to an existing but outdated block called desk in the target
drawing have to be updated to this new block definition.

4. Click the position where you want to place the inserted library item.

Searching for Items

The Search tab offers a search tool. When first shown, it does not display any items.

One way to quickly look up an item is to enter a search term in the Look for field at the top. For
example when entering the term ruler and hitting the Enter key, the library browser shows all
items that contain the term ruler in their name (Figure 17-3).
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Figure 17-3: The Look for field can be used to quickly look for any text in all item filenames.

Note that the search result can contain items as well as folders. If a folder is listed as result, all
items in that folder or a sub folder are also listed as result. In other words, if a folder matches a
search term, all items it contains automatically also match the search.

Favorites

If you regularly work with the same set of items or folders, you can add these items or folders to
your list of favorites. Simply right-click on an item in the preview area or on a folder in the File
System tab and choose Add to Favorites. You can then use the Favorites tab to quickly access
your favorite items and folders. To remove an item from the Favorites tab, right-click on it and
choose Remove from Favorites.

Extending the Part Library

If you work with blocks or symbols a lot, it is a good idea to constantly extend the part library of
QCAD with your own drawings. The following steps guide you through the process of extending
the part library. Note that you need to be familiar with the concept of folders and files on your
operating system to follow along.

Extending the Folder Structure

First, we will create a new folder in the part library. We call this folder office and will later store a
block that represents a desk inside. This part does not involve QCAD, but your operating system
and the application you normally use to manage folders and files (e.g. Windows Explorer, macOS
Finder or a Linux file manager or terminal).

1. Look up the folder on your hard drive where you have installed the QCAD application.
This can for example be C:\Program Files\QCAD or /Applications/QCAD or /home/
user/opt/qcad, depending on the operating system you are using and your personal
preference of where you usually install applications.
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2. Inside the application folder of QCAD, you can find a folder called libraries. This is
the folder that contains the part libraries that come with QCAD and any additional part
libraries you might have installed. The folder structure in that folder reflects the folder
structure shown in the top part of the File System tab of the library browser.

3. In the folder libraries/default, create a new folder called office, so that office is a
subfolder or sub directory of directory default.

4. In the library browser of QCAD, click the button at the top bottom right to synchronize
(update) the library browser to reflect the new folder structure on disk:

5. The library browser should now show the folder default/office in the top part of the File
System tab. If you click on that folder, nothing is shown at the bottom as expected, since
the folder is still empty.

Adding Items to a Library

A part library can be extended with your own custom blocks by simply storing drawings into the
folder structure of the part library. For example to add a desk to the part library, you could draw
the desk first (as a normal drawing without using blocks) and then store that drawing into the a
subfolder of the libraries folder of your QCAD installation, for example the libraries/default/of-
fice folder you have created (see above).

After restarting QCAD, or clicking the synchronization button, the new item is available in the
default/office folder of the library browser.

Creating Library Items from a Selection

Menu: Block > Create Library Item
Keycode: BT

 

As a convenience tool, QCAD allows you to save a selection in the current drawing as a new
part library item:

1. Select the drawing entities you want to be part of the new part library item.
2. Click the button at the bottom of the library browser to create a part library item from

the current selection:

3. Click the reference point you want to use when later inserting the block.
4. QCAD shows a file dialog to choose where you want to save the new item. The file

dialog automatically shows the libraries folder of your QCAD installation, so you can
easily choose an existing folder (e.g. office) in an existing library (e.g. default) to store
your new library item. You also have to give the item a name, for example desk.
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Chapter 18

Import

Objective
In this chapter, you will
• learn what bitmaps (or raster graphics) are,
• learn how to import bitmaps and SVG files into your drawings.

Bitmap Import

What is a Bitmap?

Bitmap files (or raster graphics files) are graphics files in which an image is stored as many
dots with different colors. Bitmaps typically contain photographs or paintings rather than exact
geometrical objects.
Bitmaps come in various different formats. The most commonly used bitmap formats are JPEG
(files ending in .jpeg or .jpg), GIF (.gif), PNG (.png), TIFF (.tif or .tiff) and Windows Bitmap
(.bmp). QCAD supports all of those and additionally some other formats which are rarely used.
As a CAD system, QCAD is specialized in vector graphics which contain geometrical entities
such as lines and arcs. Bitmaps are different from vector graphics. Consider the photograph of
a stone wall as shown in Figure 18-1. The photograph is stored as a bitmap file that contains
thousands of tiny dots with different colors. Figure 18-2 shows in contrast a vector graphic of
the same stone wall. This graphic is stored as lines which can be defined as vectors (hence the
name vector graphic).

Figure 18-1: Photograph of a stone wall. The image
is stored as a bitmap (small dots with different colors).
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Figure 18-2: Vector graphic of the same stone wall.
Vector graphics are stored as geometrical elements.

When to Use a Bitmap

There are only a few but nonetheless important uses for bitmaps in a CAD system:

• To include a company logo or something similar in a drawing.
• To show a photograph that helps to understand the drawing or has a connection to the

drawing.
• Bitmaps can be displayed in the background of a drawing for vectorization.

Vectorization is the process of converting a bitmap into a vector (CAD) drawing. This
is often used for drawings that don't need to be very precise. For example to trace art
designs from a scan or photograph or to vectorize the boundaries of a geographical
feature from a satellite picture. A convenient way to create the vectorized stone wall
pattern in Figure 18-2 would be to display the bitmap in Figure 18-1 and trace the
stones with the line, polyline or spline tool of QCAD.

Inserting Bitmaps into a Drawing

Menu: Draw > Insert Bitmap
Keycode: IM

 

Usage

1. To insert a bitmap image into a drawing, click the image button in the toolbar:

2. QCAD shows a dialog to choose and open an image file. Select the file you want to
insert and click the OK button.
Note that you can also insert SVG files using this tool. However, the SVG files will be
rendered into a bitmap prior to insertion. If you wish to import the geometry in an SVG
file, please use menu File > SVG Import instead.

3. When you move the mouse around in your drawing, you can see that QCAD shows a
preview of the image shape as a rectangular border. If you cannot see that border, the
image might be larger than the current viewing area.
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You can use the options toolbar to adjust the size of the image before you position the
image in the drawing:

You can also rotate the image at this point. However, this is only recommendable for
relatively small images. Rotating large images with QCAD will decrease the display
performance considerably. Large images can better be rotated before inserting them into
a drawing. You can use your favorite image manipulation program to rotate images.

4. Click the position where you want to insert the image. This is the lower, left corner of
the image.

5. Terminate the tool by clicking the right mouse button or by hitting the Escape key on
your keyboard.

6. If the bitmap overlaps and hides a part of your drawing, you can now select the bitmap
and choose the menu Modify > Send to Back to make sure that the bitmap is displayed
behind any other entity.

SVG Import

Menu: File > SVG Import...

 

QCAD also offers an SVG (Scalable Vector Graphics) import tool which is designed to import
as much of the SVG geometry as possible into QCAD. Note that only a small subset of the full
SVG standard is supported. Nevertheless, this can be useful to import logos or symbols which
are available as SVG format. Some of the part libraries that can be downloaded from the QCAD
website contain items in SVG format.
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Chapter 19

Export

Objective
In this chapter, you will

• learn how to export your drawings into various formats so you can share them
with other people or use them in other applications.

Exporting Drawings

In many situations you might have to transfer your drawings from QCAD into other applications
or embed them in a document. For example you might want to transfer a CAD drawing to a word
processor or publishing system. In the same way, all drawings in this book have been produced
with QCAD and exported into a format that is understood by the publishing system that was used
to produce this book (in this case SVG).

Exporting a drawing always results in a new file which is meant for a specific purpose. The export
tools are not suitable for storing original drawings. An exported drawing is merely a copy of a
drawing and usually intended for visual representation only. Always make sure that your original
drawings are stored in a native QCAD format (such as DXF or DWG).

Bitmap Export

Menu: File > Bitmap Export
Keycode: XB

 

Perhaps the most reliable but also a rather limited way to export a drawing for use with other
applications is to export it as a bitmap. QCAD can export drawings to all common bitmap formats
such as PNG (.png), JPEG (.jpg or .jpeg) or the Windows Bitmap format (.bmp).

Bitmap export is the right choice if you want to make an image of your drawing available on a
web site or if you want to transfer it to an image manipulation program as a basis for a bitmap
based design. In some cases bitmaps might also be sufficient for word processors or presentation
programs. However, if you need to print the material at one point, you are usually better off with
a vector format such as DXF, SVG or PDF.
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Drawings in a vector format can be scaled without losing information and can generally be printed
at a better quality than bitmaps. With QCAD it is also possible to generate high-resolution bitmaps
that can be printed without any loss in quality. However, such bitmaps consume a lot of memory
and might slow down a word processor or presentation program significantly.

Usage

1. Make sure that only the layers you want to export are visible.
2. If appropriate, switch to the block you wish to export. This can be any block, but

would usually be the model space (main drawing) or a layout block.
3. To start the bitmap export, choose the menu File > Bitmap Export.
4. QCAD shows a dialog window to choose a filename and a format. If you are not sure

what format to choose, PNG is likely to be a good choice. PNG is a widely supported,
open standard. PNG files are compressed but don’t show any compression artefacts
like JPEG.

5. Click OK to confirm the file dialog.
6. The next dialog lets you adjust the size of the exported bitmap, the background color

and various other properties:

• The first option in the dialog is the Bitmap Size. The bitmap size is specified in
pixels (small dots). The width of the bitmap is the total number of pixels the image
will have horizontally (in X direction) and the height the number of pixels vertically
(Y direction). You can enter any numbers here and QCAD will create a bitmap of
that size and place your drawing in the middle of it, scaled to fill the whole bitmap.
For example if you enter 100 for the width and 100 for the height, a bitmap of that
size will be produced with your drawing in it:
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If the same drawing is exported with a width and height of 500 pixels, it shows
more details and appears to be sharper:

Generally speaking, higher values for the width and height of the image will
generate images with a higher quality (or resolution). The price for the quality
increase is the disk space or memory usage and the time it takes to create or load
the image. Note that images with a width or height of more than about 10000 pixels
might take a long time for QCAD to generate and for other applications to load.
The maximum number of pixels that can be exported into one bitmap (width times
height) is 536.870.911 pixels.
Instead of entering a fixed width and height, you can also adjust the resolution of
the bitmap directly. If you create an image with a resolution of 20, that means that
there will be 20 dots in the image for every one unit in your drawing. For a drawing
in Millimeters, there will be 20 dots per Millimeter. QCAD calculates the width and
height of the image automatically, based on the size of your drawing. Keep an eye
on these values to make sure that you are not accidentally creating a huge image
that will take a very long time to generate.

• The second option is the Background of the bitmap. You can choose between a
white and a black background.
The color of entities that were created in black or white will be adjusted to the
opposite color of the background color to avoid having entities drawn in the same
color as the background. This behavior can be changed in the application options
under Edit > Application Preferences > Graphics View > Prevent white on white /
black on black display.

• You can export the bitmap in full color, grayscale or monochrome (black/white).
• Anti-aliasing can be enabled to diminish jagged, steplike lines that should be

smooth.
• Adding an extra margin around the bitmap to compensate for line weight can help

preventing that half of thick lines near the border might be cut off.
7. Confirm also this dialog.

Depending on the complexity of your drawing and the chosen resolution or image size,
the export might take a while to complete. QCAD notifies you in the command line
window when the export has completed or if there were any errors.
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SVG Export

Menu: File > Advanced SVG Export

 

The Scalable Vector Graphics format (SVG) is a good vector graphics alternative to bitmaps,
provided the target application supports SVG.

SVG files that are produced with QCAD can be optimized to provide SVG files that look identical
to the original drawing. Alternatively, there is an export option to transfer as much of the geometry
across as possible.

Usage

1. Make sure that only the layers you want to export are visible.
2. Choose the menu File > Advanced SVG Export...
3. QCAD shows a dialog window to choose a filename and various other options for the

SVG file to export.
The most important option is Preserve geometry:
• If enabled, this option causes QCAD to preserve as much of the geometry and

information as possible. Texts and dimension labels are exported as SVG text
elements.

• If the option is disabled, the exported graphics will look identical as it is rendered
in QCAD self. To achieve this, QCAD might split up entities with line patterns into
smaller segments. All text entities are exported as paths.

4. Click OK to confirm the file dialog.
5. QCAD generates the SVG file.

PDF Export

Menu: File > PDF Export
Keycode: XD

 

The Portable Document Format (PDF) is a de facto standard for sharing printable documents
over the Internet and across operating systems. PDF documents can be opened on any computer
and look identical on any platform. Since PDF is an extremely popular format, you can usually
assume that the receiver of your document can handle PDF files. Whenever you need to share
drawings with people who only need to view or print them and don't need to edit them, PDF is
your best choice.

Usage

1. Make sure that only the layers you want to export to the PDF are visible.
2. Choose the menu File > Print Preview to switch to the print preview of QCAD.



Part VI Import, Export and Printing

237

3. Use the print preview to adjust the scale and position of your drawing on the sheet
of paper. You can set the scale in the options toolbar or use one of the buttons in the
options toolbar to automatically fit your drawing on the paper:

To reposition the drawing manually, click the button with the hand symbol:

You can then press the left mouse button, drag the mouse and let go of the left mouse
button to reposition the paper. Click the right mouse button or press Escape when the
paper is in the desired position.
The print preview is described in more detail in the next chapter.

4. Choose the menu File > PDF Export or click the PDF button in the options toolbar of
the print preview:

5. A dialog window lets you choose a filename for the PDF file.
6. Click OK to confirm the file dialog.
7. QCAD generates the PDF file.
8. Close the print preview by clicking the close button in the options toolbar:

DXF Export

QCAD uses the DXF file format as one of its native file formats. DXF was designed to exchange
drawings between different CAD applications from different vendors. However, due to the com-
plexity of the DXF format and vector graphics formats in general, not every application that offers
support for DXF can read all entities from a QCAD drawing.

QCAD offers some possibilities to reduce the complexity of DXF files and increase compatibility
between applications.

Creating a Simplified DXF File

Many CAD and non-CAD applications do not support the full range of CAD entities in a DXF
file. For example an office suite might not be able to import dimensions or hatches from DXF
files. To get these entities across, you may want to explode them first in QCAD to break them
up into simpler entities. Such simplified DXF files can usually be loaded by applications that
import DXF files.

Procedure

1. Select all entities in your drawing.
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2. Choose the menu Modify > Explode. All complex entities have now been broken up
into simpler entities.

3. Select all entities again and choose the menu Modify > Explode again. This will further
break up the resulting entities from the first step.

4. Choose the menu File > Save As to save the drawing under a new name. Make sure
that you don't overwrite the original file as a lot of the original information contained
in your drawing is now lost. Such an exploded drawing is not suitable anymore for
CAD editing and should only be used as a means to export a drawing for display in
another application that does not support all CAD features.
In the Save As dialog, you might want to choose an older DXF format, depending on
what is supported by the target application.
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Chapter 20

Printing

Objective

In this chapter, you will

• print a drawing on paper,
• get to know the print preview of QCAD,
• learn how to print a drawing exactly to scale.

Printing a Drawing

Menu: File > Print
Keycode: Ctrl-P (Mac: ⌘P)

 

Printing a drawing with QCAD is not more complicated or difficult than printing a document
with any other application.

Usage

1. Load your drawing if it is not already loaded.
For this example, we load the example drawing flange.dxf which comes with every
QCAD installation.

2. Hide the layers you don't want to print and make sure that all layers you want to print
are visible.
For the example drawing, we want to print all layers.

3. Before you print a drawing, always switch to the print preview of QCAD, so you can
see what QCAD is going to print and avoid any unnecessary printer output.
Choose the menu File > Print Preview to switch to the print preview mode of QCAD.
In this mode you can see the paper in the background of your drawing. This allows you
to adjust the drawing scale and drawing position relative to the paper. If you cannot see
the full paper, zoom out a bit. Just like in the normal mode of QCAD, you can use the
mouse wheel to zoom in and out and the middle mouse button to pan.
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4. You might want to adjust the paper size and orientation at this point. Choose the
menu Edit > Drawing Preferences to show a dialog that allows you to adjust various
settings for the current drawing. Activate the section Printing / Page to show the page
preferences. Choose the predefined paper format that is supported by your printer. This
is most likely ISO A4 or ANSI A (Letter). For the orientation, you can choose between
Landscape (the longer page side is at the bottom) or Portrait (the shorter page side is
at the bottom).
For the example drawing, we choose the format ISO A4 or ANSI A (Letter), depending
on your printer. For the orientation we choose Landscape:

Confirm the changes by clicking the OK button.
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5. Click the button in the options toolbar to automatically fit the drawing on the chosen
paper:

This button automatically adjusts the drawing scale and position so that the whole
drawing fits on the paper and is centered on the page:

Note that your drawing has not been changed in any way. The tools in the print
preview do not scale or move your actual drawing, they merely apply some additional
information to it, so it can be printed.

6. Choose the menu File > Print.
7. The printer dialog is shown.

Click OK to confirm the printer dialog.
8. If your printer is configured correctly, QCAD prints the file now.
9. To close the print preview, choose menu File > Print Preview again or click the close

button in the options toolbar:

QCAD also offers the possibility to print your drawing exactly to scale, if necessary on multiple
papers. These more advanced printing techniques require some additional steps that are outlined
in the next section.

Printing a Drawing to Scale

CAD drawings are usually printed exactly at a standardized scale factor. Some industries have
widely accepted standards for drawing scales and you should stick to those whenever possible.
To print a drawing to scale with QCAD, you can simply define the desired scale in the options
toolbar of the print preview before printing.
The following steps guide you through the process of printing the example drawing again, this
time at a scale of 2:1 (double the actual size).
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Usage

1. Load your drawing and switch to the print preview (File > Print Preview).
2. QCAD remembers your previous printer settings for your drawing.

For our example drawing this means that the drawing is still scaled to take up the
entire page. In the options toolbar at the top, you can see an arbitrary scale factor at
which the drawing is currently scaled.
This scale factor has been automatically calculated by QCAD at the time you clicked
the button to automatically fit the drawing on the chosen paper.
To change the drawing scale, use the scale control in the options toolbar to choose the
desired scale factor or enter a factor directly.
For our example, we choose 2:1:

3. The drawing might not fit on the chosen paper size at this scale.
This is also the case for our example drawing. To print it at a scale of 2:1, we have to
print it on multiple pages. For this drawing, we can for example choose to print it on
two A4 pages in portrait orientation beside each other.

4. Choose the paper orientation you want to use.
For our example, we click the Portrait button in the options toolbar:

QCAD updates the print preview accordingly with one page in portrait orientation:
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5. Click the button to automatically add as many pages as necessary that the whole
drawing can be printed:

For our example, QCAD suggests to print the drawing on two pages beside each other:

6. Choose the menu File > Print to print the drawing. This time the printout should show
your drawing scaled with a factor of 2:1.
Instead of printing you can also create a PDF file from the print preview. This can be
useful to avoid unnecessary prints or to print only some selected pages.
Note that depending on your printer, the scale might not be 100% precise. However,
most modern printers should produce sufficiently accurate results.
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Using Layouts

So far, we have seen how an entire drawing can be printed to scale. For more advanced printing
requirements, a layout (or paper space) can be created. A layout shows one or multiple parts of
the drawing, typically accompanied by a drawing border and drawing header. Each part can be
shown at a selected scale and angle. Figure 20-1 shows a layout block with a drawing border, a
drawing header (bottom right) and three parts of the main drawing (dashed rectangular areas).

Figure 20-1: A layout block containing parts of the
main drawing and a drawing border and header.

Layouts can only be created in special layout blocks. Unlike other blocks, these blocks cannot
be inserted into the drawing but are exclusively used to arrange parts of a drawing for printing.
Layout blocks are shown at the top in the block list, directly under the main drawing (the "Mod-
el_Space" block).

When starting a new drawing from scratch, one layout block is already present ("Layout1"). More
layout blocks can be added using Block > Add Layout Block.

If a layout block is double-clicked in the block list, QCAD automatically switches to the print
preview and shows the contents of the layout block. Initially, the layout block is empty. Before
getting started, make sure that the layout block is configured to use the desired paper size and
orientation: Edit > Drawing Preferences > Printing > Page. Note that these preferences apply
only to the current block. In QCAD, each block can have its own printer settings.

After setting up the paper format, you would typically draw or insert a drawing border and header.

Parts of the drawing can then be shown in the layout by creating viewports. A viewport is a
rectangular area that shows a part of the main drawing at a configurable scale. If the viewport
is not large enough to display the whole drawing, the drawing is clipped at the viewport border.
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Viewports act like block references to the main drawing. If the main drawing is updated, the
viewports automatically reflect those changes.

Adding Viewports

Menu: Draw > Viewport > Add Viewport
Keycode: VT

 

With this tool you can add a viewport to a layout block.

1. After starting this tool, QCAD switches to the model space, the block that contains your
main drawing.

2. Adjust the scale and rotation angle of the viewport. Note that rotated viewports are not
supported by other CAD systems.

3. Click the first corner of the area the viewport should display.
4. Click the second corner of the area.
5. QCAD now automatically switches to the layout block. If there are multiple layout

blocks, a dialog lets you choose which layout block to use.
6. Insert the viewport by clicking the center of the viewport.
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Chapter 21

Orthographic Projections

Objective

In this chapter, you will

• see how three-dimensional objects can be drawn in two dimensions,
• learn what orthographic projections are,
• get some practice in interpreting plans and technical drawings.

Views of an Object

The aim of most drawings is to present enough information that the object in the drawing could
be manufactured. If this information cannot be contained in one single view, several views of the
same object may be provided in one drawing.

The most common views show an object from its top (top view), front (front view) or side (side
view). All these views are called orthographic projections. An orthographic projection projects
a three dimensional object onto a vertical or horizontal plane.

Figure 21-1 shows three orthographic projections of a chair. The top view shows the chair as it
would be seen by a viewer who looks vertically down on the top of the chair. The front view
shows the chair from its front side and the side view from its side (in this case the right side).
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Figure 21-1: ISO arrangement of orthographic projec-
tions as used in Europe and Asia (first-angle projection).

Local Standards

First-Angle Projection

The way in which the views are arranged depends on the local standards that are in use. In Figure
21-1, the views are arranged according to the ISO standard. This standard is also called first-
angle projection and very common in Europe and Asia. In a first-angle projection, the top view is
placed at the bottom of the drawing and the front view straight above the top view. The side view
is placed at the left of the front view if the right side is drawn. Alternatively, if the view from the
left is more convenient, it may be drawn to the right of the front view.

Third-Angle Projection

In the US, Canada and Australia, the views are usually combined in a different way as shown in
Figure 21-2. This arrangement is called third-angle projection.
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Figure 21-2: Arrangement of orthographic projections
in the US, Canada and Australia (third-angle projection).

Comparison of First-Angle Projection and Third-Angle
Projection

Figure 21-3 illustrates how the first-angle projection relates to a three-dimensional object (in this
case a dice). Imagine there is a box around the object. You can think of the first-angle projection
as a projection of the object onto those three walls of the box that are behind and below the object.
The drawing at the left shows how the top, front and side of the dice are projected onto the walls
behind and below the object. In the drawing at the right, the box is unfolded onto one flat plane.

Figure 21-3: First-angle projection of a dice.

When third-angle projection is used instead, the object is projected onto those walls of the box
that are before and above the object as shown in Figure 21-4.
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Figure 21-4: Third-angle projection of a dice.

Note that both standards show the same views of the dice. The difference is only in the way how
the views are arranged when combined in a single drawing.

First-angle projection and third-angle projection are both equivalent. Nevertheless, there can be
misunderstandings when interchanging drawings between different countries. To avoid such con-
fusion, drawings may contain a symbol that indicates which standard is being used. Figure 21-5
shows the international symbols for first-angle projection and third-angle projection.

Figure 21-5: These international symbols may be used to in-
dicate which standard is in use on a particular drawing.

Drawing Techniques

One way to easily construct orthogonal projections is by using vertical and horizontal lines to
connect the views. These lines are often called auxiliary lines and are later removed or hidden
for the final drawing.

First Step: The Top View

To create the three orthographic projections of an object, the draftsperson starts with the most
detailed view which is very often the top view. An example for a top view of an object is shown
in Figure 21-6.
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Figure 21-6: The top view of an object.

This top view gives a first idea of the shape of the object. However, it does not define any vertical
properties such as the total height or whether that circle is a hole in the object or a cylinder that
is sticking out of the object. Figure 21-7 shows only three of many possibilities of objects with
exactly this top view.

Figure 21-7: Three possible objects for the top view shown in Figure 21-6.

Second Step: The Front View

The next step is to create the front view and place it directly above the top view. Since the top
view is already there, many measures of the front view can now be easily transferred from the
top view. This is often done with vertical lines that go through edges and significant points of the
front view. Figure 21-8 shows the top view and the front view with the auxiliary vertical lines
that were used to transfer the measures across. These lines may be removed or hidden after the
front view is complete.

Figure 21-8: Transferring measures from the top view to draw the front view.

With these two views given, most parts of the object are now defined. In fact, two views are often
enough to completely define an object. In our case, however, there are still multiple objects that
would have the same top and front view. Figure 21-9 shows two possible objects with identical
top and front views.
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Figure 21-9: Two possible objects for the top and front view shown in Figure 21-8.

Third Step: The Side View

The vertical measures of the side view can be easily produced by transferring the edges of the
front view with horizontal lines to the left into the side view as shown in Figure 21-10.

Figure 21-10: Transferring the vertical measures from the front view into the side view.

To transfer the horizontal measures across from the top view, a diagonal line at an angle of 45
degrees may be used as shown in Figure 21-11. For each position, a horizontal line is drawn from
the top view towards the left until it meets the diagonal. From those intersection points, vertical
lines are drawn into the side view.

Figure 21-11: Transferring the horizontal measures from the top view into the side view.

The side view can now be drawn by connecting the correct intersections of the auxiliary horizontal
and vertical lines (Figure 21-12).
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Figure 21-12: Transferring the horizontal measures from the top view into the side view.

After that, the auxiliary lines may be removed or hidden to get the final drawing (Figure 21-13).

Figure 21-13: The final drawing with the three orthogonal projections.

Figure 21-14 shows the three projections again, together with the only possible object that match-
es the given top view, front view and side view.

Figure 21-14: The three orthogonal projections with the object they define.

Hands-on: Orthographic Projections

Before you can start drawing the orthogonal projections of an object you need to have a good
idea of how the object will look like. When you are working on a real CAD project, you would
usually start with a few hand sketches on a sheet of paper or sometimes just with a picture in
your imagination.

For the purpose of this example we start with the three dimensional drawing shown in Figure
21-15.



Part VII Projections

255

Figure 21-15: In this exercise we will draw the
top view, front view and side view of this object.

Setting up the Drawing

1. Launch QCAD with a new, empty drawing.
2. For this drawing we will need four layers:

• Layer name: visible
• Color: Black
• Width: 0.25mm
• Line type: Continuous

• Layer name: hidden
• Color: Black
• Width: 0.18mm
• Line type: Dash

• Layer name: center
• Color: Red
• Width: 0.13mm
• Line type: Dash Dot

• Layer name: auxiliary
• Color: Yellow
• Width: 0.05mm
• Line type: Dot

Layer auxiliary will be used for the lines we will use to transfer measures from one view to
another one.

The Top View

We start by drawing the top view of the object. Figure 21-16 shows how the top view will look
like when it is finished.
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Figure 21-16: The finished top view of the part shown in Figure .

1. Activate layer visible and draw a rectangle that represents the outline of the object as
seen from the top. Set the first corner of the rectangle at the origin of the drawing (1)
and the other corner at 30,20 (2).

2. Use the parallel tool to create the parallels at the top and bottom. The distance from the
border to the parallels is 4.

3. Switch the active layer to center and create the center line as a parallel to the right side
with distance 10.

4. Create the lines for the drilling on layer hidden. The radius of the drilling is 4.

5. Delete the unwanted segments with the Break out Segment tool:

6. Extend the center line on both ends by 2.5 using the Lengthen tool:
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The top view is now complete.

The Front View

Next we add the front view of the object. We place the front view directly over the top view (first-
angle projection). Figure 21-17 show the front view we are going todraw.

Figure 21-17: The front view when it is finished.

1. We start the front view by transferring the X-Coordinates from the top view up into the
location of the front view. For that purpose, we draw some auxiliary lines vertically
from the top view to the area where the front view will be.

2. Activate layer auxiliary.
3. Choose the tool for drawing vertical lines:

4. Enter 50 for the length and set the snap point to Start:

5. Use the auto snap tool of QCAD to position the vertical lines:

Position the vertical lines through every significant point in the top view which you
want to transfer to the front view:
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6. Stay on layer auxiliary. Create the base line of the front view as a parallel to the
uppermost line in the top view with distance 10.

7. Create four parallels to that base line with distances 8, 15, 25 and 35.
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8. Create two parallels with distance 4 to the line which is at the center of the drilling.

9. Switch to layer visible and create the three visible straight edges of the front view with
the line tool.

Note that for the sake of brevity the illustration above only shows that part of the
drawing that is going to contain the front view.

10. Choose the tool for drawing circles with a given center and a given point on the circle
line:

11. The circle tool lets you choose the center of the circle first and then a point on the
circle line. To draw the circle for the drilling, set the center point at the intersection of
the vertical center line with the horizontal center line. Set the point on the circle line at
the intersection at the right or left of the center:
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12. With the same tool, create also the larger circle around the same center.

13. For the next step we need to create a tangent from the loose end at the left to the larger
of the two circles. QCAD offers a special tool for creating a tangent from a given point
to a circle.

14. The tool asks you first for the point. Click the end point of the loose end at the left (1).

15. Move the mouse cursor to the larger circle, close to the point where the tangent
touches the circle (2). This is important because there are two possibilities to create
a tangent from a point to a circle and QCAD will choose the one that is closer to the
mouse cursor when you click the mouse button.

16. For the next two steps, the auxiliary lines would be in the way. However, we don't have
to delete them but can simply hide them for the moment by hiding the layer auxiliary.
To do that, click on the eye symbol close to the layer name auxiliary in the layer list.

17. The larger of the two circles should only be an arc instead of a full circle. The quickest
way to get rid of the part that we don't want in our drawing is by deleting the segment
we don't want with the Break out Segment tool:
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Click the lower part of the circle to remove that segment.

18. We can now round the corner that is shaped by the left side and the tangent. QCAD
offers a tool that can round a corner that is formed by two lines.

19. The tool shows an option toolbar which lets you enter the radius of the rounded corner.
Type 10 for the radius and make sure that trimming is enabled (the trim check box is
ticked).

20. Click the first line that forms the corner (1) and move the mouse cursor to the second
line (2). QCAD shows a preview of the rounding before you click the second line.
This allows you to check if the correct rounding is chosen if there is more than one
possibility. Click to confirm when the preview looks right.

21. Make the layer auxiliary visible again by clicking its eye symbol.
22. Switch to layer hidden and draw the one invisible edge of the front view.
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23. Switch to layer center and draw the center lines of the drilling. Hide layer
auxiliary and use the Lengthen tool to extend the center lines by 2.5 beyond the circle.

24. The front view is now complete.

The Side View

The side view is placed at the left of the front view, exactly on the same height as the front view
(first-angle projection). Figure 21-18 shows the completed side view.

Figure 21-18: The finished side view.

1. First, we transfer the edges of the front view horizontally over into the side view. We
could do this similarly as we transferred the measures from the top view into the front
view. However, we already have those auxiliary horizontal lines we used to create the
front view, so we can simply extend those to the left into the side view.

2. To make sure that you will only extend auxiliary lines and not lines that are part of our
final drawing, hide all layers except layer auxiliary. The quickest way to do this is to
first hide all layers by clicking the button with a gray eye at the top of the layer list:

 
Then show layer auxiliary by clicking its eye icon in the layer list.

3. Use the Lengthen tool to extend the horizontal auxiliary lines by 40 units to the left:
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4. Make all layers visible again with the button that shows a black eye at the top of the
layer list.

 
5. At this point your drawing should look like this.

6. We now need to transfer the measures from the top view across to the side view
and start this process by creating a 45 degree auxiliary line through the origin of the
drawing. Use the tool for drawing a line with a given angle for that.

 
 

7. Enter the angle 45 degrees and a length of 50 and make sure that the snap point is set
to End:

8. Set the position of the line at the lower left corner of the front view (coordinate 0/30).

9. Draw horizontal lines from the edges of the top view to the left. Just like for vertical
lines, QCAD also has a tool for horizontal lines:

 
Set the length of the horizontal lines to 40.
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10. This already gives us the points we need as intersection points but for clarity we will
now remove the line segments that extend beyond the 45 degree line. Use the Break
out Segment tool to do that.

11. On the 45 degree line, we can now clearly see the points that we want to transfer into
the side view. Choose the tool for vertical lines with a length of 70 and click every
intersection point on the 45 degree line. The vertical lines should now intersect with
the previously extended horizontal lines from the front view. How far they extend
above that is not important since we are only interested in the intersections.
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12. Try to create the side view including the invisible line and the center line by
connecting the appropriate intersection points.

13. Extend the center line like you are used to, and you are done with the side view. You
can now switch off layer auxiliary to show the complete drawing.

Exercises

1. Draw the top, front and side view of this cube. Use the arrangement (first-angle
projection or third-angle projection) that is common in your location.
The side length of the cube is 20 and the drilling has a radius of 5 and goes through the
whole cube.

Note: You might want to do this with a pencil on a sheet of paper before you do it with
QCAD.
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2. Use paper and pencil to sketch an approximate three-dimensional view of the object
shown here.

3. Is the side view in the figure of the previous exercise necessary or would you know
how the object looks like even with only the top and the front view?
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Chapter 22

Isometric Projections

Objective

In this chapter, you will

• learn what isometric projections and isometric drawings are,
• learn how to produce simple isometric (three-dimensional) views from

orthogonal drawings.

What are Isometric Projections?

A collection of two-dimensional orthogonal projections provide sufficient information for a man-
ufacturer to produce an object. However, they often require a great deal of imagination from the
viewer to mentally combine the two-dimensional drawings into a three-dimensional object. Con-
sider the three orthogonal projections in Figure 22-1. The projections define a unique object, but
even an experienced drafts person cannot tell immediately how the object looks like.

Figure 22-1: Orthogonal projections require a good imagina-
tion from the viewer to fully understand how an object looks like.

For this reason, orthogonal projections are often accompanied by a three-dimensional drawing
of the object. The three-dimensional drawing is not required for manufacturing but it gives the
viewer an immediate impression of the object without having to study the orthogonal projections.

One of the most popular three-dimensional projections is the isometric projection. Figure 22-2
shows the drawing from Figure 22-1 again, this time accompanied by an isometric projection of
the object.
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Figure 22-2: Isometric projections are very popular for technical drawings and
presentations. An isometric projection (right) usually gives a better immedi-

ate impression of how an object looks like than the orthogonal projections (left).

Creating Isometric Projections

Menu: Modify > Isometric Projection
Keycode: PJ

 

Isometric projections are usually created once the orthogonal projections are complete. QCAD
offers a tool that supports you to create isometric projections from orthogonal projections. The
tool creates a flat top, front or side projection for the selected objects. Table 22-1 shows what the
tool produces for the different viewing directions. Note that this tool is only an auxiliary tool and
additional work is required to produce the correct isometric projection.

Table 22-1 Isometric Projections
Orthogonal
projection (selection for the
isometric projection tool)

Viewing direction Isometric projection

Top

Front



Part VII Projections

269

Orthogonal
projection (selection for the
isometric projection tool)

Viewing direction Isometric projection

Side

The following steps guide you through the process of creating the isometric projection at the right
in Figure 22-2 from the orthogonal projections at the left in Figure 22-2.

Usage

1. Before you create an isometric projection you need to create at least two of the
orthogonal views of the object (top, front or side views).
For our example, the starting point are the three complete orthogonal projections from
Figure 22-1:

2. Select all entities of the orthogonal view that contains the most characteristics of the
object. This is often but not always the top view.
We select the entities of the top view for the example:

3. Choose the Isometric Projection tool from the CAD toolbar at the left:

4. Click a reference point for the projection. At this point the reference point is not
important since this is the first projection we are creating. In subsequent projections,
the reference point should be a point that has already been projected, so that the
projection can be easily positioned correctly into the existing isometric projection.
For our example, we choose the lower left corner as reference point:
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5. In the toolbar at the top, make sure that the correct projection type is chosen.
Since we are projecting the top view, we choose the icon for the top view:

The second option is the segment length for arcs and circles. Circular entities are
broken up into line segments for the projection. This value indicates the length of these
segments. The smaller the segment length the smoother your drawing will look but at
the cost of making your drawing larger and slower to load and to display.

6. Place the projection into an empty part of your drawing by clicking that position.
For example to the right of the orthogonal projections:

7. We now have an isometric projection of the top view. However, it is still flat since
QCAD does not know the elevation of the individual edges and corners.

8. Select all entities of an orthogonal view that contains height information. This can be
the side or front view.
In our example, we project the front view next:

9. Choose the Isometric Projection tool again and click a reference point. The reference
point should be one of the points that is common between the view and the already
projected view.
We choose the lower left corner of the view which corresponds to the lower or upper
left corner of the top view:
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10. Set the viewing direction to Left:

11. We can now conveniently position the projected front view into the isometric
projection at the right:

12. Finally, we project the side view with viewing direction Side in the same way. We
select the side view:

Choose a suitable reference point:

And project it with viewing direction Right into the isometric projection:

13. This is as far as the projection tool of QCAD supports you. The isometric projection
can now easily be completed by moving and copying individual edges and endpoints
and deleting the invisible edges. Table 22-2 shows the steps how the example can be
completed.
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Table 22-2 Finishing up Isometric Projections
Procedure

1 2

3 4

5 6

7 8

The Scale of Isometric Projections

One of the advantages of isometric projections compared to other three-dimensional projections
is that the scale along all three axes of the Cartesian coordinate system is identical. If a cube
is projected, all edges have the same length in the isometric projection. However, the length in
the projection is not identical to the real length or original length as shown in the orthogonal
projection. The projected lengths in an isometric projection are about 0.81647 times the true
length. The exact scale factor can be calculated as the cosine of 35 degrees and 16 minutes.

Traditionally, isometric projections are often scaled 1:1 because they are easier to produce in
real scale. An isometric projection that is scaled to 100% of the true scale is called an Isometric
Drawing. With QCAD, you can produce an isometric drawing by scaling the isometric projection
with a factor of 1.224779 or 1 / cos(35°16').
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